libva: move PACKAGECONFIG options to libva.inc

Message ID 20211211163521.2647454-1-f_l_k@t-online.de
State Accepted, archived
Commit cb9923f4e62339192c0d8e3d2852f1e71c1963b9
Headers show
Series libva: move PACKAGECONFIG options to libva.inc | expand

Commit Message

Markus Volk Dec. 11, 2021, 4:35 p.m. UTC
This fixes an error in libva-initial build if 'systemd' is in DISTRO_FEATURES
and libdrm is set to be built with udev support.

| Run-time dependency xfixes found: NO (tried pkgconfig and cmake)
| Run-time dependency wayland-client found: YES 1.19.0
| Program wayland-scanner /usr/bin/wayland-scanner found: NO
|
| ../libva-2.13.0/meson.build:107:4: ERROR: Program 'wayland-scanner /usr/bin/wayland-scanner' not found
|
| A full log can be found at /home/flk/build/poky/build-rock/tmp/work/cortexa72-cortexa53-crypto-poky-linux/libva-initial/2.13.0-r0/build/meson-logs/meson-log.txt
| ERROR: meson failed
| WARNING: exit code 1 from a shell command.
---
 meta/recipes-graphics/libva/libva-initial_2.13.0.bb | 3 +++
 meta/recipes-graphics/libva/libva.inc               | 6 ++++++
 meta/recipes-graphics/libva/libva_2.13.0.bb         | 5 -----
 3 files changed, 9 insertions(+), 5 deletions(-)

Patch

diff --git a/meta/recipes-graphics/libva/libva-initial_2.13.0.bb b/meta/recipes-graphics/libva/libva-initial_2.13.0.bb
index 4c3045bc65..453096822f 100644
--- a/meta/recipes-graphics/libva/libva-initial_2.13.0.bb
+++ b/meta/recipes-graphics/libva/libva-initial_2.13.0.bb
@@ -1,5 +1,8 @@ 
 require libva.inc
 
+PACKAGECONFIG ?= ""
+
 do_install:append () {
 	rm -f ${D}${libdir}/*.so*
 }
+
diff --git a/meta/recipes-graphics/libva/libva.inc b/meta/recipes-graphics/libva/libva.inc
index bcf9757c1a..dcdc1f378c 100644
--- a/meta/recipes-graphics/libva/libva.inc
+++ b/meta/recipes-graphics/libva/libva.inc
@@ -27,3 +27,9 @@  UPSTREAM_CHECK_URI = "https://github.com/intel/libva/releases"
 DEPENDS = "libdrm"
 
 inherit meson pkgconfig
+
+PACKAGECONFIG[x11] = "-Dwith_x11=yes,-Dwith_x11=no,virtual/libx11 libxext libxfixes"
+PACKAGECONFIG[glx] = "-Dwith_glx=yes,-Dwith_glx=no,virtual/mesa"
+
+PACKAGECONFIG[wayland] = "-Dwith_wayland=yes,-Dwith_wayland=no,wayland-native wayland"
+
diff --git a/meta/recipes-graphics/libva/libva_2.13.0.bb b/meta/recipes-graphics/libva/libva_2.13.0.bb
index ed2be289fc..63dc5af8f2 100644
--- a/meta/recipes-graphics/libva/libva_2.13.0.bb
+++ b/meta/recipes-graphics/libva/libva_2.13.0.bb
@@ -5,11 +5,6 @@  PACKAGECONFIG ??= " \
     ${@bb.utils.filter('DISTRO_FEATURES', 'x11 wayland', d)} \
 "
 
-PACKAGECONFIG[x11] = "-Dwith_x11=yes,-Dwith_x11=no,virtual/libx11 libxext libxfixes"
-PACKAGECONFIG[glx] = "-Dwith_glx=yes,-Dwith_glx=no,virtual/mesa"
-
-PACKAGECONFIG[wayland] = "-Dwith_wayland=yes,-Dwith_wayland=no,wayland-native wayland"
-
 PACKAGES =+ "${PN}-x11 ${PN}-glx ${PN}-wayland"
 
 RDEPENDS:${PN}-x11 =+ "${PN}"