[RFC,04/10] python3-installer: bootstrap by installing installer with installer

Message ID 20220526171001.4074388-5-ross.burton@arm.com
State New
Headers show
Series Change Python package building to use picobuild | expand

Commit Message

Ross Burton May 26, 2022, 5:09 p.m. UTC
The installer can install itself by simply adding src/ to PYTHONPATH.

As this previously used unzip, we need to disable bytecode as otherwise
the newly packaged .pyc files conflict with the any generated .pyc files
in the sysroot.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta/recipes-devtools/python/python3-installer_0.5.1.bb | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

Patch

diff --git a/meta/recipes-devtools/python/python3-installer_0.5.1.bb b/meta/recipes-devtools/python/python3-installer_0.5.1.bb
index f4f9e1bde64..b7780702d6b 100644
--- a/meta/recipes-devtools/python/python3-installer_0.5.1.bb
+++ b/meta/recipes-devtools/python/python3-installer_0.5.1.bb
@@ -12,11 +12,13 @@  SRC_URI[sha256sum] = "f970995ec2bb815e2fdaf7977b26b2091e1e386f0f42eafd5ac811953d
 
 inherit pypi python_flit_core
 
+# Bootstrap the native install by installing with ourself
 DEPENDS:remove:class-native = "python3-installer-native"
-DEPENDS:append:class-native = " unzip-native"
 
-do_install:class-native () {
-    python_pep517_do_bootstrap_install
+INSTALL_WHEEL_COMPILE_BYTECODE:class-native = "--no-compile-bytecode"
+
+do_install:prepend:class-native() {
+    export PYTHONPATH="${S}/src"
 }
 
 BBCLASSEXTEND = "native nativesdk"