libseccomp: Add missing files for ptests

Message ID 20220525092659.771559-1-lkml@jv-coder.de
State Accepted, archived
Commit 32ba67bc37b5ca73f7d29cb6c7de281ab8f824bd
Headers show
Series libseccomp: Add missing files for ptests | expand

Commit Message

Joerg Vehlow May 25, 2022, 9:26 a.m. UTC
From: Joerg Vehlow <joerg.vehlow@aox.de>

pfc files are used e.g. in 38-basic-pfc_coverage.sh
valgrind_test.supp is required, when valgrind is installed, otherwise
all valgrind tests fail

Signed-off-by: Joerg Vehlow <joerg.vehlow@aox.de>
---
 meta/recipes-support/libseccomp/libseccomp_2.5.4.bb | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Steve Sakoman May 30, 2022, 2:35 p.m. UTC | #1
On Tue, May 24, 2022 at 11:27 PM J?rg Vehlow <lkml@jv-coder.de> wrote:
>
> From: Joerg Vehlow <joerg.vehlow@aox.de>
>
> pfc files are used e.g. in 38-basic-pfc_coverage.sh
> valgrind_test.supp is required, when valgrind is installed, otherwise
> all valgrind tests fail

Is this issue specific to 2.5.4 or does it also apply to the 2.5.3
version in kirkstone?

Thanks!

Steve

> Signed-off-by: Joerg Vehlow <joerg.vehlow@aox.de>
> ---
>  meta/recipes-support/libseccomp/libseccomp_2.5.4.bb | 4 ++++
>  1 file changed, 4 insertions(+)
>
> diff --git a/meta/recipes-support/libseccomp/libseccomp_2.5.4.bb b/meta/recipes-support/libseccomp/libseccomp_2.5.4.bb
> index c76f3c3573..731d9ae08d 100644
> --- a/meta/recipes-support/libseccomp/libseccomp_2.5.4.bb
> +++ b/meta/recipes-support/libseccomp/libseccomp_2.5.4.bb
> @@ -37,6 +37,10 @@ do_install_ptest() {
>      for file in $(find tests/*.tests -type f); do
>          install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests
>      done
> +        for file in $(find tests/*.pfc -type f); do
> +        install -m 644 ${S}/${file} ${D}/${PTEST_PATH}/tests
> +    done
> +    install -m 644 ${S}/tests/valgrind_test.supp ${D}/${PTEST_PATH}/tests
>      for file in $(find tools/* -executable -type f); do
>          install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tools
>      done
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#166108): https://lists.openembedded.org/g/openembedded-core/message/166108
> Mute This Topic: https://lists.openembedded.org/mt/91329522/3620601
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [steve@sakoman.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Joerg Vehlow May 30, 2022, 2:43 p.m. UTC | #2
Hi Steve,

Am 5/30/2022 um 4:35 PM schrieb Steve Sakoman:
> On Tue, May 24, 2022 at 11:27 PM J?rg Vehlow <lkml@jv-coder.de> wrote:
>>
>> From: Joerg Vehlow <joerg.vehlow@aox.de>
>>
>> pfc files are used e.g. in 38-basic-pfc_coverage.sh
>> valgrind_test.supp is required, when valgrind is installed, otherwise
>> all valgrind tests fail
> 
> Is this issue specific to 2.5.4 or does it also apply to the 2.5.3
> version in kirkstone?
I am pretty sure that depending on the configuration (e.g. valgrind
installed or bpf enabled), that these files are required in at least all
2.5 versions.
> 
> Thanks!
> 
> Steve

Joerg
Steve Sakoman May 30, 2022, 3:50 p.m. UTC | #3
On Mon, May 30, 2022 at 4:43 AM J?rg Vehlow <lkml@jv-coder.de> wrote:
>
> Hi Steve,
>
> Am 5/30/2022 um 4:35 PM schrieb Steve Sakoman:
> > On Tue, May 24, 2022 at 11:27 PM J?rg Vehlow <lkml@jv-coder.de> wrote:
> >>
> >> From: Joerg Vehlow <joerg.vehlow@aox.de>
> >>
> >> pfc files are used e.g. in 38-basic-pfc_coverage.sh
> >> valgrind_test.supp is required, when valgrind is installed, otherwise
> >> all valgrind tests fail
> >
> > Is this issue specific to 2.5.4 or does it also apply to the 2.5.3
> > version in kirkstone?
> I am pretty sure that depending on the configuration (e.g. valgrind
> installed or bpf enabled), that these files are required in at least all
> 2.5 versions.

OK, will add this to my test queue.

Thanks!

Steve

Patch

diff --git a/meta/recipes-support/libseccomp/libseccomp_2.5.4.bb b/meta/recipes-support/libseccomp/libseccomp_2.5.4.bb
index c76f3c3573..731d9ae08d 100644
--- a/meta/recipes-support/libseccomp/libseccomp_2.5.4.bb
+++ b/meta/recipes-support/libseccomp/libseccomp_2.5.4.bb
@@ -37,6 +37,10 @@  do_install_ptest() {
     for file in $(find tests/*.tests -type f); do
         install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests
     done
+        for file in $(find tests/*.pfc -type f); do
+        install -m 644 ${S}/${file} ${D}/${PTEST_PATH}/tests
+    done
+    install -m 644 ${S}/tests/valgrind_test.supp ${D}/${PTEST_PATH}/tests
     for file in $(find tools/* -executable -type f); do
         install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tools
     done