[meta-python] python3-traitlets: Upgrade to 5.2.1

Message ID 20220523182203.8969-1-raj.khem@gmail.com
State New
Headers show
Series [meta-python] python3-traitlets: Upgrade to 5.2.1 | expand

Commit Message

Khem Raj May 23, 2022, 6:22 p.m. UTC
Fix build with latest setuptools while here.

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 .../dynamic_description.patch                 | 36 +++++++++++++++++++
 ...ts_5.2.0.bb => python3-traitlets_5.2.1.bb} |  3 +-
 2 files changed, 38 insertions(+), 1 deletion(-)
 create mode 100644 meta-python/recipes-devtools/python/python3-traitlets/dynamic_description.patch
 rename meta-python/recipes-devtools/python/{python3-traitlets_5.2.0.bb => python3-traitlets_5.2.1.bb} (74%)

Comments

Ross Burton May 24, 2022, 10:25 a.m. UTC | #1
I have genuinely no idea how this builds: the recipe says to use setuptools_build_meta but 5.2.1 deletes all the setuptools files and has ported to a new build system called hatchling.

Maybe setuptools_build_meta infers a lot and it sort of works, but this is not the correct fix.  I have a branch locally which is almost complete to add hatchling (and it’s dependencies) so this can be built properly.

Ross

From: openembedded-devel@lists.openembedded.org <openembedded-devel@lists.openembedded.org> on behalf of Khem Raj via lists.openembedded.org <raj.khem=gmail.com@lists.openembedded.org>
Date: Monday, 23 May 2022 at 19:22
To: openembedded-devel@lists.openembedded.org <openembedded-devel@lists.openembedded.org>
Cc: Khem Raj <raj.khem@gmail.com>
Subject: [oe] [meta-python][PATCH] python3-traitlets: Upgrade to 5.2.1
Fix build with latest setuptools while here.

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 .../dynamic_description.patch                 | 36 +++++++++++++++++++
 ...ts_5.2.0.bb => python3-traitlets_5.2.1.bb} |  3 +-
 2 files changed, 38 insertions(+), 1 deletion(-)
 create mode 100644 meta-python/recipes-devtools/python/python3-traitlets/dynamic_description.patch
 rename meta-python/recipes-devtools/python/{python3-traitlets_5.2.0.bb => python3-traitlets_5.2.1.bb} (74%)

diff --git a/meta-python/recipes-devtools/python/python3-traitlets/dynamic_description.patch b/meta-python/recipes-devtools/python/python3-traitlets/dynamic_description.patch
new file mode 100644
index 0000000000..6d8e4b1f50
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-traitlets/dynamic_description.patch
@@ -0,0 +1,36 @@
+New setuptools turns on autodiscovery of modules which ends up in funny errors like
+
+error: Multiple top-level packages discovered in a flat-layout: ['patches', 'traitlets'].
+
+To avoid accidental inclusion of unwanted files or directories,
+setuptools will not proceed with this build.
+
+
+this is becasue patches/ folder is created by quilt. Secondly, define description and version
+statically since new setuptools complain about it.
+
+Upstream-Status: Pending
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -4,6 +4,8 @@ build-backend = "hatchling.build"
+
+ [project]
+ name = "traitlets"
++version = "5.2.1"
++description = "A lightweight Traits like module"
+ authors = [{name = "IPython Development Team", email = "ipython-dev@python.org"}]
+ license = {file = "COPYING.md"}
+ readme = "README.md"
+@@ -18,7 +20,9 @@ classifiers = [
+ ]
+ urls = {Homepage = "https://github.com/ipython/traitlets"}
+ requires-python = ">=3.7"
+-dynamic = ["description", "version"]
++
++[tool.setuptools]
++py-modules = []
+
+ [project.optional-dependencies]
+ test = ["pytest", "pre-commit"]
diff --git a/meta-python/recipes-devtools/python/python3-traitlets_5.2.0.bb b/meta-python/recipes-devtools/python/python3-traitlets_5.2.1.bb
similarity index 74%
rename from meta-python/recipes-devtools/python/python3-traitlets_5.2.0.bb
rename to meta-python/recipes-devtools/python/python3-traitlets_5.2.1.bb
index 56ebaac675..588bddbd74 100644
--- a/meta-python/recipes-devtools/python/python3-traitlets_5.2.0.bb
+++ b/meta-python/recipes-devtools/python/python3-traitlets_5.2.1.bb
@@ -6,7 +6,8 @@ LIC_FILES_CHKSUM = "file://COPYING.md;md5=9c125dfc5ff5364d40b5f56f02cd9de3<file:///COPYING.md;md5=9c125dfc5ff5364d40b5f56f02cd9de3>"

 PYPI_PACKAGE = "traitlets"

-SRC_URI[sha256sum] = "60474f39bf1d39a11e0233090b99af3acee93bbc2281777e61dd8c87da8a0014"
+SRC_URI += "file://dynamic_description.patch<file:///dynamic_description.patch>"
+SRC_URI[sha256sum] = "a415578cde1985f1b773faefe49e9f078d345f38665ce3e9e914ec7b41150ce9"

 RDEPENDS:${PN} = "\
     ${PYTHON_PN}-ipython-genutils \
--
2.36.1
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.
Khem Raj May 24, 2022, 3:14 p.m. UTC | #2
On Tue, May 24, 2022 at 3:25 AM Ross Burton <Ross.Burton@arm.com> wrote:
>
> I have genuinely no idea how this builds: the recipe says to use setuptools_build_meta but 5.2.1 deletes all the setuptools files and has ported to a new build system called hatchling.
>
>
>
> Maybe setuptools_build_meta infers a lot and it sort of works, but this is not the correct fix.  I have a branch locally which is almost complete to add hatchling (and it’s dependencies) so this can be built properly.
>

yeah hatching would be an improvement for sure. I was just trying to
bring it back to where it was. I will wait for your fix

>
>
> Ross
>
>
>
> From: openembedded-devel@lists.openembedded.org <openembedded-devel@lists.openembedded.org> on behalf of Khem Raj via lists.openembedded.org <raj.khem=gmail.com@lists.openembedded.org>
> Date: Monday, 23 May 2022 at 19:22
> To: openembedded-devel@lists.openembedded.org <openembedded-devel@lists.openembedded.org>
> Cc: Khem Raj <raj.khem@gmail.com>
> Subject: [oe] [meta-python][PATCH] python3-traitlets: Upgrade to 5.2.1
>
> Fix build with latest setuptools while here.
>
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> ---
>  .../dynamic_description.patch                 | 36 +++++++++++++++++++
>  ...ts_5.2.0.bb => python3-traitlets_5.2.1.bb} |  3 +-
>  2 files changed, 38 insertions(+), 1 deletion(-)
>  create mode 100644 meta-python/recipes-devtools/python/python3-traitlets/dynamic_description.patch
>  rename meta-python/recipes-devtools/python/{python3-traitlets_5.2.0.bb => python3-traitlets_5.2.1.bb} (74%)
>
> diff --git a/meta-python/recipes-devtools/python/python3-traitlets/dynamic_description.patch b/meta-python/recipes-devtools/python/python3-traitlets/dynamic_description.patch
> new file mode 100644
> index 0000000000..6d8e4b1f50
> --- /dev/null
> +++ b/meta-python/recipes-devtools/python/python3-traitlets/dynamic_description.patch
> @@ -0,0 +1,36 @@
> +New setuptools turns on autodiscovery of modules which ends up in funny errors like
> +
> +error: Multiple top-level packages discovered in a flat-layout: ['patches', 'traitlets'].
> +
> +To avoid accidental inclusion of unwanted files or directories,
> +setuptools will not proceed with this build.
> +
> +
> +this is becasue patches/ folder is created by quilt. Secondly, define description and version
> +statically since new setuptools complain about it.
> +
> +Upstream-Status: Pending
> +
> +Signed-off-by: Khem Raj <raj.khem@gmail.com>
> +--- a/pyproject.toml
> ++++ b/pyproject.toml
> +@@ -4,6 +4,8 @@ build-backend = "hatchling.build"
> +
> + [project]
> + name = "traitlets"
> ++version = "5.2.1"
> ++description = "A lightweight Traits like module"
> + authors = [{name = "IPython Development Team", email = "ipython-dev@python.org"}]
> + license = {file = "COPYING.md"}
> + readme = "README.md"
> +@@ -18,7 +20,9 @@ classifiers = [
> + ]
> + urls = {Homepage = "https://github.com/ipython/traitlets"}
> + requires-python = ">=3.7"
> +-dynamic = ["description", "version"]
> ++
> ++[tool.setuptools]
> ++py-modules = []
> +
> + [project.optional-dependencies]
> + test = ["pytest", "pre-commit"]
> diff --git a/meta-python/recipes-devtools/python/python3-traitlets_5.2.0.bb b/meta-python/recipes-devtools/python/python3-traitlets_5.2.1.bb
> similarity index 74%
> rename from meta-python/recipes-devtools/python/python3-traitlets_5.2.0.bb
> rename to meta-python/recipes-devtools/python/python3-traitlets_5.2.1.bb
> index 56ebaac675..588bddbd74 100644
> --- a/meta-python/recipes-devtools/python/python3-traitlets_5.2.0.bb
> +++ b/meta-python/recipes-devtools/python/python3-traitlets_5.2.1.bb
> @@ -6,7 +6,8 @@ LIC_FILES_CHKSUM = "file://COPYING.md;md5=9c125dfc5ff5364d40b5f56f02cd9de3"
>
>  PYPI_PACKAGE = "traitlets"
>
> -SRC_URI[sha256sum] = "60474f39bf1d39a11e0233090b99af3acee93bbc2281777e61dd8c87da8a0014"
> +SRC_URI += "file://dynamic_description.patch"
> +SRC_URI[sha256sum] = "a415578cde1985f1b773faefe49e9f078d345f38665ce3e9e914ec7b41150ce9"
>
>  RDEPENDS:${PN} = "\
>      ${PYTHON_PN}-ipython-genutils \
> --
> 2.36.1
>
> IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

Patch

diff --git a/meta-python/recipes-devtools/python/python3-traitlets/dynamic_description.patch b/meta-python/recipes-devtools/python/python3-traitlets/dynamic_description.patch
new file mode 100644
index 0000000000..6d8e4b1f50
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-traitlets/dynamic_description.patch
@@ -0,0 +1,36 @@ 
+New setuptools turns on autodiscovery of modules which ends up in funny errors like
+
+error: Multiple top-level packages discovered in a flat-layout: ['patches', 'traitlets'].
+
+To avoid accidental inclusion of unwanted files or directories,
+setuptools will not proceed with this build.
+
+
+this is becasue patches/ folder is created by quilt. Secondly, define description and version
+statically since new setuptools complain about it.
+
+Upstream-Status: Pending
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -4,6 +4,8 @@ build-backend = "hatchling.build"
+ 
+ [project]
+ name = "traitlets"
++version = "5.2.1"
++description = "A lightweight Traits like module"
+ authors = [{name = "IPython Development Team", email = "ipython-dev@python.org"}]
+ license = {file = "COPYING.md"}
+ readme = "README.md"
+@@ -18,7 +20,9 @@ classifiers = [
+ ]
+ urls = {Homepage = "https://github.com/ipython/traitlets"}
+ requires-python = ">=3.7"
+-dynamic = ["description", "version"]
++
++[tool.setuptools]
++py-modules = []
+ 
+ [project.optional-dependencies]
+ test = ["pytest", "pre-commit"]
diff --git a/meta-python/recipes-devtools/python/python3-traitlets_5.2.0.bb b/meta-python/recipes-devtools/python/python3-traitlets_5.2.1.bb
similarity index 74%
rename from meta-python/recipes-devtools/python/python3-traitlets_5.2.0.bb
rename to meta-python/recipes-devtools/python/python3-traitlets_5.2.1.bb
index 56ebaac675..588bddbd74 100644
--- a/meta-python/recipes-devtools/python/python3-traitlets_5.2.0.bb
+++ b/meta-python/recipes-devtools/python/python3-traitlets_5.2.1.bb
@@ -6,7 +6,8 @@  LIC_FILES_CHKSUM = "file://COPYING.md;md5=9c125dfc5ff5364d40b5f56f02cd9de3"
 
 PYPI_PACKAGE = "traitlets"
 
-SRC_URI[sha256sum] = "60474f39bf1d39a11e0233090b99af3acee93bbc2281777e61dd8c87da8a0014"
+SRC_URI += "file://dynamic_description.patch"
+SRC_URI[sha256sum] = "a415578cde1985f1b773faefe49e9f078d345f38665ce3e9e914ec7b41150ce9"
 
 RDEPENDS:${PN} = "\
     ${PYTHON_PN}-ipython-genutils \