[v2] lttng-modules: fix build against 5.18-rc7+

Message ID 20220520004609.21335-1-bruce.ashfield@gmail.com
State Accepted, archived
Commit fb69e5cfb043a15354beb2d613772aa0233d12ae
Headers show
Series [v2] lttng-modules: fix build against 5.18-rc7+ | expand

Commit Message

Bruce Ashfield May 20, 2022, 12:46 a.m. UTC
From: Bruce Ashfield <bruce.ashfield@gmail.com>

lttng-modules fails to build against 5.18-rc7, the details of the fix
are as follows:

   The commit [fix: sched/tracing: Don't re-read p->state when emitting
   sched_switch event (v5.18)] was correct, but the kernel changed their
   mind with the following commit:

      commit 9c2136be0878c88c53dea26943ce40bb03ad8d8d
      Author: Delyan Kratunov <delyank@fb.com>
      Date:   Wed May 11 18:28:36 2022 +0000

          sched/tracing: Append prev_state to tp args instead

          Commit fa2c3254d7cf (sched/tracing: Don't re-read p->state when emitting
          sched_switch event, 2022-01-20) added a new prev_state argument to the
          sched_switch tracepoint, before the prev task_struct pointer.

          This reordering of arguments broke BPF programs that use the raw
          tracepoint (e.g. tp_btf programs). The type of the second argument has
          changed and existing programs that assume a task_struct* argument
          (e.g. for bpf_task_storage access) will now fail to verify.

          If we instead append the new argument to the end, all existing programs
          would continue to work and can conditionally extract the prev_state
          argument on supported kernel versions.

          Fixes: fa2c3254d7cf (sched/tracing: Don't re-read p->state when emitting sched_switch event, 2022-01-20)
          Signed-off-by: Delyan Kratunov <delyank@fb.com>
          Signed-off-by: Peter Zijlstra (Intel) <peterz@infradead.org>
          Acked-by: Steven Rostedt (Google) <rostedt@goodmis.org>
          Link: https://lkml.kernel.org/r/c8a6930dfdd58a4a5755fc01732675472979732b.camel@fb.com

   By reordering the parameters (again) we can get back up and building.

Upstream-Status: Backport

Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
---

v2: upstream merged their fix for 5.18-rc7+, so I've updated with that
fix and spun v2.

Bruce


 ...g-Append-prev_state-to-tp-args-inste.patch | 59 +++++++++++++++++++
 .../lttng/lttng-modules_2.13.3.bb             |  1 +
 2 files changed, 60 insertions(+)
 create mode 100644 meta/recipes-kernel/lttng/lttng-modules/0001-fix-sched-tracing-Append-prev_state-to-tp-args-inste.patch

Patch

diff --git a/meta/recipes-kernel/lttng/lttng-modules/0001-fix-sched-tracing-Append-prev_state-to-tp-args-inste.patch b/meta/recipes-kernel/lttng/lttng-modules/0001-fix-sched-tracing-Append-prev_state-to-tp-args-inste.patch
new file mode 100644
index 0000000000..b41053b6bc
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-modules/0001-fix-sched-tracing-Append-prev_state-to-tp-args-inste.patch
@@ -0,0 +1,59 @@ 
+From 9c5b8de32b5745f3ff31079c02da64595e101bee Mon Sep 17 00:00:00 2001
+From: Michael Jeanson <mjeanson@efficios.com>
+Date: Tue, 17 May 2022 11:46:29 -0400
+Subject: [PATCH] fix: sched/tracing: Append prev_state to tp args instead
+ (v5.18)
+
+See upstream commit :
+
+  commit 9c2136be0878c88c53dea26943ce40bb03ad8d8d
+  Author: Delyan Kratunov <delyank@fb.com>
+  Date:   Wed May 11 18:28:36 2022 +0000
+
+    sched/tracing: Append prev_state to tp args instead
+
+    Commit fa2c3254d7cf (sched/tracing: Don't re-read p->state when emitting
+    sched_switch event, 2022-01-20) added a new prev_state argument to the
+    sched_switch tracepoint, before the prev task_struct pointer.
+
+    This reordering of arguments broke BPF programs that use the raw
+    tracepoint (e.g. tp_btf programs). The type of the second argument has
+    changed and existing programs that assume a task_struct* argument
+    (e.g. for bpf_task_storage access) will now fail to verify.
+
+    If we instead append the new argument to the end, all existing programs
+    would continue to work and can conditionally extract the prev_state
+    argument on supported kernel versions.
+
+
+Upstream-Status: Backport
+
+Change-Id: Ife2ec88a8bea2743562590cbd357068d7773863f
+Signed-off-by: Michael Jeanson <mjeanson@efficios.com>
+Signed-off-by: Mathieu Desnoyers <mathieu.desnoyers@efficios.com>
+---
+ include/instrumentation/events/sched.h | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/include/instrumentation/events/sched.h b/include/instrumentation/events/sched.h
+index 339bec94..c1c3df15 100644
+--- a/include/instrumentation/events/sched.h
++++ b/include/instrumentation/events/sched.h
+@@ -356,11 +356,11 @@ LTTNG_TRACEPOINT_EVENT_INSTANCE(sched_wakeup_template, sched_wakeup_new,
+ LTTNG_TRACEPOINT_EVENT(sched_switch,
+ 
+ 	TP_PROTO(bool preempt,
+-		unsigned int prev_state,
+ 		struct task_struct *prev,
+-		struct task_struct *next),
++		struct task_struct *next,
++		unsigned int prev_state),
+ 
+-	TP_ARGS(preempt, prev_state, prev, next),
++	TP_ARGS(preempt, prev, next, prev_state),
+ 
+ 	TP_FIELDS(
+ 		ctf_array_text(char, prev_comm,	prev->comm, TASK_COMM_LEN)
+-- 
+2.19.1
+
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.13.3.bb b/meta/recipes-kernel/lttng/lttng-modules_2.13.3.bb
index 2b00534e53..a5e6b906d2 100644
--- a/meta/recipes-kernel/lttng/lttng-modules_2.13.3.bb
+++ b/meta/recipes-kernel/lttng/lttng-modules_2.13.3.bb
@@ -20,6 +20,7 @@  SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \
            file://0008-fix-scsi-core-Remove-scsi-scsi_request.h-v5.18.patch \
            file://0009-Rename-genhd-wrapper-to-blkdev.patch \
            file://0010-fix-mm-compaction-cleanup-the-compaction-trace-event.patch \
+           file://0001-fix-sched-tracing-Append-prev_state-to-tp-args-inste.patch \
           "
 
 # Use :append here so that the patch is applied also when using devupstream