[5/5] lttng-modules: fix build against 5.18-rc7+

Message ID b982f36796617300aa27c3868fb911879de615c0.1652973084.git.bruce.ashfield@gmail.com
State Accepted, archived
Commit fb69e5cfb043a15354beb2d613772aa0233d12ae
Headers show
Series [1/5] linux-yocto/5.15: update to v5.15.37 | expand

Commit Message

Bruce Ashfield May 19, 2022, 3:15 p.m. UTC
From: Bruce Ashfield <bruce.ashfield@gmail.com>

lttng-modules fails to build against 5.18-rc7, the details of the fix
are as follows:

   The commit [fix: sched/tracing: Don't re-read p->state when emitting
   sched_switch event (v5.18)] was correct, but the kernel changed their
   mind with the following commit:

      commit 9c2136be0878c88c53dea26943ce40bb03ad8d8d
      Author: Delyan Kratunov <delyank@fb.com>
      Date:   Wed May 11 18:28:36 2022 +0000

          sched/tracing: Append prev_state to tp args instead

          Commit fa2c3254d7cf (sched/tracing: Don't re-read p->state when emitting
          sched_switch event, 2022-01-20) added a new prev_state argument to the
          sched_switch tracepoint, before the prev task_struct pointer.

          This reordering of arguments broke BPF programs that use the raw
          tracepoint (e.g. tp_btf programs). The type of the second argument has
          changed and existing programs that assume a task_struct* argument
          (e.g. for bpf_task_storage access) will now fail to verify.

          If we instead append the new argument to the end, all existing programs
          would continue to work and can conditionally extract the prev_state
          argument on supported kernel versions.

          Fixes: fa2c3254d7cf (sched/tracing: Don't re-read p->state when emitting sched_switch event, 2022-01-20)
          Signed-off-by: Delyan Kratunov <delyank@fb.com>
          Signed-off-by: Peter Zijlstra (Intel) <peterz@infradead.org>
          Acked-by: Steven Rostedt (Google) <rostedt@goodmis.org>
          Link: https://lkml.kernel.org/r/c8a6930dfdd58a4a5755fc01732675472979732b.camel@fb.com

   By reordering the parameters (again) we can get back up and building.

Upstream-Status: Submitted [https://lists.lttng.org/pipermail/lttng-dev/2022-May/030185.html]
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
---
 ...x-__trace_sched_switch_state-5.18-rc.patch | 88 +++++++++++++++++++
 .../lttng/lttng-modules_2.13.3.bb             |  1 +
 2 files changed, 89 insertions(+)
 create mode 100644 meta/recipes-kernel/lttng/lttng-modules/0001-sched-tracing-fix-__trace_sched_switch_state-5.18-rc.patch

Comments

Bruce Ashfield May 19, 2022, 4:03 p.m. UTC | #1
On Thu, May 19, 2022 at 11:15 AM <bruce.ashfield@gmail.com> wrote:
>
> From: Bruce Ashfield <bruce.ashfield@gmail.com>
>
> lttng-modules fails to build against 5.18-rc7, the details of the fix
> are as follows:
>
>    The commit [fix: sched/tracing: Don't re-read p->state when emitting
>    sched_switch event (v5.18)] was correct, but the kernel changed their
>    mind with the following commit:
>
>       commit 9c2136be0878c88c53dea26943ce40bb03ad8d8d
>       Author: Delyan Kratunov <delyank@fb.com>
>       Date:   Wed May 11 18:28:36 2022 +0000
>
>           sched/tracing: Append prev_state to tp args instead
>
>           Commit fa2c3254d7cf (sched/tracing: Don't re-read p->state when emitting
>           sched_switch event, 2022-01-20) added a new prev_state argument to the
>           sched_switch tracepoint, before the prev task_struct pointer.
>
>           This reordering of arguments broke BPF programs that use the raw
>           tracepoint (e.g. tp_btf programs). The type of the second argument has
>           changed and existing programs that assume a task_struct* argument
>           (e.g. for bpf_task_storage access) will now fail to verify.
>
>           If we instead append the new argument to the end, all existing programs
>           would continue to work and can conditionally extract the prev_state
>           argument on supported kernel versions.
>
>           Fixes: fa2c3254d7cf (sched/tracing: Don't re-read p->state when emitting sched_switch event, 2022-01-20)
>           Signed-off-by: Delyan Kratunov <delyank@fb.com>
>           Signed-off-by: Peter Zijlstra (Intel) <peterz@infradead.org>
>           Acked-by: Steven Rostedt (Google) <rostedt@goodmis.org>
>           Link: https://lkml.kernel.org/r/c8a6930dfdd58a4a5755fc01732675472979732b.camel@fb.com
>
>    By reordering the parameters (again) we can get back up and building.
>
> Upstream-Status: Submitted [https://lists.lttng.org/pipermail/lttng-dev/2022-May/030185.html]

Upstream has a fix in flight as well, that should merge today.

We can hold on this patch, and I'll update it tomorrow (or as soon as)
the patch lands in lttng-modules.

Bruce

> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
> ---
>  ...x-__trace_sched_switch_state-5.18-rc.patch | 88 +++++++++++++++++++
>  .../lttng/lttng-modules_2.13.3.bb             |  1 +
>  2 files changed, 89 insertions(+)
>  create mode 100644 meta/recipes-kernel/lttng/lttng-modules/0001-sched-tracing-fix-__trace_sched_switch_state-5.18-rc.patch
>
> diff --git a/meta/recipes-kernel/lttng/lttng-modules/0001-sched-tracing-fix-__trace_sched_switch_state-5.18-rc.patch b/meta/recipes-kernel/lttng/lttng-modules/0001-sched-tracing-fix-__trace_sched_switch_state-5.18-rc.patch
> new file mode 100644
> index 0000000000..1f6e8a3c34
> --- /dev/null
> +++ b/meta/recipes-kernel/lttng/lttng-modules/0001-sched-tracing-fix-__trace_sched_switch_state-5.18-rc.patch
> @@ -0,0 +1,88 @@
> +From fbcc510cab67b918a6103c3b1903b1b69f28d399 Mon Sep 17 00:00:00 2001
> +From: Bruce Ashfield <bruce.ashfield@gmail.com>
> +Date: Thu, 19 May 2022 10:46:19 -0400
> +Subject: [PATCH] sched/tracing: fix __trace_sched_switch_state (5.18-rc7+)
> +
> +The commit [fix: sched/tracing: Don't re-read p->state when emitting
> +sched_switch event (v5.18)] was correct, but the kernel changed their
> +mind with the following commit:
> +
> +   commit 9c2136be0878c88c53dea26943ce40bb03ad8d8d
> +   Author: Delyan Kratunov <delyank@fb.com>
> +   Date:   Wed May 11 18:28:36 2022 +0000
> +
> +       sched/tracing: Append prev_state to tp args instead
> +
> +       Commit fa2c3254d7cf (sched/tracing: Don't re-read p->state when emitting
> +       sched_switch event, 2022-01-20) added a new prev_state argument to the
> +       sched_switch tracepoint, before the prev task_struct pointer.
> +
> +       This reordering of arguments broke BPF programs that use the raw
> +       tracepoint (e.g. tp_btf programs). The type of the second argument has
> +       changed and existing programs that assume a task_struct* argument
> +       (e.g. for bpf_task_storage access) will now fail to verify.
> +
> +       If we instead append the new argument to the end, all existing programs
> +       would continue to work and can conditionally extract the prev_state
> +       argument on supported kernel versions.
> +
> +       Fixes: fa2c3254d7cf (sched/tracing: Don't re-read p->state when emitting sched_switch event, 2022-01-20)
> +       Signed-off-by: Delyan Kratunov <delyank@fb.com>
> +       Signed-off-by: Peter Zijlstra (Intel) <peterz@infradead.org>
> +       Acked-by: Steven Rostedt (Google) <rostedt@goodmis.org>
> +       Link: https://lkml.kernel.org/r/c8a6930dfdd58a4a5755fc01732675472979732b.camel@fb.com
> +
> +By reordering the parameters (again) we can get back up and building.
> +
> +Upstream-Status: Submitted [https://lists.lttng.org/pipermail/lttng-dev/2022-May/030185.html]
> +
> +Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
> +---
> + include/instrumentation/events/sched.h | 15 ++++++++-------
> + 1 file changed, 8 insertions(+), 7 deletions(-)
> +
> +diff --git a/include/instrumentation/events/sched.h b/include/instrumentation/events/sched.h
> +index 339bec9..f9e9c38 100644
> +--- a/include/instrumentation/events/sched.h
> ++++ b/include/instrumentation/events/sched.h
> +@@ -23,8 +23,9 @@
> + #if (LTTNG_LINUX_VERSION_CODE >= LTTNG_KERNEL_VERSION(5,18,0))
> +
> + static inline long __trace_sched_switch_state(bool preempt,
> +-              unsigned int prev_state,
> +-              struct task_struct *p)
> ++              struct task_struct *p,
> ++              struct task_struct *n,
> ++              unsigned int prev_state )
> + {
> +         unsigned int state;
> +
> +@@ -356,20 +357,20 @@ LTTNG_TRACEPOINT_EVENT_INSTANCE(sched_wakeup_template, sched_wakeup_new,
> + LTTNG_TRACEPOINT_EVENT(sched_switch,
> +
> +       TP_PROTO(bool preempt,
> +-              unsigned int prev_state,
> +               struct task_struct *prev,
> +-              struct task_struct *next),
> ++              struct task_struct *next,
> ++              unsigned int prev_state),
> +
> +-      TP_ARGS(preempt, prev_state, prev, next),
> ++      TP_ARGS(preempt, prev, next, prev_state),
> +
> +       TP_FIELDS(
> +               ctf_array_text(char, prev_comm, prev->comm, TASK_COMM_LEN)
> +               ctf_integer(pid_t, prev_tid, prev->pid)
> +               ctf_integer(int, prev_prio, prev->prio - MAX_RT_PRIO)
> + #ifdef CONFIG_LTTNG_EXPERIMENTAL_BITWISE_ENUM
> +-              ctf_enum(task_state, long, prev_state, __trace_sched_switch_state(preempt, prev_state, prev))
> ++              ctf_enum(task_state, long, prev_state, __trace_sched_switch_state(preempt, prev, next, prev_state))
> + #else
> +-              ctf_integer(long, prev_state, __trace_sched_switch_state(preempt, prev_state, prev))
> ++              ctf_integer(long, prev_state, __trace_sched_switch_state(preempt, prev, next, prev_state))
> + #endif
> +               ctf_array_text(char, next_comm, next->comm, TASK_COMM_LEN)
> +               ctf_integer(pid_t, next_tid, next->pid)
> +--
> +2.19.1
> +
> diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.13.3.bb b/meta/recipes-kernel/lttng/lttng-modules_2.13.3.bb
> index 2b00534e53..96b6491a4b 100644
> --- a/meta/recipes-kernel/lttng/lttng-modules_2.13.3.bb
> +++ b/meta/recipes-kernel/lttng/lttng-modules_2.13.3.bb
> @@ -20,6 +20,7 @@ SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \
>             file://0008-fix-scsi-core-Remove-scsi-scsi_request.h-v5.18.patch \
>             file://0009-Rename-genhd-wrapper-to-blkdev.patch \
>             file://0010-fix-mm-compaction-cleanup-the-compaction-trace-event.patch \
> +           file://0001-sched-tracing-fix-__trace_sched_switch_state-5.18-rc.patch \
>            "
>
>  # Use :append here so that the patch is applied also when using devupstream
> --
> 2.19.1
>

Patch

diff --git a/meta/recipes-kernel/lttng/lttng-modules/0001-sched-tracing-fix-__trace_sched_switch_state-5.18-rc.patch b/meta/recipes-kernel/lttng/lttng-modules/0001-sched-tracing-fix-__trace_sched_switch_state-5.18-rc.patch
new file mode 100644
index 0000000000..1f6e8a3c34
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-modules/0001-sched-tracing-fix-__trace_sched_switch_state-5.18-rc.patch
@@ -0,0 +1,88 @@ 
+From fbcc510cab67b918a6103c3b1903b1b69f28d399 Mon Sep 17 00:00:00 2001
+From: Bruce Ashfield <bruce.ashfield@gmail.com>
+Date: Thu, 19 May 2022 10:46:19 -0400
+Subject: [PATCH] sched/tracing: fix __trace_sched_switch_state (5.18-rc7+)
+
+The commit [fix: sched/tracing: Don't re-read p->state when emitting
+sched_switch event (v5.18)] was correct, but the kernel changed their
+mind with the following commit:
+
+   commit 9c2136be0878c88c53dea26943ce40bb03ad8d8d
+   Author: Delyan Kratunov <delyank@fb.com>
+   Date:   Wed May 11 18:28:36 2022 +0000
+
+       sched/tracing: Append prev_state to tp args instead
+
+       Commit fa2c3254d7cf (sched/tracing: Don't re-read p->state when emitting
+       sched_switch event, 2022-01-20) added a new prev_state argument to the
+       sched_switch tracepoint, before the prev task_struct pointer.
+
+       This reordering of arguments broke BPF programs that use the raw
+       tracepoint (e.g. tp_btf programs). The type of the second argument has
+       changed and existing programs that assume a task_struct* argument
+       (e.g. for bpf_task_storage access) will now fail to verify.
+
+       If we instead append the new argument to the end, all existing programs
+       would continue to work and can conditionally extract the prev_state
+       argument on supported kernel versions.
+
+       Fixes: fa2c3254d7cf (sched/tracing: Don't re-read p->state when emitting sched_switch event, 2022-01-20)
+       Signed-off-by: Delyan Kratunov <delyank@fb.com>
+       Signed-off-by: Peter Zijlstra (Intel) <peterz@infradead.org>
+       Acked-by: Steven Rostedt (Google) <rostedt@goodmis.org>
+       Link: https://lkml.kernel.org/r/c8a6930dfdd58a4a5755fc01732675472979732b.camel@fb.com
+
+By reordering the parameters (again) we can get back up and building.
+
+Upstream-Status: Submitted [https://lists.lttng.org/pipermail/lttng-dev/2022-May/030185.html]
+
+Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
+---
+ include/instrumentation/events/sched.h | 15 ++++++++-------
+ 1 file changed, 8 insertions(+), 7 deletions(-)
+
+diff --git a/include/instrumentation/events/sched.h b/include/instrumentation/events/sched.h
+index 339bec9..f9e9c38 100644
+--- a/include/instrumentation/events/sched.h
++++ b/include/instrumentation/events/sched.h
+@@ -23,8 +23,9 @@
+ #if (LTTNG_LINUX_VERSION_CODE >= LTTNG_KERNEL_VERSION(5,18,0))
+ 
+ static inline long __trace_sched_switch_state(bool preempt,
+-		unsigned int prev_state,
+-		struct task_struct *p)
++		struct task_struct *p,
++		struct task_struct *n,
++		unsigned int prev_state )
+ {
+         unsigned int state;
+ 
+@@ -356,20 +357,20 @@ LTTNG_TRACEPOINT_EVENT_INSTANCE(sched_wakeup_template, sched_wakeup_new,
+ LTTNG_TRACEPOINT_EVENT(sched_switch,
+ 
+ 	TP_PROTO(bool preempt,
+-		unsigned int prev_state,
+ 		struct task_struct *prev,
+-		struct task_struct *next),
++		struct task_struct *next,
++		unsigned int prev_state),
+ 
+-	TP_ARGS(preempt, prev_state, prev, next),
++	TP_ARGS(preempt, prev, next, prev_state),
+ 
+ 	TP_FIELDS(
+ 		ctf_array_text(char, prev_comm,	prev->comm, TASK_COMM_LEN)
+ 		ctf_integer(pid_t, prev_tid, prev->pid)
+ 		ctf_integer(int, prev_prio, prev->prio - MAX_RT_PRIO)
+ #ifdef CONFIG_LTTNG_EXPERIMENTAL_BITWISE_ENUM
+-		ctf_enum(task_state, long, prev_state, __trace_sched_switch_state(preempt, prev_state, prev))
++		ctf_enum(task_state, long, prev_state, __trace_sched_switch_state(preempt, prev, next, prev_state))
+ #else
+-		ctf_integer(long, prev_state, __trace_sched_switch_state(preempt, prev_state, prev))
++		ctf_integer(long, prev_state, __trace_sched_switch_state(preempt, prev, next, prev_state))
+ #endif
+ 		ctf_array_text(char, next_comm, next->comm, TASK_COMM_LEN)
+ 		ctf_integer(pid_t, next_tid, next->pid)
+-- 
+2.19.1
+
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.13.3.bb b/meta/recipes-kernel/lttng/lttng-modules_2.13.3.bb
index 2b00534e53..96b6491a4b 100644
--- a/meta/recipes-kernel/lttng/lttng-modules_2.13.3.bb
+++ b/meta/recipes-kernel/lttng/lttng-modules_2.13.3.bb
@@ -20,6 +20,7 @@  SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \
            file://0008-fix-scsi-core-Remove-scsi-scsi_request.h-v5.18.patch \
            file://0009-Rename-genhd-wrapper-to-blkdev.patch \
            file://0010-fix-mm-compaction-cleanup-the-compaction-trace-event.patch \
+           file://0001-sched-tracing-fix-__trace_sched_switch_state-5.18-rc.patch \
           "
 
 # Use :append here so that the patch is applied also when using devupstream