[meta-python,1/2] python3-speedtest-cli: fix RDEPENDS

Message ID 20220519131827.166725-1-brgl@bgdev.pl
State New
Headers show
Series [meta-python,1/2] python3-speedtest-cli: fix RDEPENDS | expand

Commit Message

Bartosz Golaszewski May 19, 2022, 1:18 p.m. UTC
There are packages missing in RDEPENDS needed to run speedtest-cli. Add
them and use += for the assignment as we don't know what inherited
classes may have added.

Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl>
---
 .../recipes-devtools/python/python3-speedtest-cli_2.1.3.bb  | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

Comments

Bartosz Golaszewski May 24, 2022, 2:49 p.m. UTC | #1
On Thu, May 19, 2022 at 3:18 PM Bartosz Golaszewski <brgl@bgdev.pl> wrote:
>
> There are packages missing in RDEPENDS needed to run speedtest-cli. Add
> them and use += for the assignment as we don't know what inherited
> classes may have added.
>
> Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl>
> ---
>  .../recipes-devtools/python/python3-speedtest-cli_2.1.3.bb  | 6 +++++-
>  1 file changed, 5 insertions(+), 1 deletion(-)
>
> diff --git a/meta-python/recipes-devtools/python/python3-speedtest-cli_2.1.3.bb b/meta-python/recipes-devtools/python/python3-speedtest-cli_2.1.3.bb
> index 06d98cbe1..472113b05 100644
> --- a/meta-python/recipes-devtools/python/python3-speedtest-cli_2.1.3.bb
> +++ b/meta-python/recipes-devtools/python/python3-speedtest-cli_2.1.3.bb
> @@ -7,4 +7,8 @@ SRC_URI[sha256sum] = "5e2773233cedb5fa3d8120eb7f97bcc4974b5221b254d33ff16e2f1d41
>
>  inherit pypi setuptools3
>
> -RDEPENDS:${PN} = "${PYTHON_PN}-misc"
> +RDEPENDS:${PN} += " \
> +    python3-misc \
> +    python3-threading \
> +    python3-xml \
> +"
> --
> 2.34.1
>

Hi!

This has been in master-next for days but didn't get into master
proper. Just a gentle ping.

Bart
Khem Raj May 24, 2022, 3:31 p.m. UTC | #2
On Tue, May 24, 2022 at 7:49 AM Bartosz Golaszewski <brgl@bgdev.pl> wrote:
>
> On Thu, May 19, 2022 at 3:18 PM Bartosz Golaszewski <brgl@bgdev.pl> wrote:
> >
> > There are packages missing in RDEPENDS needed to run speedtest-cli. Add
> > them and use += for the assignment as we don't know what inherited
> > classes may have added.
> >
> > Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl>
> > ---
> >  .../recipes-devtools/python/python3-speedtest-cli_2.1.3.bb  | 6 +++++-
> >  1 file changed, 5 insertions(+), 1 deletion(-)
> >
> > diff --git a/meta-python/recipes-devtools/python/python3-speedtest-cli_2.1.3.bb b/meta-python/recipes-devtools/python/python3-speedtest-cli_2.1.3.bb
> > index 06d98cbe1..472113b05 100644
> > --- a/meta-python/recipes-devtools/python/python3-speedtest-cli_2.1.3.bb
> > +++ b/meta-python/recipes-devtools/python/python3-speedtest-cli_2.1.3.bb
> > @@ -7,4 +7,8 @@ SRC_URI[sha256sum] = "5e2773233cedb5fa3d8120eb7f97bcc4974b5221b254d33ff16e2f1d41
> >
> >  inherit pypi setuptools3
> >
> > -RDEPENDS:${PN} = "${PYTHON_PN}-misc"
> > +RDEPENDS:${PN} += " \
> > +    python3-misc \
> > +    python3-threading \
> > +    python3-xml \
> > +"
> > --
> > 2.34.1
> >
>
> Hi!
>
> This has been in master-next for days but didn't get into master
> proper. Just a gentle ping.

Thanks for reminder, if you have not heard on it causing issues then
It will be in master in due course soon. Sometimes its other recipes being
sorted with current master etc. that delays merges

>
> Bart

Patch

diff --git a/meta-python/recipes-devtools/python/python3-speedtest-cli_2.1.3.bb b/meta-python/recipes-devtools/python/python3-speedtest-cli_2.1.3.bb
index 06d98cbe1..472113b05 100644
--- a/meta-python/recipes-devtools/python/python3-speedtest-cli_2.1.3.bb
+++ b/meta-python/recipes-devtools/python/python3-speedtest-cli_2.1.3.bb
@@ -7,4 +7,8 @@  SRC_URI[sha256sum] = "5e2773233cedb5fa3d8120eb7f97bcc4974b5221b254d33ff16e2f1d41
 
 inherit pypi setuptools3
 
-RDEPENDS:${PN} = "${PYTHON_PN}-misc"
+RDEPENDS:${PN} += " \
+    python3-misc \
+    python3-threading \
+    python3-xml \
+"