[meta-python] python3-redis: upgrade 4.2.2 -> 4.3.1

Message ID 1652940188-8005-3-git-send-email-xuhuan.fnst@fujitsu.com
State New
Headers show
Series [meta-python] python3-redis: upgrade 4.2.2 -> 4.3.1 | expand

Commit Message

XU Huan May 19, 2022, 6:03 a.m. UTC
From: Xu Huan <xuhuan.fnst@fujitsu.com>

Changelog:
=========
changes:
--------
    Fix asyncio Search crash
    Replace OSError exceptions from can_read with redis.ConnectionError
    Updated FUNCTION LOAD changes (from release 7.0 rc3 to support redis 7.0 final)

New Features
--------------
    Get command keys for subcommands
    Add support for CLUSTER SHARDS
    Add support for COMMAND LIST
    Add Async RedisCluster
    ACL SETUSER - add selectors and key based permissions
    Support for redis 7 streams features
    Async Connection: Allow PubSub.run() without previous subscribe()
    Implemented LATENCY HISTOGRAM by always throwing NotImplementedError
    Add async supoort for SEARCH commands
    Retry(): Support negative retries value
    Add support for MODULE LOADEX
    INFO - add support for taking multiple section arguments
    CONFIG SET - add the ability to set multiple parameters in one call
    CONFIG GET - add the ability to pass multiple pattern parameters in one call
    Add support for COMMAND GETKEYSANDFLAGS
    Support CASESENSITIVE for TAG fields

Bug Fixes
---------
    Rename 'update_supported_erros' to 'update_supported_errors' in Retry module
    Fix execute_command() determining nodes error when no key command
    Fix incorrect return statement in aut

Maintenance
------------
    Add unittest for PubSub.connect()
    Fix incorrect return annotation in asyncio.lock
    Minor cleanups in commands/cluster.py
    Update xtrim type annotation
    Async tests for redis commands, json, bloom, timeseries
    Fixed typing in getex command

Signed-off-by: Xu Huan <xuhuan.fnst@fujitsu.com>
---
 .../python/{python3-redis_4.2.2.bb => python3-redis_4.3.1.bb}   | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-redis_4.2.2.bb => python3-redis_4.3.1.bb} (81%)

Patch

diff --git a/meta-python/recipes-devtools/python/python3-redis_4.2.2.bb b/meta-python/recipes-devtools/python/python3-redis_4.3.1.bb
similarity index 81%
rename from meta-python/recipes-devtools/python/python3-redis_4.2.2.bb
rename to meta-python/recipes-devtools/python/python3-redis_4.3.1.bb
index 1e70cf484..c0d9c0064 100644
--- a/meta-python/recipes-devtools/python/python3-redis_4.2.2.bb
+++ b/meta-python/recipes-devtools/python/python3-redis_4.3.1.bb
@@ -4,7 +4,7 @@  HOMEPAGE = "http://github.com/andymccurdy/redis-py"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=51d9ad56299ab60ba7be65a621004f27"
 
-SRC_URI[sha256sum] = "0107dc8e98a4f1d1d4aa00100e044287f77121a1e6d2085545c4b7fa94a7a27f"
+SRC_URI[sha256sum] = "94b617b4cd296e94991146f66fc5559756fbefe9493604f0312e4d3298ac63e9"
 
 inherit pypi setuptools3