[meta-ti,dunfell] ti-tros-firmware: Add DM firmware binary to deploy directory for am62xx-evm

Message ID 20220513073848.13539-1-a-m1@ti.com
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series [meta-ti,dunfell] ti-tros-firmware: Add DM firmware binary to deploy directory for am62xx-evm | expand

Commit Message

Aparna M May 13, 2022, 7:38 a.m. UTC
The DM firmware binary is required for building uboot binaries for
am62xx-evm  using toplevel makefile in SDK. Add this file to deploy
directory so it can be included in prebuilt-images directory of SDK
for am62xx-evm.

Signed-off-by: Aparna M <a-m1@ti.com>
---

I have had to include a dummy do_deplo without which yocto build fails
with a "Task do_deploy is empty" error. Any suggestions as to why this
could be happening?

 recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb | 12 ++++++++++++
 1 file changed, 12 insertions(+)

Comments

Denys Dmytriyenko May 13, 2022, 9:53 p.m. UTC | #1
On Fri, May 13, 2022 at 01:08:48PM +0530, Aparna M wrote:
> The DM firmware binary is required for building uboot binaries for
> am62xx-evm  using toplevel makefile in SDK. Add this file to deploy
> directory so it can be included in prebuilt-images directory of SDK
> for am62xx-evm.
> 
> Signed-off-by: Aparna M <a-m1@ti.com>
> ---
> 
> I have had to include a dummy do_deplo without which yocto build fails
> with a "Task do_deploy is empty" error. Any suggestions as to why this
> could be happening?

You could have an empty do_deploy with a single colon symbol (NOP) in it:
https://git.openembedded.org/openembedded-core/tree/meta/recipes-support/user-creation/xuser-account_0.1.bb?h=dunfell


>  recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb | 12 ++++++++++++
>  1 file changed, 12 insertions(+)
> 
> diff --git a/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb b/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
> index 56a74899..0f2ba9af 100644
> --- a/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
> +++ b/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
> @@ -169,6 +169,16 @@ do_install_am62xx() {
>      install -m 0644 ${RTOS_DM_FW_DIR}/ipc_echo_testb_mcu1_0_release_strip.xer5f ${LEGACY_DM_FW_DIR}
>  }
>  
> +
> +do_deploy() {
> +    install -d ${DEPLOYDIR}
> +}
> +
> +do_deploy_am62xx() {
> +    install -d ${DEPLOYDIR}
> +    install -m 0644 ${RTOS_DM_FW_DIR}/ipc_echo_testb_mcu1_0_release_strip.xer5f ${DEPLOYDIR}
> +}
> +
>  # Set up names for the firmwares
>  ALTERNATIVE_${PN}_am65xx = "\
>                      am65x-mcu-r5f0_0-fw \
> @@ -357,3 +367,5 @@ INSANE_SKIP_${PN} += "arch"
>  # we don't want to configure and build the source code
>  do_compile[noexec] = "1"
>  do_configure[noexec] = "1"
> +
> +addtask deploy after do_install
> -- 
> 2.17.1
>

Patch

diff --git a/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb b/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
index 56a74899..0f2ba9af 100644
--- a/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
+++ b/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
@@ -169,6 +169,16 @@  do_install_am62xx() {
     install -m 0644 ${RTOS_DM_FW_DIR}/ipc_echo_testb_mcu1_0_release_strip.xer5f ${LEGACY_DM_FW_DIR}
 }
 
+
+do_deploy() {
+    install -d ${DEPLOYDIR}
+}
+
+do_deploy_am62xx() {
+    install -d ${DEPLOYDIR}
+    install -m 0644 ${RTOS_DM_FW_DIR}/ipc_echo_testb_mcu1_0_release_strip.xer5f ${DEPLOYDIR}
+}
+
 # Set up names for the firmwares
 ALTERNATIVE_${PN}_am65xx = "\
                     am65x-mcu-r5f0_0-fw \
@@ -357,3 +367,5 @@  INSANE_SKIP_${PN} += "arch"
 # we don't want to configure and build the source code
 do_compile[noexec] = "1"
 do_configure[noexec] = "1"
+
+addtask deploy after do_install