[meta-ti,dunfell] ti-graphics: update for 4K/64K page size GPU drivers

Message ID 20220512155107.19390-1-detheridge@ti.com
State Rejected
Delegated to: Ryan Eatmon
Headers show
Series [meta-ti,dunfell] ti-graphics: update for 4K/64K page size GPU drivers | expand

Commit Message

Etheridge, Darren May 12, 2022, 3:51 p.m. UTC
Pull in the GPU KM/UMLIBS that enable the unified 4K/64K page
firmware support in the IMG Rogue drivers.

Signed-off-by: Darren Etheridge <detheridge@ti.com>
---

Ryan, this is needed for rc4

 .../powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb     | 6 +++---
 .../libgles/ti-img-rogue-umlibs_1.15.6133109.bb             | 6 +++---
 2 files changed, 6 insertions(+), 6 deletions(-)

Patch

diff --git a/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb b/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb
index 6d2d68cd..718c7845 100644
--- a/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb
+++ b/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb
@@ -7,7 +7,7 @@  inherit module features_check
 
 REQUIRED_MACHINE_FEATURES = "gpu"
 
-MACHINE_KERNEL_PR_append = "a"
+MACHINE_KERNEL_PR_append = "b"
 PR = "${MACHINE_KERNEL_PR}"
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -17,7 +17,7 @@  DEPENDS = "virtual/kernel"
 
 PROVIDES = "virtual/gpudriver"
 
-BRANCH = "linuxws/dunfell/k5.10/${PV}"
+BRANCH = "linuxws/dunfell/k5.10/${PV}_unified_fw_pagesize"
 
 SRC_URI = " \
     git://git.ti.com/graphics/ti-img-rogue-driver.git;branch=${BRANCH} \
@@ -26,7 +26,7 @@  SRC_URI = " \
 
 S = "${WORKDIR}/git"
 
-SRCREV = "ee0674adccac16f5b2f7cb8d5d05948706080cb5"
+SRCREV = "6d3d62a15ceb85b719c35f34c6c9e35f556b406b"
 
 TARGET_PRODUCT_j7-evm = "j721e_linux"
 TARGET_PRODUCT_j7-hs-evm = "j721e_linux"
diff --git a/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb b/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb
index 0f3f9192..1bfb2b93 100644
--- a/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb
+++ b/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb
@@ -10,12 +10,12 @@  REQUIRED_MACHINE_FEATURES = "gpu"
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 COMPATIBLE_MACHINE = "j7-evm|j7-hs-evm|j721s2-evm|am62xx"
 
-PR = "r1"
+PR = "r2"
 
-BRANCH = "linuxws/dunfell/k5.10/${PV}"
+BRANCH = "linuxws/dunfell/k5.10/${PV}_unified_fw_pagesize"
 
 SRC_URI = "git://git.ti.com/graphics/ti-img-rogue-umlibs.git;branch=${BRANCH}"
-SRCREV = "47c3ffc44f2881397d45c8a2b5dfa7d6c58b79fb"
+SRCREV = "fba0c770b712640ab3761dbe8369d43f89f616ed"
 
 TARGET_PRODUCT_j7-evm = "j721e_linux"
 TARGET_PRODUCT_j7-hs-evm = "j721e_linux"