[meta-python] python3-bitarray: upgrade 2.4.1 -> 2.5.0

Message ID 1652347154-16706-1-git-send-email-zhengrq.fnst@fujitsu.com
State Under Review
Headers show
Series [meta-python] python3-bitarray: upgrade 2.4.1 -> 2.5.0 | expand

Commit Message

zhengrq.fnst@fujitsu.com May 12, 2022, 9:19 a.m. UTC
2022-05-04   2.5.0:
-------------------
  * add calculating of canonical Huffman codes 'util.canonical_huffman()'
    and decoding thereof 'util.canonical_decode()', see #173
  * allow creating "Huffman codes" from frequency maps with a single symbol
    in 'util.huffman_code()' and 'util.canonical_huffman()', see #172
  * allow bytes-like argument in '.frombytes()' and '.pack()' - previously,
    the arguments were limited to the 'bytes' object, see #174
  * allow bytes-like arguments in 'util.deserialize()'
  * add official pyodide support
  * add [DEFLATE decompression](../examples/puff/) example
  * optimize '.bytereverse()'
  * optimize 'delslice()' for cases like 'del a[1:17:2]' when 'a' is large
  * fix 'examples/huffman/compress.py' to handle files with 0 or 1 characters,
    see also #172
  * add 'skipIF' decorator for skipping tests
  * add test

Signed-off-by: Zheng Ruoqin <zhengrq.fnst@fujitsu.com>
---
 .../{python3-bitarray_2.4.1.bb => python3-bitarray_2.5.0.bb}    | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-bitarray_2.4.1.bb => python3-bitarray_2.5.0.bb} (77%)

Patch

diff --git a/meta-python/recipes-devtools/python/python3-bitarray_2.4.1.bb b/meta-python/recipes-devtools/python/python3-bitarray_2.5.0.bb
similarity index 77%
rename from meta-python/recipes-devtools/python/python3-bitarray_2.4.1.bb
rename to meta-python/recipes-devtools/python/python3-bitarray_2.5.0.bb
index fbb89b8dd..bb80c4a04 100644
--- a/meta-python/recipes-devtools/python/python3-bitarray_2.4.1.bb
+++ b/meta-python/recipes-devtools/python/python3-bitarray_2.5.0.bb
@@ -3,7 +3,7 @@  HOMEPAGE = "https://github.com/ilanschnell/bitarray"
 LICENSE = "PSF-2.0"
 LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=2ad702cdcd49e8d2ac01d7e7d0810d2d"
 
-SRC_URI[sha256sum] = "faeca03f979e992cc76f7406af7eb9795cb111b8d8969c891a032bd7497c87da"
+SRC_URI[sha256sum] = "5abed04adcd2031f6e714993d95223bf9ae85354c640c270b2ed6f46b83573ba"
 
 inherit setuptools3 pypi