[meta-python,02/16] python3-cytoolz: new package

Message ID 20220512084152.1388464-3-brgl@bgdev.pl
State Under Review
Headers show
Series python: add a bunch of packages for interacting with ethereum blockchains | expand

Commit Message

Bartosz Golaszewski May 12, 2022, 8:41 a.m. UTC
Add a recipe for cytoolz: cython implementation of the toolz package.

Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl>
---
 .../packagegroups/packagegroup-meta-python.bb        |  1 +
 .../python/python3-cytoolz_0.11.2.bb                 | 12 ++++++++++++
 2 files changed, 13 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-cytoolz_0.11.2.bb

Patch

diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
index 5edec8f68..5f97bd954 100644
--- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
+++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
@@ -86,6 +86,7 @@  RDEPENDS:packagegroup-meta-python3 = "\
     python3-custom-inherit \
     ${@bb.utils.contains_any('FORTRAN', [',fortran',',f77'], 'python3-cvxopt', '', d)} \
     python3-cycler \
+    python3-cytoolz \
     python3-dateparser \
     python3-dateutil \
     python3-dbus-next \
diff --git a/meta-python/recipes-devtools/python/python3-cytoolz_0.11.2.bb b/meta-python/recipes-devtools/python/python3-cytoolz_0.11.2.bb
new file mode 100644
index 000000000..14f597c28
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cytoolz_0.11.2.bb
@@ -0,0 +1,12 @@ 
+SUMMARY = "Cython implementation of the toolz package, which provides high \
+performance utility functions for iterables, functions, and dictionaries."
+HOMEPAGE = "https://github.com/pytoolz/cytoolz"
+SECTION = "devel/python"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=efbcddfa5610ca0c07ecfa274a82b373"
+
+SRC_URI[sha256sum] = "ea23663153806edddce7e4153d1d407d62357c05120a4e8485bddf1bd5ab22b4"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += "python3-toolz"