[2/2] logrotate: add packageconfigs

Submitted by Fahad Usman on Aug. 25, 2014, 4:22 p.m.

Details

Message ID 1408983725-45864-2-git-send-email-fahad_usman@mentor.com
State Accepted
Commit 885cec11c978975d5c51ded92882a3b00d5ccf8c
Headers show

Commit Message

Fahad Usman Aug. 25, 2014, 4:22 p.m.
add packageconfigs for acl and selinux.

Signed-off-by: Fahad Usman <fahad.usman@gmail.com>
Signed-off-by: Christopher Larson <kergoth@gmail.com>
---
 meta/recipes-extended/logrotate/logrotate_3.8.7.bb |    8 ++++++++
 1 file changed, 8 insertions(+)

Patch hide | download patch | download mbox

diff --git a/meta/recipes-extended/logrotate/logrotate_3.8.7.bb b/meta/recipes-extended/logrotate/logrotate_3.8.7.bb
index 42cd764..faa8e02 100644
--- a/meta/recipes-extended/logrotate/logrotate_3.8.7.bb
+++ b/meta/recipes-extended/logrotate/logrotate_3.8.7.bb
@@ -16,6 +16,11 @@  SRC_URI = "https://fedorahosted.org/releases/l/o/logrotate/logrotate-${PV}.tar.g
 SRC_URI[md5sum] = "99e08503ef24c3e2e3ff74cc5f3be213"
 SRC_URI[sha256sum] = "f6ba691f40e30e640efa2752c1f9499a3f9738257660994de70a45fe00d12b64"
 
+PACKAGECONFIG ?= "\
+    ${@base_contains('DISTRO_FEATURES', 'acl', 'acl', '', d)} \
+    ${@base_contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)} \
+"
+
 # If RPM_OPT_FLAGS is unset, it adds -g itself rather than obeying our
 # optimization variables, so use it rather than EXTRA_CFLAGS.
 EXTRA_OEMAKE = "\
@@ -25,6 +30,9 @@  EXTRA_OEMAKE = "\
     'CC=${CC}' \
     'RPM_OPT_FLAGS=${CFLAGS}' \
     'EXTRA_LDFLAGS=${LDFLAGS}' \
+    \
+    ${@base_contains('PACKAGECONFIG', 'acl', 'WITH_ACL=yes', '', d)} \
+    ${@base_contains('PACKAGECONFIG', 'selinux', 'WITH_SELINUX=yes', '', d)} \
 "
 
 # OS_NAME in the makefile defaults to `uname -s`. The behavior for

Comments

Ross Burton Aug. 27, 2014, 3:52 p.m.
On 25 August 2014 17:22, Fahad Usman <fahad_usman@mentor.com> wrote:
> +    ${@base_contains('PACKAGECONFIG', 'acl', 'WITH_ACL=yes', '', d)} \
> +    ${@base_contains('PACKAGECONFIG', 'selinux', 'WITH_SELINUX=yes', '', d)} \

Should this have WITH_XXX=no for clarity and safety?

Ross
Chris Larson Aug. 27, 2014, 4:19 p.m.
On Wed, Aug 27, 2014 at 8:52 AM, Burton, Ross <ross.burton@intel.com> wrote:

> On 25 August 2014 17:22, Fahad Usman <fahad_usman@mentor.com> wrote:
> > +    ${@base_contains('PACKAGECONFIG', 'acl', 'WITH_ACL=yes', '', d)} \
> > +    ${@base_contains('PACKAGECONFIG', 'selinux', 'WITH_SELINUX=yes',
> '', d)} \
>
> Should this have WITH_XXX=no for clarity and safety?


Yeah, that'd be a good idea, so we don't rely on the default behavior of
the underlying buildsystem, which could change in future releases. We can
submit an additional patch to improve that.