[meta-oe,for-daisy] php: Fix native build due mistakenly linking against host's iconv

Submitted by Otavio Salvador on Aug. 24, 2014, 9:03 p.m.

Details

Message ID 1408914239-11562-1-git-send-email-otavio@ossystems.com.br
State Accepted, archived
Headers show

Commit Message

Otavio Salvador Aug. 24, 2014, 9:03 p.m.
The configure script has mistakenly choose to enable iconv support,
due host to provide it, adding '/usr/lib' to the linking flags and
failing as:

,----[ Linking error while testing 'fork' support ]
| conftest.c:268: warning: conflicting types for built-in function 'fork'
| .../build/tmp/sysroots/x86_64-linux/usr/lib/libxml2.so:
|     undefined reference to `gzopen64@ZLIB_1.2.3.3'
| collect2: ld returned 1 exit status
`----

This patch disables iconv support for native builds fixing the error.

Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
---
 meta-oe/recipes-devtools/php/php.inc |    1 +
 1 file changed, 1 insertion(+)

Patch hide | download patch | download mbox

diff --git a/meta-oe/recipes-devtools/php/php.inc b/meta-oe/recipes-devtools/php/php.inc
index b1bf79c..1e2aa72 100644
--- a/meta-oe/recipes-devtools/php/php.inc
+++ b/meta-oe/recipes-devtools/php/php.inc
@@ -37,6 +37,7 @@  EXTRA_OECONF = "--enable-mbstring \
 EXTRA_OECONF_virtclass-native = " \
                 --with-zlib=${STAGING_LIBDIR_NATIVE}/.. \
                 --with-libxml-dir=${STAGING_BINDIR_NATIVE} \
+                --without-iconv \
                 ${COMMON_EXTRA_OECONF} \
 "
 

Comments

Khem Raj Aug. 24, 2014, 11:36 p.m.
On Sun, Aug 24, 2014 at 2:03 PM, Otavio Salvador
<otavio@ossystems.com.br> wrote:
> The configure script has mistakenly choose to enable iconv support,
> due host to provide it, adding '/usr/lib' to the linking flags and
> failing as:
>
> ,----[ Linking error while testing 'fork' support ]
> | conftest.c:268: warning: conflicting types for built-in function 'fork'
> | .../build/tmp/sysroots/x86_64-linux/usr/lib/libxml2.so:
> |     undefined reference to `gzopen64@ZLIB_1.2.3.3'
> | collect2: ld returned 1 exit status
> `----
>
> This patch disables iconv support for native builds fixing the error.
>

the patch subject is confusing. enabling iconv is not mistake but its
probed and if found its used. in this case libz against which libxml2
is linked is not used here and that ends up in error.

Can you try to add --with-iconv-dir=${STAGING_LIBDIR_NATIVE}
and see if it helps ?

> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
> ---
>  meta-oe/recipes-devtools/php/php.inc |    1 +
>  1 file changed, 1 insertion(+)
>
> diff --git a/meta-oe/recipes-devtools/php/php.inc b/meta-oe/recipes-devtools/php/php.inc
> index b1bf79c..1e2aa72 100644
> --- a/meta-oe/recipes-devtools/php/php.inc
> +++ b/meta-oe/recipes-devtools/php/php.inc
> @@ -37,6 +37,7 @@ EXTRA_OECONF = "--enable-mbstring \
>  EXTRA_OECONF_virtclass-native = " \
>                  --with-zlib=${STAGING_LIBDIR_NATIVE}/.. \
>                  --with-libxml-dir=${STAGING_BINDIR_NATIVE} \
> +                --without-iconv \
>                  ${COMMON_EXTRA_OECONF} \
>  "
>
> --
> 1.7.10.4
>
> --
> _______________________________________________
> Openembedded-devel mailing list
> Openembedded-devel@lists.openembedded.org
> http://lists.openembedded.org/mailman/listinfo/openembedded-devel
Otavio Salvador Aug. 25, 2014, 1:15 p.m.
On Sun, Aug 24, 2014 at 8:36 PM, Khem Raj <raj.khem@gmail.com> wrote:
> On Sun, Aug 24, 2014 at 2:03 PM, Otavio Salvador
> <otavio@ossystems.com.br> wrote:
>> The configure script has mistakenly choose to enable iconv support,
>> due host to provide it, adding '/usr/lib' to the linking flags and
>> failing as:
>>
>> ,----[ Linking error while testing 'fork' support ]
>> | conftest.c:268: warning: conflicting types for built-in function 'fork'
>> | .../build/tmp/sysroots/x86_64-linux/usr/lib/libxml2.so:
>> |     undefined reference to `gzopen64@ZLIB_1.2.3.3'
>> | collect2: ld returned 1 exit status
>> `----
>>
>> This patch disables iconv support for native builds fixing the error.
>>
>
> the patch subject is confusing. enabling iconv is not mistake but its
> probed and if found its used. in this case libz against which libxml2
> is linked is not used here and that ends up in error.
>
> Can you try to add --with-iconv-dir=${STAGING_LIBDIR_NATIVE}
> and see if it helps ?

The native does not depends on virtual/iconv. So the natural thing is
to disable it.
Otavio Salvador Aug. 28, 2014, 2:04 a.m.
On Mon, Aug 25, 2014 at 10:15 AM, Otavio Salvador
<otavio@ossystems.com.br> wrote:
> On Sun, Aug 24, 2014 at 8:36 PM, Khem Raj <raj.khem@gmail.com> wrote:
>> On Sun, Aug 24, 2014 at 2:03 PM, Otavio Salvador
>> <otavio@ossystems.com.br> wrote:
>>> The configure script has mistakenly choose to enable iconv support,
>>> due host to provide it, adding '/usr/lib' to the linking flags and
>>> failing as:
>>>
>>> ,----[ Linking error while testing 'fork' support ]
>>> | conftest.c:268: warning: conflicting types for built-in function 'fork'
>>> | .../build/tmp/sysroots/x86_64-linux/usr/lib/libxml2.so:
>>> |     undefined reference to `gzopen64@ZLIB_1.2.3.3'
>>> | collect2: ld returned 1 exit status
>>> `----
>>>
>>> This patch disables iconv support for native builds fixing the error.
>>>
>>
>> the patch subject is confusing. enabling iconv is not mistake but its
>> probed and if found its used. in this case libz against which libxml2
>> is linked is not used here and that ends up in error.
>>
>> Can you try to add --with-iconv-dir=${STAGING_LIBDIR_NATIVE}
>> and see if it helps ?
>
> The native does not depends on virtual/iconv. So the natural thing is
> to disable it.

Hey guys, can you review this one for backporting?
Otavio Salvador Aug. 28, 2014, 1:54 p.m.
Martin,

On Wed, Aug 27, 2014 at 11:04 PM, Otavio Salvador
<otavio@ossystems.com.br> wrote:
> On Mon, Aug 25, 2014 at 10:15 AM, Otavio Salvador
> <otavio@ossystems.com.br> wrote:
>> On Sun, Aug 24, 2014 at 8:36 PM, Khem Raj <raj.khem@gmail.com> wrote:
>>> On Sun, Aug 24, 2014 at 2:03 PM, Otavio Salvador
>>> <otavio@ossystems.com.br> wrote:
>>>> The configure script has mistakenly choose to enable iconv support,
>>>> due host to provide it, adding '/usr/lib' to the linking flags and
>>>> failing as:
>>>>
>>>> ,----[ Linking error while testing 'fork' support ]
>>>> | conftest.c:268: warning: conflicting types for built-in function 'fork'
>>>> | .../build/tmp/sysroots/x86_64-linux/usr/lib/libxml2.so:
>>>> |     undefined reference to `gzopen64@ZLIB_1.2.3.3'
>>>> | collect2: ld returned 1 exit status
>>>> `----
>>>>
>>>> This patch disables iconv support for native builds fixing the error.
>>>>
>>>
>>> the patch subject is confusing. enabling iconv is not mistake but its
>>> probed and if found its used. in this case libz against which libxml2
>>> is linked is not used here and that ends up in error.
>>>
>>> Can you try to add --with-iconv-dir=${STAGING_LIBDIR_NATIVE}
>>> and see if it helps ?
>>
>> The native does not depends on virtual/iconv. So the natural thing is
>> to disable it.
>
> Hey guys, can you review this one for backporting?

This is the Daisy backport one.
Armin Kuster Aug. 28, 2014, 7:37 p.m.
Acked-by: Armin Kuster <akuster808@gmail.com>


might have acked the wrong one.



On 08/28/2014 06:54 AM, Otavio Salvador wrote:
> Martin,
>
> On Wed, Aug 27, 2014 at 11:04 PM, Otavio Salvador
> <otavio@ossystems.com.br> wrote:
>> On Mon, Aug 25, 2014 at 10:15 AM, Otavio Salvador
>> <otavio@ossystems.com.br> wrote:
>>> On Sun, Aug 24, 2014 at 8:36 PM, Khem Raj <raj.khem@gmail.com> wrote:
>>>> On Sun, Aug 24, 2014 at 2:03 PM, Otavio Salvador
>>>> <otavio@ossystems.com.br> wrote:
>>>>> The configure script has mistakenly choose to enable iconv support,
>>>>> due host to provide it, adding '/usr/lib' to the linking flags and
>>>>> failing as:
>>>>>
>>>>> ,----[ Linking error while testing 'fork' support ]
>>>>> | conftest.c:268: warning: conflicting types for built-in function 'fork'
>>>>> | .../build/tmp/sysroots/x86_64-linux/usr/lib/libxml2.so:
>>>>> |     undefined reference to `gzopen64@ZLIB_1.2.3.3'
>>>>> | collect2: ld returned 1 exit status
>>>>> `----
>>>>>
>>>>> This patch disables iconv support for native builds fixing the error.
>>>>>
>>>>
>>>> the patch subject is confusing. enabling iconv is not mistake but its
>>>> probed and if found its used. in this case libz against which libxml2
>>>> is linked is not used here and that ends up in error.
>>>>
>>>> Can you try to add --with-iconv-dir=${STAGING_LIBDIR_NATIVE}
>>>> and see if it helps ?
>>>
>>> The native does not depends on virtual/iconv. So the natural thing is
>>> to disable it.
>>
>> Hey guys, can you review this one for backporting?
>
> This is the Daisy backport one.
>
Cliff Brake Aug. 29, 2014, 6:11 p.m.
Acked-by: Cliff Brake <cbrake@bec-systems.com>

On Thu, Aug 28, 2014 at 3:37 PM, akuster808 <akuster808@gmail.com> wrote:
>  Acked-by: Armin Kuster <akuster808@gmail.com>
>
>
> might have acked the wrong one.
>
>
>
>
> On 08/28/2014 06:54 AM, Otavio Salvador wrote:
>>
>> Martin,
>>
>> On Wed, Aug 27, 2014 at 11:04 PM, Otavio Salvador
>> <otavio@ossystems.com.br> wrote:
>>>
>>> On Mon, Aug 25, 2014 at 10:15 AM, Otavio Salvador
>>> <otavio@ossystems.com.br> wrote:
>>>>
>>>> On Sun, Aug 24, 2014 at 8:36 PM, Khem Raj <raj.khem@gmail.com> wrote:
>>>>>
>>>>> On Sun, Aug 24, 2014 at 2:03 PM, Otavio Salvador
>>>>> <otavio@ossystems.com.br> wrote:
>>>>>>
>>>>>> The configure script has mistakenly choose to enable iconv support,
>>>>>> due host to provide it, adding '/usr/lib' to the linking flags and
>>>>>> failing as:
>>>>>>
>>>>>> ,----[ Linking error while testing 'fork' support ]
>>>>>> | conftest.c:268: warning: conflicting types for built-in function
>>>>>> 'fork'
>>>>>> | .../build/tmp/sysroots/x86_64-linux/usr/lib/libxml2.so:
>>>>>> |     undefined reference to `gzopen64@ZLIB_1.2.3.3'
>>>>>> | collect2: ld returned 1 exit status
>>>>>> `----
>>>>>>
>>>>>> This patch disables iconv support for native builds fixing the error.
>>>>>>
>>>>>
>>>>> the patch subject is confusing. enabling iconv is not mistake but its
>>>>> probed and if found its used. in this case libz against which libxml2
>>>>> is linked is not used here and that ends up in error.
>>>>>
>>>>> Can you try to add --with-iconv-dir=${STAGING_LIBDIR_NATIVE}
>>>>> and see if it helps ?
>>>>
>>>>
>>>> The native does not depends on virtual/iconv. So the natural thing is
>>>> to disable it.
>>>
>>>
>>> Hey guys, can you review this one for backporting?
>>
>>
>> This is the Daisy backport one.
>>
>