glib-2.0: Add missing nativesdk-gettext DEPENDS

Submitted by Richard Purdie on Aug. 17, 2014, 8:51 a.m.

Details

Message ID 1408265518.24858.3.camel@ted
State Accepted
Commit 1f7d22ce9322b960c89afd3673ace9f0d937b2a6
Headers show

Commit Message

Richard Purdie Aug. 17, 2014, 8:51 a.m.
This override overrides the gettext class additions so we need to
add back the dependency manually.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>

Patch hide | download patch | download mbox

diff --git a/meta/recipes-core/glib-2.0/glib.inc b/meta/recipes-core/glib-2.0/glib.inc
index f797ab3..bd8d74b 100644
--- a/meta/recipes-core/glib-2.0/glib.inc
+++ b/meta/recipes-core/glib-2.0/glib.inc
@@ -18,7 +18,7 @@  BBCLASSEXTEND = "native nativesdk"
 DEPENDS = "glib-2.0-native virtual/libiconv libffi zlib"
 DEPENDS_append_class-target = "${@bb.utils.contains('DISTRO_FEATURES', 'ptest', ' dbus', '', d)}"
 DEPENDS_class-native = "pkgconfig-native gettext-native libffi-native zlib-native"
-DEPENDS_class-nativesdk = "nativesdk-libtool nativesdk-libffi nativesdk-zlib ${BPN}-native"
+DEPENDS_class-nativesdk = "nativesdk-libtool nativesdk-gettext nativesdk-libffi nativesdk-zlib ${BPN}-native"
 
 PACKAGES =+ "${PN}-utils ${PN}-bash-completion ${PN}-codegen"