apt-native: Add missing DEPENDS on db-native and curl-native

Submitted by Richard Purdie on July 26, 2014, 8:02 a.m.


Message ID 1406361743.27697.49.camel@ted
State Accepted
Commit 9a3240acd0ac64a257bcfd48f743fc85b6c8f449
Headers show

Commit Message

Richard Purdie July 26, 2014, 8:02 a.m.
The target recipe has these DEPENDS but the native version does not
and this can lead to none deterministic builds. Fix this.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>

Patch hide | download patch | download mbox

diff --git a/meta/recipes-devtools/apt/apt-native.inc b/meta/recipes-devtools/apt/apt-native.inc
index 36035b0..fede869 100644
--- a/meta/recipes-devtools/apt/apt-native.inc
+++ b/meta/recipes-devtools/apt/apt-native.inc
@@ -1,7 +1,7 @@ 
 require apt.inc
 inherit native
-DEPENDS += "dpkg-native gettext-native"
+DEPENDS += "dpkg-native gettext-native db-native curl-native"
 USE_NLS = "yes"