[meta-ti,dunfell,v3,2/2] conf/machine: am62xx: Update build flag for low power mode

Message ID 20220505013006.27140-3-reatmon@ti.com
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series am62xx: Upgrade ATF to get LP support | expand

Commit Message

Ryan Eatmon May 5, 2022, 1:30 a.m. UTC
From: Nishanth Menon <nm@ti.com>

Update build flag for arm-trusted-firmware to include low power mode
support

K3_PM_SYSTEM_SUSPEND is added in arm-trusted-firmware now which enables
low power mode support for am62xx.

Signed-off-by: Nishanth Menon <nm@ti.com>
Signed-off-by: Praneeth Bajjuri <praneeth@ti.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
---
 conf/machine/include/am62xx.inc                              | 2 ++
 recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend | 1 +
 2 files changed, 3 insertions(+)

Comments

Denys Dmytriyenko May 5, 2022, 10:50 p.m. UTC | #1
On Wed, May 04, 2022 at 08:30:06PM -0500, Ryan Eatmon via lists.yoctoproject.org wrote:
> From: Nishanth Menon <nm@ti.com>
> 
> Update build flag for arm-trusted-firmware to include low power mode
> support
> 
> K3_PM_SYSTEM_SUSPEND is added in arm-trusted-firmware now which enables
> low power mode support for am62xx.
> 
> Signed-off-by: Nishanth Menon <nm@ti.com>
> Signed-off-by: Praneeth Bajjuri <praneeth@ti.com>
> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
> ---
>  conf/machine/include/am62xx.inc                              | 2 ++
>  recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend | 1 +
>  2 files changed, 3 insertions(+)
> 
> diff --git a/conf/machine/include/am62xx.inc b/conf/machine/include/am62xx.inc
> index e8823dd2..ff857b97 100644
> --- a/conf/machine/include/am62xx.inc
> +++ b/conf/machine/include/am62xx.inc
> @@ -6,6 +6,8 @@ MACHINE_FEATURES += "screen touchscreen"
>  SERIAL_CONSOLES = "115200;ttyS2"
>  SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
>  
> +TFA_K3_SYSTEM_SUSPEND = "1"

Might want to keep this TFA_ variable together with the other TFA_BOARD being 
set futher down in the file, to avoid scattering them all over...

Otherwise looks good to me.


> +
>  # AM62 supports multi-certificate images, use the same
>  IMAGE_BOOT_FILES = "${IMAGE_BOOT_FILES_MULTI_CERT}"
>  
> diff --git a/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend b/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
> index 80b1d664..68bfa899 100644
> --- a/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
> +++ b/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
> @@ -9,6 +9,7 @@ TFA_INSTALL_TARGET_k3 = "bl31"
>  TFA_SPD_k3 = "opteed"
>  
>  EXTRA_OEMAKE_append_k3 = "${@ 'K3_USART=' + d.getVar('TFA_K3_USART') if d.getVar('TFA_K3_USART') else ''}"
> +EXTRA_OEMAKE_append_k3 = "${@ 'K3_PM_SYSTEM_SUSPEND=' + d.getVar('TFA_K3_SYSTEM_SUSPEND') if d.getVar('TFA_K3_SYSTEM_SUSPEND') else ''}"
>  
>  do_compile_append_am65xx-hs-evm() {
>  	export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
> -- 
> 2.17.1

Patch

diff --git a/conf/machine/include/am62xx.inc b/conf/machine/include/am62xx.inc
index e8823dd2..ff857b97 100644
--- a/conf/machine/include/am62xx.inc
+++ b/conf/machine/include/am62xx.inc
@@ -6,6 +6,8 @@  MACHINE_FEATURES += "screen touchscreen"
 SERIAL_CONSOLES = "115200;ttyS2"
 SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
 
+TFA_K3_SYSTEM_SUSPEND = "1"
+
 # AM62 supports multi-certificate images, use the same
 IMAGE_BOOT_FILES = "${IMAGE_BOOT_FILES_MULTI_CERT}"
 
diff --git a/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend b/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
index 80b1d664..68bfa899 100644
--- a/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
+++ b/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
@@ -9,6 +9,7 @@  TFA_INSTALL_TARGET_k3 = "bl31"
 TFA_SPD_k3 = "opteed"
 
 EXTRA_OEMAKE_append_k3 = "${@ 'K3_USART=' + d.getVar('TFA_K3_USART') if d.getVar('TFA_K3_USART') else ''}"
+EXTRA_OEMAKE_append_k3 = "${@ 'K3_PM_SYSTEM_SUSPEND=' + d.getVar('TFA_K3_SYSTEM_SUSPEND') if d.getVar('TFA_K3_SYSTEM_SUSPEND') else ''}"
 
 do_compile_append_am65xx-hs-evm() {
 	export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}