[kirkstone,10/39] ufw: Fix build with usrmerge distro feature

Message ID ae2e614954567483b716f07aa7522b20d7115ce2.1651346200.git.akuster808@gmail.com
State Accepted, archived
Headers show
Series [kirkstone,01/39] crash: Upgrade to 8.0.0 | expand

Commit Message

akuster808 April 30, 2022, 7:17 p.m. UTC
From: Khem Raj <raj.khem@gmail.com>

Signed-off-by: Khem Raj <raj.khem@gmail.com>
(cherry picked from commit a47c833126334404fcad459cc683e304fee54595)
Signed-off-by: Armin Kuster <akuster808@gmail.com>
---
 meta-networking/recipes-connectivity/ufw/ufw_0.36.1.bb | 7 +++++++
 1 file changed, 7 insertions(+)

Patch

diff --git a/meta-networking/recipes-connectivity/ufw/ufw_0.36.1.bb b/meta-networking/recipes-connectivity/ufw/ufw_0.36.1.bb
index 70216a85e3..6dca784bf4 100644
--- a/meta-networking/recipes-connectivity/ufw/ufw_0.36.1.bb
+++ b/meta-networking/recipes-connectivity/ufw/ufw_0.36.1.bb
@@ -38,6 +38,13 @@  RRECOMMENDS:${PN} = " \
                      kernel-module-nf-recent \
 "
 
+
+do_configure:prepend() {
+    if ${@bb.utils.contains('DISTRO_FEATURES','usrmerge','true','false',d)}; then
+        sed -i -e 's|/lib|${nonarch_base_libdir}|' ${S}/setup.py
+    fi
+}
+
 do_install:append() {
     install -d ${D}${systemd_unitdir}/system/
     install -m 0644 ${S}/doc/systemd.example ${D}${systemd_unitdir}/system/ufw.service