gpgme: Update to ensure we pkg-config for dependencies

Submitted by Richard Purdie on May 22, 2014, 9:53 a.m.

Details

Message ID 1400752408.17834.63.camel@ted
State Accepted
Commit ffffc627b21a3cf8b407d16a437793b5fddf7127
Headers show

Commit Message

Richard Purdie May 22, 2014, 9:53 a.m.
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>

Patch hide | download patch | download mbox

diff --git a/meta/recipes-support/gpgme/gpgme_1.4.3.bb b/meta/recipes-support/gpgme/gpgme_1.4.3.bb
index bb53e38..9d21ade 100644
--- a/meta/recipes-support/gpgme/gpgme_1.4.3.bb
+++ b/meta/recipes-support/gpgme/gpgme_1.4.3.bb
@@ -24,3 +24,9 @@  inherit autotools texinfo binconfig
 PACKAGES =+ "${PN}-pthread"
 FILES_${PN}-pthread = "${libdir}/libgpgme-pthread.so.*"
 FILES_${PN}-dev += "${datadir}/common-lisp/source/gpgme/*"
+
+do_configure_prepend () {
+	# Else these could be used in preference to those in aclocal-copy
+	rm -f ${S}/m4/gpg-error.m4
+	rm -f ${S}/m4/libassuan.m4
+}