libhandy: add hdy-enums-private.h

Message ID 20211208063641.8068-1-mingli.yu@windriver.com
State New
Headers show
Series libhandy: add hdy-enums-private.h | expand

Commit Message

Yu, Mingli Dec. 8, 2021, 6:36 a.m. UTC
From: Mingli Yu <mingli.yu@windriver.com>

After the commit(8157ecc Separate public and private enums) introduced,
there comes a race as below:
 | In file included from ../git/src/hdy-settings.c:11:
 | ../git/src/hdy-settings-private.h:16:10: fatal error: hdy-enums-private.h: No such file or directory
 |    16 | #include "hdy-enums-private.h"

So add hdy-enums-private.h to libhandy_sources to fix the issue.

Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
---
 .../0001-Add-hdy-enums-private.h.patch        | 52 +++++++++++++++++++
 meta/recipes-gnome/libhandy/libhandy_1.5.0.bb |  4 +-
 2 files changed, 55 insertions(+), 1 deletion(-)
 create mode 100644 meta/recipes-gnome/libhandy/libhandy/0001-Add-hdy-enums-private.h.patch

Patch

diff --git a/meta/recipes-gnome/libhandy/libhandy/0001-Add-hdy-enums-private.h.patch b/meta/recipes-gnome/libhandy/libhandy/0001-Add-hdy-enums-private.h.patch
new file mode 100644
index 0000000000..e50eae0b42
--- /dev/null
+++ b/meta/recipes-gnome/libhandy/libhandy/0001-Add-hdy-enums-private.h.patch
@@ -0,0 +1,52 @@ 
+From 8ee30d1c415b916b6b59557c0081274756b1d849 Mon Sep 17 00:00:00 2001
+From: Mingli Yu <mingli.yu@windriver.com>
+Date: Wed, 8 Dec 2021 01:58:14 +0000
+Subject: [PATCH] Add hdy-enums-private.h
+
+After the commit(8157ecc Separate public and private enums) introduced,
+there comes a race as below:
+ | In file included from ../git/src/hdy-settings.c:11:
+ | ../git/src/hdy-settings-private.h:16:10: fatal error: hdy-enums-private.h: No such file or directory
+ |    16 | #include "hdy-enums-private.h"
+
+So add hdy-enums-private.h to libhandy_sources to fix the issue.
+
+Upstream-Status: Submitted [https://gitlab.gnome.org/GNOME/libhandy/-/merge_requests/796]
+
+Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
+---
+ src/meson.build | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/src/meson.build b/src/meson.build
+index d087323..dd7c3ee 100644
+--- a/src/meson.build
++++ b/src/meson.build
+@@ -39,6 +39,8 @@ hdy_version_h = configure_file(
+ 
+ libhandy_generated_headers = [
+ ]
++libhandy_generated_private_headers = [
++]
+ 
+ install_headers(['handy.h'],
+   subdir: libhandy_header_subdir)
+@@ -66,6 +68,7 @@ hdy_private_enums = gnome.mkenums('hdy-enums-private',
+ libhandy_public_sources += [hdy_public_enums[0]]
+ libhandy_private_sources += [hdy_private_enums[0]]
+ libhandy_generated_headers += [hdy_public_enums[1]]
++libhandy_generated_private_headers += [hdy_private_enums[1]]
+ 
+ src_headers = [
+   'hdy-action-row.h',
+@@ -187,6 +190,7 @@ install_headers(src_headers, subdir: libhandy_header_subdir)
+ 
+ libhandy_sources = [
+   libhandy_generated_headers,
++  libhandy_generated_private_headers,
+   libhandy_public_sources,
+   libhandy_private_sources,
+   libhandy_resources,
+-- 
+2.32.0
+
diff --git a/meta/recipes-gnome/libhandy/libhandy_1.5.0.bb b/meta/recipes-gnome/libhandy/libhandy_1.5.0.bb
index d0b59b1a62..3ff56a6111 100644
--- a/meta/recipes-gnome/libhandy/libhandy_1.5.0.bb
+++ b/meta/recipes-gnome/libhandy/libhandy_1.5.0.bb
@@ -9,7 +9,9 @@  BUGTRACKER = "https://gitlab.gnome.org/GNOME/libhandy/-/issues"
 LICENSE = "LGPLv2.1"
 LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
 
-SRC_URI = "git://gitlab.gnome.org/GNOME/libhandy.git;protocol=https;branch=master"
+SRC_URI = "git://gitlab.gnome.org/GNOME/libhandy.git;protocol=https;branch=master \
+           file://0001-Add-hdy-enums-private.h.patch \
+"
 SRCREV = "8fa8306a79215fc6ebf2483145da98bf9b2495ab"
 S = "${WORKDIR}/git"