[meta-oe,hardknott] makedumpfile: Upgrade to 1.6.9

Message ID 20220424084538.2940999-1-mingli.yu@windriver.com
State New
Headers show
Series [meta-oe,hardknott] makedumpfile: Upgrade to 1.6.9 | expand

Commit Message

Yu, Mingli April 24, 2022, 8:45 a.m. UTC
From: Mingli Yu <mingli.yu@windriver.com>

* Linux 5.10 introduces a new lockless ringbuffer. The new ringbuffer
  is structured completely different to the previous iterations.
  Add support for retrieving the ringbuffer from debug information
  and/or using vmcoreinfo. The new ringbuffer is detected based on
  the availability of the "prb" symbol.

* Support newer kernels as follows:

  - 5.10, 5.11, 5.12  (x86_64 SPARSEMEM)

Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
---
 ...1-makedumpfile-replace-hardcode-CFLAGS.patch | 17 +++++++++--------
 ...edumpfile_1.6.8.bb => makedumpfile_1.6.9.bb} |  2 +-
 2 files changed, 10 insertions(+), 9 deletions(-)
 rename meta-oe/recipes-kernel/makedumpfile/{makedumpfile_1.6.8.bb => makedumpfile_1.6.9.bb} (97%)

Comments

akuster808 April 24, 2022, 9:49 p.m. UTC | #1
On 4/24/22 01:45, mingli.yu@windriver.com wrote:
> From: Mingli Yu <mingli.yu@windriver.com>
>
> * Linux 5.10 introduces a new lockless ringbuffer. The new ringbuffer
>    is structured completely different to the previous iterations.
>    Add support for retrieving the ringbuffer from debug information
>    and/or using vmcoreinfo. The new ringbuffer is detected based on
>    the availability of the "prb" symbol.
>
> * Support newer kernels as follows:
>
>    - 5.10, 5.11, 5.12  (x86_64 SPARSEMEM)

Isn't 5.10 supported in Hardknott? Did any 5.10 kernel updates introduce 
a regression?

-armin
>
> Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
> ---
>   ...1-makedumpfile-replace-hardcode-CFLAGS.patch | 17 +++++++++--------
>   ...edumpfile_1.6.8.bb => makedumpfile_1.6.9.bb} |  2 +-
>   2 files changed, 10 insertions(+), 9 deletions(-)
>   rename meta-oe/recipes-kernel/makedumpfile/{makedumpfile_1.6.8.bb => makedumpfile_1.6.9.bb} (97%)
>
> diff --git a/meta-oe/recipes-kernel/makedumpfile/makedumpfile/0001-makedumpfile-replace-hardcode-CFLAGS.patch b/meta-oe/recipes-kernel/makedumpfile/makedumpfile/0001-makedumpfile-replace-hardcode-CFLAGS.patch
> index 270cc3562..94eac931e 100644
> --- a/meta-oe/recipes-kernel/makedumpfile/makedumpfile/0001-makedumpfile-replace-hardcode-CFLAGS.patch
> +++ b/meta-oe/recipes-kernel/makedumpfile/makedumpfile/0001-makedumpfile-replace-hardcode-CFLAGS.patch
> @@ -1,4 +1,4 @@
> -From af97e2ad643334b4c7c3d66f971ce9ebb2b596af Mon Sep 17 00:00:00 2001
> +From 1053cf25be28b266ba264705e11179cf4f04aa91 Mon Sep 17 00:00:00 2001
>   From: Mingli Yu <mingli.yu@windriver.com>
>   Date: Thu, 21 Jul 2016 18:06:21 +0800
>   Subject: [PATCH] makedumpfile: replace hardcode CFLAGS
> @@ -13,14 +13,15 @@ Subject: [PATCH] makedumpfile: replace hardcode CFLAGS
>   Upstream-Status: Inappropriate[oe specific]
>   
>   Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
> +
>   ---
>    Makefile | 45 +++++++++++++++++++++++----------------------
>    1 file changed, 23 insertions(+), 22 deletions(-)
>   
> -Index: git/Makefile
> -===================================================================
> ---- git.orig/Makefile
> -+++ git/Makefile
> +diff --git a/Makefile b/Makefile
> +index 6fa00bc..7aa7ae2 100644
> +--- a/Makefile
> ++++ b/Makefile
>   @@ -8,12 +8,6 @@ ifeq ($(strip $CC),)
>    CC	= gcc
>    endif
> @@ -79,7 +80,7 @@ Index: git/Makefile
>   +              -DRELEASE_DATE='"$(DATE)"'
>   +
>    SRC_BASE = makedumpfile.c makedumpfile.h diskdump_mod.h sadump_mod.h sadump_info.h
> - SRC_PART = print_info.c dwarf_info.c elf_info.c erase_info.c sadump_info.c cache.c tools.c
> + SRC_PART = print_info.c dwarf_info.c elf_info.c erase_info.c sadump_info.c cache.c tools.c printk.c
>    OBJ_PART=$(patsubst %.c,%.o,$(SRC_PART))
>   @@ -52,12 +53,12 @@ OBJ_ARCH=$(patsubst %.c,%.o,$(SRC_ARCH))
>    
> @@ -104,7 +105,7 @@ Index: git/Makefile
>   +CFLAGS_COMMON += -DUSESNAPPY
>    endif
>    
> - LIBS := -lpthread $(LIBS)
> + LIBS := $(LIBS) -lpthread
>   @@ -90,14 +91,14 @@ LIBS := $(LIBS) $(call try-run,\
>    all: makedumpfile
>    
> @@ -122,7 +123,7 @@ Index: git/Makefile
>    	echo .TH MAKEDUMPFILE 8 \"$(DATE)\" \"makedumpfile v$(VERSION)\" \"Linux System Administrator\'s Manual\" > temp.8
>    	grep -v "^.TH MAKEDUMPFILE 8" $(VPATH)makedumpfile.8 >> temp.8
>    	mv temp.8 makedumpfile.8
> -@@ -108,7 +109,7 @@ makedumpfile: $(SRC_BASE) $(OBJ_PART) $(
> +@@ -108,7 +109,7 @@ makedumpfile: $(SRC_BASE) $(OBJ_PART) $(OBJ_ARCH)
>    	gzip -c ./makedumpfile.conf.5 > ./makedumpfile.conf.5.gz
>    
>    eppic_makedumpfile.so: extension_eppic.c
> diff --git a/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.8.bb b/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.9.bb
> similarity index 97%
> rename from meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.8.bb
> rename to meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.9.bb
> index 6f87db177..4350ea126 100644
> --- a/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.8.bb
> +++ b/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.9.bb
> @@ -11,7 +11,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
>   LICENSE = "GPLv2.0"
>   
>   SRCBRANCH ?= "master"
> -SRCREV = "18e0cdba48feeccea2429b3b0b2691f4314d1062"
> +SRCREV = "a9ad811c15e769c8e6d8d915a05cebc32f2ea2f5"
>   
>   DEPENDS = "bzip2 zlib elfutils xz"
>   RDEPENDS_${PN}-tools = "perl ${PN}"
Yu, Mingli April 25, 2022, 5:36 a.m. UTC | #2
Hi Armin,

On 4/25/22 5:49 AM, akuster808 wrote:
> [Please note: This e-mail is from an EXTERNAL e-mail address]
> 
> On 4/24/22 01:45, mingli.yu@windriver.com wrote:
>> From: Mingli Yu <mingli.yu@windriver.com>
>>
>> * Linux 5.10 introduces a new lockless ringbuffer. The new ringbuffer
>>    is structured completely different to the previous iterations.
>>    Add support for retrieving the ringbuffer from debug information
>>    and/or using vmcoreinfo. The new ringbuffer is detected based on
>>    the availability of the "prb" symbol.
>>
>> * Support newer kernels as follows:
>>
>>    - 5.10, 5.11, 5.12  (x86_64 SPARSEMEM)
> 
> Isn't 5.10 supported in Hardknott? Did any 5.10 kernel updates introduce
> a regression?

FYI.

https://git.openembedded.org/openembedded-core/commit/?h=hardknott&id=03c3af8bcd0a7059ae37e6e633d9c94310ebdc16

Thanks,

> 
> -armin
>>
>> Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
>> ---
>>   ...1-makedumpfile-replace-hardcode-CFLAGS.patch | 17 +++++++++--------
>>   ...edumpfile_1.6.8.bb => makedumpfile_1.6.9.bb} |  2 +-
>>   2 files changed, 10 insertions(+), 9 deletions(-)
>>   rename meta-oe/recipes-kernel/makedumpfile/{makedumpfile_1.6.8.bb => 
>> makedumpfile_1.6.9.bb} (97%)
>>
>> diff --git 
>> a/meta-oe/recipes-kernel/makedumpfile/makedumpfile/0001-makedumpfile-replace-hardcode-CFLAGS.patch 
>> b/meta-oe/recipes-kernel/makedumpfile/makedumpfile/0001-makedumpfile-replace-hardcode-CFLAGS.patch 
>>
>> index 270cc3562..94eac931e 100644
>> --- 
>> a/meta-oe/recipes-kernel/makedumpfile/makedumpfile/0001-makedumpfile-replace-hardcode-CFLAGS.patch 
>>
>> +++ 
>> b/meta-oe/recipes-kernel/makedumpfile/makedumpfile/0001-makedumpfile-replace-hardcode-CFLAGS.patch 
>>
>> @@ -1,4 +1,4 @@
>> -From af97e2ad643334b4c7c3d66f971ce9ebb2b596af Mon Sep 17 00:00:00 2001
>> +From 1053cf25be28b266ba264705e11179cf4f04aa91 Mon Sep 17 00:00:00 2001
>>   From: Mingli Yu <mingli.yu@windriver.com>
>>   Date: Thu, 21 Jul 2016 18:06:21 +0800
>>   Subject: [PATCH] makedumpfile: replace hardcode CFLAGS
>> @@ -13,14 +13,15 @@ Subject: [PATCH] makedumpfile: replace hardcode 
>> CFLAGS
>>   Upstream-Status: Inappropriate[oe specific]
>>
>>   Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
>> +
>>   ---
>>    Makefile | 45 +++++++++++++++++++++++----------------------
>>    1 file changed, 23 insertions(+), 22 deletions(-)
>>
>> -Index: git/Makefile
>> -===================================================================
>> ---- git.orig/Makefile
>> -+++ git/Makefile
>> +diff --git a/Makefile b/Makefile
>> +index 6fa00bc..7aa7ae2 100644
>> +--- a/Makefile
>> ++++ b/Makefile
>>   @@ -8,12 +8,6 @@ ifeq ($(strip $CC),)
>>    CC = gcc
>>    endif
>> @@ -79,7 +80,7 @@ Index: git/Makefile
>>   +              -DRELEASE_DATE='"$(DATE)"'
>>   +
>>    SRC_BASE = makedumpfile.c makedumpfile.h diskdump_mod.h 
>> sadump_mod.h sadump_info.h
>> - SRC_PART = print_info.c dwarf_info.c elf_info.c erase_info.c 
>> sadump_info.c cache.c tools.c
>> + SRC_PART = print_info.c dwarf_info.c elf_info.c erase_info.c 
>> sadump_info.c cache.c tools.c printk.c
>>    OBJ_PART=$(patsubst %.c,%.o,$(SRC_PART))
>>   @@ -52,12 +53,12 @@ OBJ_ARCH=$(patsubst %.c,%.o,$(SRC_ARCH))
>>
>> @@ -104,7 +105,7 @@ Index: git/Makefile
>>   +CFLAGS_COMMON += -DUSESNAPPY
>>    endif
>>
>> - LIBS := -lpthread $(LIBS)
>> + LIBS := $(LIBS) -lpthread
>>   @@ -90,14 +91,14 @@ LIBS := $(LIBS) $(call try-run,\
>>    all: makedumpfile
>>
>> @@ -122,7 +123,7 @@ Index: git/Makefile
>>       echo .TH MAKEDUMPFILE 8 \"$(DATE)\" \"makedumpfile v$(VERSION)\" 
>> \"Linux System Administrator\'s Manual\" > temp.8
>>       grep -v "^.TH MAKEDUMPFILE 8" $(VPATH)makedumpfile.8 >> temp.8
>>       mv temp.8 makedumpfile.8
>> -@@ -108,7 +109,7 @@ makedumpfile: $(SRC_BASE) $(OBJ_PART) $(
>> +@@ -108,7 +109,7 @@ makedumpfile: $(SRC_BASE) $(OBJ_PART) $(OBJ_ARCH)
>>       gzip -c ./makedumpfile.conf.5 > ./makedumpfile.conf.5.gz
>>
>>    eppic_makedumpfile.so: extension_eppic.c
>> diff --git a/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.8.bb 
>> b/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.9.bb
>> similarity index 97%
>> rename from meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.8.bb
>> rename to meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.9.bb
>> index 6f87db177..4350ea126 100644
>> --- a/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.8.bb
>> +++ b/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.9.bb
>> @@ -11,7 +11,7 @@ LIC_FILES_CHKSUM = 
>> "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
>>   LICENSE = "GPLv2.0"
>>
>>   SRCBRANCH ?= "master"
>> -SRCREV = "18e0cdba48feeccea2429b3b0b2691f4314d1062"
>> +SRCREV = "a9ad811c15e769c8e6d8d915a05cebc32f2ea2f5"
>>
>>   DEPENDS = "bzip2 zlib elfutils xz"
>>   RDEPENDS_${PN}-tools = "perl ${PN}"
>

Patch

diff --git a/meta-oe/recipes-kernel/makedumpfile/makedumpfile/0001-makedumpfile-replace-hardcode-CFLAGS.patch b/meta-oe/recipes-kernel/makedumpfile/makedumpfile/0001-makedumpfile-replace-hardcode-CFLAGS.patch
index 270cc3562..94eac931e 100644
--- a/meta-oe/recipes-kernel/makedumpfile/makedumpfile/0001-makedumpfile-replace-hardcode-CFLAGS.patch
+++ b/meta-oe/recipes-kernel/makedumpfile/makedumpfile/0001-makedumpfile-replace-hardcode-CFLAGS.patch
@@ -1,4 +1,4 @@ 
-From af97e2ad643334b4c7c3d66f971ce9ebb2b596af Mon Sep 17 00:00:00 2001
+From 1053cf25be28b266ba264705e11179cf4f04aa91 Mon Sep 17 00:00:00 2001
 From: Mingli Yu <mingli.yu@windriver.com>
 Date: Thu, 21 Jul 2016 18:06:21 +0800
 Subject: [PATCH] makedumpfile: replace hardcode CFLAGS
@@ -13,14 +13,15 @@  Subject: [PATCH] makedumpfile: replace hardcode CFLAGS
 Upstream-Status: Inappropriate[oe specific]
 
 Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
+
 ---
  Makefile | 45 +++++++++++++++++++++++----------------------
  1 file changed, 23 insertions(+), 22 deletions(-)
 
-Index: git/Makefile
-===================================================================
---- git.orig/Makefile
-+++ git/Makefile
+diff --git a/Makefile b/Makefile
+index 6fa00bc..7aa7ae2 100644
+--- a/Makefile
++++ b/Makefile
 @@ -8,12 +8,6 @@ ifeq ($(strip $CC),)
  CC	= gcc
  endif
@@ -79,7 +80,7 @@  Index: git/Makefile
 +              -DRELEASE_DATE='"$(DATE)"'
 +
  SRC_BASE = makedumpfile.c makedumpfile.h diskdump_mod.h sadump_mod.h sadump_info.h
- SRC_PART = print_info.c dwarf_info.c elf_info.c erase_info.c sadump_info.c cache.c tools.c
+ SRC_PART = print_info.c dwarf_info.c elf_info.c erase_info.c sadump_info.c cache.c tools.c printk.c
  OBJ_PART=$(patsubst %.c,%.o,$(SRC_PART))
 @@ -52,12 +53,12 @@ OBJ_ARCH=$(patsubst %.c,%.o,$(SRC_ARCH))
  
@@ -104,7 +105,7 @@  Index: git/Makefile
 +CFLAGS_COMMON += -DUSESNAPPY
  endif
  
- LIBS := -lpthread $(LIBS)
+ LIBS := $(LIBS) -lpthread
 @@ -90,14 +91,14 @@ LIBS := $(LIBS) $(call try-run,\
  all: makedumpfile
  
@@ -122,7 +123,7 @@  Index: git/Makefile
  	echo .TH MAKEDUMPFILE 8 \"$(DATE)\" \"makedumpfile v$(VERSION)\" \"Linux System Administrator\'s Manual\" > temp.8
  	grep -v "^.TH MAKEDUMPFILE 8" $(VPATH)makedumpfile.8 >> temp.8
  	mv temp.8 makedumpfile.8
-@@ -108,7 +109,7 @@ makedumpfile: $(SRC_BASE) $(OBJ_PART) $(
+@@ -108,7 +109,7 @@ makedumpfile: $(SRC_BASE) $(OBJ_PART) $(OBJ_ARCH)
  	gzip -c ./makedumpfile.conf.5 > ./makedumpfile.conf.5.gz
  
  eppic_makedumpfile.so: extension_eppic.c
diff --git a/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.8.bb b/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.9.bb
similarity index 97%
rename from meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.8.bb
rename to meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.9.bb
index 6f87db177..4350ea126 100644
--- a/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.8.bb
+++ b/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.9.bb
@@ -11,7 +11,7 @@  LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
 LICENSE = "GPLv2.0"
 
 SRCBRANCH ?= "master"
-SRCREV = "18e0cdba48feeccea2429b3b0b2691f4314d1062"
+SRCREV = "a9ad811c15e769c8e6d8d915a05cebc32f2ea2f5"
 
 DEPENDS = "bzip2 zlib elfutils xz"
 RDEPENDS_${PN}-tools = "perl ${PN}"