[master/daisy] libav: Add libsdl to DEPENDS only when x11 is enabled

Submitted by Khem Raj on April 19, 2014, 9:59 a.m.

Details

Message ID 1397901568-992-1-git-send-email-raj.khem@gmail.com
State Accepted
Commit fe9fe5ca5039743fc80d14f0518b95929c458b1a
Headers show

Commit Message

Khem Raj April 19, 2014, 9:59 a.m.
When we have opengl in distro features but not x11 and try to
build libav then it calls out to build libsdl which inturn has depependency on libglu
and libglu fails to build

ld: error: cannot find -lGL
| collect2: error: ld returned 1 exit status
| make: *** [libGLU.la] Error 1
| ERROR: oe_runmake failed

since libglu wants glx enabled in mesa and glx in mesa is (righly) enabled only when x11
is in distro features.

This breaks the dependency chain leading to this problem

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-multimedia/libav/libav.inc |    4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Patch hide | download patch | download mbox

diff --git a/meta/recipes-multimedia/libav/libav.inc b/meta/recipes-multimedia/libav/libav.inc
index 5e675be..2152936 100644
--- a/meta/recipes-multimedia/libav/libav.inc
+++ b/meta/recipes-multimedia/libav/libav.inc
@@ -9,7 +9,7 @@  PROVIDES = "ffmpeg"
 
 ARM_INSTRUCTION_SET = "arm"
 
-DEPENDS = "virtual/libsdl zlib libogg libvorbis libtheora yasm-native"
+DEPENDS = "zlib libogg libvorbis libtheora yasm-native"
 
 INC_PR = "r8"
 
@@ -32,7 +32,7 @@  PACKAGECONFIG[x264] = "--enable-libx264,--disable-libx264,x264"
 PACKAGECONFIG[vpx] = "--enable-libvpx,--disable-libvpx,libvpx"
 PACKAGECONFIG[mp3lame] = "--enable-libmp3lame,--disable-libmp3lame,lame"
 PACKAGECONFIG[faac] = "--enable-libfaac,--disable-libfaac,faac"
-PACKAGECONFIG[x11] = "--enable-x11grab,--disable-x11grab,virtual/libx11 libxfixes libxext xproto"
+PACKAGECONFIG[x11] = "--enable-x11grab,--disable-x11grab,virtual/libx11 libxfixes libxext xproto virtual/libsdl"
 
 EXTRA_OECONF = " \
     --enable-shared \