[meta-oe] poppler: Support building for native

Message ID 20220420091216.11337-1-pkj@axis.com
State New
Headers show
Series [meta-oe] poppler: Support building for native | expand

Commit Message

Peter Kjellerstedt April 20, 2022, 9:12 a.m. UTC
* Disable RUN_GPERF_IF_PRESENT. Otherwise cmake will look for gperf. For
  target, it will not find it and proceeds to use the pregenerated
  files. However, for native it finds `/usr/bin/gperf`, but then tries
  to run `gperf` instead, which fails since it is not in hosttools.
* Disable ENABLE_CPP for native. Otherwise it needs iconv, which it
  cannot find.

Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
---
 meta-oe/recipes-support/poppler/poppler_22.04.0.bb | 4 ++++
 1 file changed, 4 insertions(+)

Patch

diff --git a/meta-oe/recipes-support/poppler/poppler_22.04.0.bb b/meta-oe/recipes-support/poppler/poppler_22.04.0.bb
index 9c9122160..b7cdb4f1b 100644
--- a/meta-oe/recipes-support/poppler/poppler_22.04.0.bb
+++ b/meta-oe/recipes-support/poppler/poppler_22.04.0.bb
@@ -33,9 +33,11 @@  EXTRA_OECMAKE += " \
     -DENABLE_UNSTABLE_API_ABI_HEADERS=ON \
     -DBUILD_GTK_TESTS=OFF \
     -DENABLE_ZLIB=ON \
+    -DRUN_GPERF_IF_PRESENT=OFF \
     -DCMAKE_CXX_IMPLICIT_INCLUDE_DIRECTORIES:PATH='${STAGING_INCDIR}' \
     ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DENABLE_GOBJECT_INTROSPECTION=ON', '-DENABLE_GOBJECT_INTROSPECTION=OFF', d)} \
 "
+EXTRA_OECMAKE:append:class-native = " -DENABLE_CPP=OFF"
 
 do_configure:append() {
     # poppler macro uses pkg-config to check for g-ir runtimes. Something
@@ -49,3 +51,5 @@  FILES:libpoppler = "${libdir}/libpoppler.so.*"
 FILES:libpoppler-glib = "${libdir}/libpoppler-glib.so.*"
 
 RDEPENDS:libpoppler = "poppler-data"
+
+BBCLASSEXTEND = "native"