glib-2.0-native: Fix DEPENDS

Submitted by Richard Purdie on March 24, 2014, 1:58 p.m.

Details

Message ID 1395669481.24232.59.camel@ted
State Accepted
Commit f7fd641c13543f0df412fe0ff01238734ddbbaff
Headers show

Commit Message

Richard Purdie March 24, 2014, 1:58 p.m.
Address the error

| checking for ZLIB... no
| checking for inflate in -lz... no
| configure: error: *** Working zlib library and headers not found ***

by ensuring zlib-native is in DEPENDS.

[YOCTO #5773]

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---

Patch hide | download patch | download mbox

diff --git a/meta/recipes-core/glib-2.0/glib.inc b/meta/recipes-core/glib-2.0/glib.inc
index 33d30c1..cb07665 100644
--- a/meta/recipes-core/glib-2.0/glib.inc
+++ b/meta/recipes-core/glib-2.0/glib.inc
@@ -17,7 +17,7 @@  BBCLASSEXTEND = "native nativesdk"
 
 DEPENDS = "glib-2.0-native virtual/libiconv libffi zlib"
 DEPENDS_append_class-target = "${@base_contains('DISTRO_FEATURES', 'ptest', ' dbus', '', d)}"
-DEPENDS_class-native = "pkgconfig-native gettext-native libffi-native"
+DEPENDS_class-native = "pkgconfig-native gettext-native libffi-native zlib-native"
 DEPENDS_class-nativesdk = "nativesdk-libtool nativesdk-libffi nativesdk-zlib ${BPN}-native"
 
 PACKAGES =+ "${PN}-utils ${PN}-bash-completion ${PN}-codegen"