[meta-oe] gnuplot: inherit pkgconfig

Message ID 20220419162825.2202995-1-preeti.sachan@intel.com
State New
Headers show
Series [meta-oe] gnuplot: inherit pkgconfig | expand

Commit Message

preeti.sachan@intel.com April 19, 2022, 4:28 p.m. UTC
From: Preeti Sachan <preeti.sachan@intel.com>

Inherited pkgconfig to fix pngcairo terminal compilation enabled
by default with pkgconfig option PACKAGECONFIG[cairo]

Signed-off-by: Preeti Sachan <preeti.sachan@intel.com>
---
 meta-oe/recipes-extended/gnuplot/gnuplot_5.4.3.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

preeti.sachan@intel.com April 19, 2022, 4:31 p.m. UTC | #1
This patch is to fix do_configure issue for cairo.

*configure log:*
checking for CAIROPDF... configure: WARNING:
*The pkg-config script could not be found or is too old.  Make sure it*
*is in your PATH or set the PKG_CONFIG environment variable to the full*
*path to pkg-config.*

Alternatively, you may set the environment variables CAIROPDF_CFLAGS
and CAIROPDF_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

To get pkg-config, see <http://www.freedesktop.org/software/pkgconfig>.
*configure: WARNING: The cairo terminals will not be compiled.*

Patch

diff --git a/meta-oe/recipes-extended/gnuplot/gnuplot_5.4.3.bb b/meta-oe/recipes-extended/gnuplot/gnuplot_5.4.3.bb
index 7343a08c7..fe5e5c067 100644
--- a/meta-oe/recipes-extended/gnuplot/gnuplot_5.4.3.bb
+++ b/meta-oe/recipes-extended/gnuplot/gnuplot_5.4.3.bb
@@ -7,7 +7,7 @@  LICENSE = "gnuplot"
 LIC_FILES_CHKSUM = "file://Copyright;md5=243a186fc2fd3b992125d60d5b1bab8f"
 DEPENDS = "${BPN}-native virtual/libx11 gd readline"
 
-inherit autotools features_check
+inherit autotools features_check pkgconfig
 # depends on virtual/libx11
 REQUIRED_DISTRO_FEATURES = "x11"