[meta-ti,master/dunfell] ti-graphics: Add j7-hs-evm as a compatible machine.

Message ID 20220418222026.3201-1-reatmon@ti.com
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series [meta-ti,master/dunfell] ti-graphics: Add j7-hs-evm as a compatible machine. | expand

Commit Message

Ryan Eatmon April 18, 2022, 10:20 p.m. UTC
The recent change to explicitly list the compatible machines is missing the j7-hs-evm.

Signed-off-by: Ryan Eatmon <reatmon@ti.com>
---
 .../powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb       | 4 +++-
 recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb  | 3 ++-
 2 files changed, 5 insertions(+), 2 deletions(-)

Comments

Andrew Davis April 20, 2022, 3:14 a.m. UTC | #1
On 4/18/22 5:20 PM, Ryan Eatmon via lists.yoctoproject.org wrote:
> The recent change to explicitly list the compatible machines is missing the j7-hs-evm.
> 
> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
> ---
>   .../powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb       | 4 +++-
>   recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb  | 3 ++-
>   2 files changed, 5 insertions(+), 2 deletions(-)
> 
> diff --git a/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb b/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb
> index fbff6c51..6d2d68cd 100644
> --- a/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb
> +++ b/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb
> @@ -11,7 +11,7 @@ MACHINE_KERNEL_PR_append = "a"
>   PR = "${MACHINE_KERNEL_PR}"
>   
>   PACKAGE_ARCH = "${MACHINE_ARCH}"
> -COMPATIBLE_MACHINE = "j7-evm|j721s2-evm|am62xx"
> +COMPATIBLE_MACHINE = "j7-evm|j7-hs-evm|j721s2-evm|am62xx"


Doesn't seem right, we haven't needed to specify the HS version before..

Seems we are mixing SoC and board, the GPU driver depends on the SoC
not the board, we match correctly for am62xx on SoC, but J7 on
specific board name. Suggest

+COMPATIBLE_MACHINE = "j7|j721s2|am62xx"

Andrew


>   
>   DEPENDS = "virtual/kernel"
>   
> @@ -29,9 +29,11 @@ S = "${WORKDIR}/git"
>   SRCREV = "ee0674adccac16f5b2f7cb8d5d05948706080cb5"
>   
>   TARGET_PRODUCT_j7-evm = "j721e_linux"
> +TARGET_PRODUCT_j7-hs-evm = "j721e_linux"
>   TARGET_PRODUCT_j721s2-evm = "j721s2_linux"
>   TARGET_PRODUCT_am62xx = "am62_linux"
>   TARGET_BVNC_j7-evm = "22.104.208.318"
> +TARGET_BVNC_j7-hs-evm = "22.104.208.318"
>   TARGET_BVNC_j721s2-evm = "36.53.104.796"
>   TARGET_BVNC_am62xx = "33.15.11.3"
>   PVR_BUILD = "release"
> diff --git a/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb b/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb
> index e00dce99..0f3f9192 100644
> --- a/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb
> +++ b/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb
> @@ -8,7 +8,7 @@ inherit features_check
>   REQUIRED_MACHINE_FEATURES = "gpu"
>   
>   PACKAGE_ARCH = "${MACHINE_ARCH}"
> -COMPATIBLE_MACHINE = "j7-evm|j721s2-evm|am62xx"
> +COMPATIBLE_MACHINE = "j7-evm|j7-hs-evm|j721s2-evm|am62xx"
>   
>   PR = "r1"
>   
> @@ -18,6 +18,7 @@ SRC_URI = "git://git.ti.com/graphics/ti-img-rogue-umlibs.git;branch=${BRANCH}"
>   SRCREV = "47c3ffc44f2881397d45c8a2b5dfa7d6c58b79fb"
>   
>   TARGET_PRODUCT_j7-evm = "j721e_linux"
> +TARGET_PRODUCT_j7-hs-evm = "j721e_linux"
>   TARGET_PRODUCT_j721s2-evm = "j721s2_linux"
>   TARGET_PRODUCT_am62xx = "am62_linux"
>   PVR_BUILD ?= "release"
> 
> 
> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#14603): https://lists.yoctoproject.org/g/meta-ti/message/14603
> Mute This Topic: https://lists.yoctoproject.org/mt/90550375/3619733
> Group Owner: meta-ti+owner@lists.yoctoproject.org
> Unsubscribe: https://lists.yoctoproject.org/g/meta-ti/unsub [afd@ti.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Denys Dmytriyenko April 20, 2022, 12:26 p.m. UTC | #2
On Tue, Apr 19, 2022 at 10:14:16PM -0500, Andrew F. Davis via lists.yoctoproject.org wrote:
> On 4/18/22 5:20 PM, Ryan Eatmon via lists.yoctoproject.org wrote:
> >The recent change to explicitly list the compatible machines is missing the j7-hs-evm.
> >
> >Signed-off-by: Ryan Eatmon <reatmon@ti.com>
> >---
> >  .../powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb       | 4 +++-
> >  recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb  | 3 ++-
> >  2 files changed, 5 insertions(+), 2 deletions(-)
> >
> >diff --git a/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb b/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb
> >index fbff6c51..6d2d68cd 100644
> >--- a/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb
> >+++ b/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb
> >@@ -11,7 +11,7 @@ MACHINE_KERNEL_PR_append = "a"
> >  PR = "${MACHINE_KERNEL_PR}"
> >  PACKAGE_ARCH = "${MACHINE_ARCH}"
> >-COMPATIBLE_MACHINE = "j7-evm|j721s2-evm|am62xx"
> >+COMPATIBLE_MACHINE = "j7-evm|j7-hs-evm|j721s2-evm|am62xx"
> 
> 
> Doesn't seem right, we haven't needed to specify the HS version before..

https://git.yoctoproject.org/meta-ti/commit/?h=dunfell&id=ed94c75b436f2f8c5c3a8a6ebed45d7276cc35e4


> Seems we are mixing SoC and board, the GPU driver depends on the SoC
> not the board, we match correctly for am62xx on SoC, but J7 on
> specific board name. Suggest
> 
> +COMPATIBLE_MACHINE = "j7|j721s2|am62xx"

There's no j721s2 SoC family in Dunfell.

I'm guessing "j7-evm|j7-hs-evm|j721s2-evm" was done because j7 SoC family in 
Dunfell is too broad and also covers headless j7200, which lacks "gpu" machine 
feature... Could be just "j7|am62xx" in Dunfell and more specific SoC families 
in master/kirkstone.

Patch

diff --git a/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb b/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb
index fbff6c51..6d2d68cd 100644
--- a/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb
+++ b/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb
@@ -11,7 +11,7 @@  MACHINE_KERNEL_PR_append = "a"
 PR = "${MACHINE_KERNEL_PR}"
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"
-COMPATIBLE_MACHINE = "j7-evm|j721s2-evm|am62xx"
+COMPATIBLE_MACHINE = "j7-evm|j7-hs-evm|j721s2-evm|am62xx"
 
 DEPENDS = "virtual/kernel"
 
@@ -29,9 +29,11 @@  S = "${WORKDIR}/git"
 SRCREV = "ee0674adccac16f5b2f7cb8d5d05948706080cb5"
 
 TARGET_PRODUCT_j7-evm = "j721e_linux"
+TARGET_PRODUCT_j7-hs-evm = "j721e_linux"
 TARGET_PRODUCT_j721s2-evm = "j721s2_linux"
 TARGET_PRODUCT_am62xx = "am62_linux"
 TARGET_BVNC_j7-evm = "22.104.208.318"
+TARGET_BVNC_j7-hs-evm = "22.104.208.318"
 TARGET_BVNC_j721s2-evm = "36.53.104.796"
 TARGET_BVNC_am62xx = "33.15.11.3"
 PVR_BUILD = "release"
diff --git a/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb b/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb
index e00dce99..0f3f9192 100644
--- a/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb
+++ b/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb
@@ -8,7 +8,7 @@  inherit features_check
 REQUIRED_MACHINE_FEATURES = "gpu"
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"
-COMPATIBLE_MACHINE = "j7-evm|j721s2-evm|am62xx"
+COMPATIBLE_MACHINE = "j7-evm|j7-hs-evm|j721s2-evm|am62xx"
 
 PR = "r1"
 
@@ -18,6 +18,7 @@  SRC_URI = "git://git.ti.com/graphics/ti-img-rogue-umlibs.git;branch=${BRANCH}"
 SRCREV = "47c3ffc44f2881397d45c8a2b5dfa7d6c58b79fb"
 
 TARGET_PRODUCT_j7-evm = "j721e_linux"
+TARGET_PRODUCT_j7-hs-evm = "j721e_linux"
 TARGET_PRODUCT_j721s2-evm = "j721s2_linux"
 TARGET_PRODUCT_am62xx = "am62_linux"
 PVR_BUILD ?= "release"