[meta-oe,dunfell] mongodb: Pass OBJCOPY to scons so it does not use it from host

Message ID 20220417155638.3304469-1-akuster808@gmail.com
State New
Headers show
Series [meta-oe,dunfell] mongodb: Pass OBJCOPY to scons so it does not use it from host | expand

Commit Message

akuster808 April 17, 2022, 3:56 p.m. UTC
From: Khem Raj <raj.khem@gmail.com>

Fixes
objcopy: Unable to recognise the format of the input file `build/opt/mongo/mongos'

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Cc: Vincent Prince <vincent.prince.fr@gmail.com.com>
(cherry picked from commit e91940073af4e19cd18a09cd12aa381ff60fe54b)
[Fix up for Dunfell context:
also fixes Please add a conforming MONGO_VERSION=x.y.z[-extra] as an argument to SCons]
Signed-off-by: Armin Kuster <akuster808@gmail.com>
---
 .../meta-python/recipes-dbs/mongodb/mongodb_git.bb              | 2 ++
 1 file changed, 2 insertions(+)

Patch

diff --git a/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb b/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb
index 7ef8f69827..cc15a8de31 100644
--- a/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb
+++ b/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb
@@ -56,6 +56,8 @@  EXTRA_OESCONS = "--prefix=${D}${prefix} \
                  LINKFLAGS='${LDFLAGS}' \
                  CXXFLAGS='${CXXFLAGS}' \
                  TARGET_ARCH=${TARGET_ARCH} \
+                 MONGO_VERSION=${PV} \
+                 OBJCOPY=${OBJCOPY} \
                  --ssl \
                  --disable-warnings-as-errors \
                  --use-system-zlib \