[meta-oe] wxwidgets: Fix build without x11 and with opengl DISTRO_FEATURES

Message ID 20220409194644.78969-1-marex@denx.de
State New
Headers show
Series [meta-oe] wxwidgets: Fix build without x11 and with opengl DISTRO_FEATURES | expand

Commit Message

Marek Vasut April 9, 2022, 7:46 p.m. UTC
In case DISTRO_FEATURES contains both 'x11' and 'opengl', which is a
valid use case for systems using e.g. WL instead, the PACKAGECONFIG
of this recipe is expanded to 'no_gui opengl', and the 'no_gui' option
conflicts with 'opengl'.

Adjust the default PACKAGECONFIG such that 'opengl' is added only in
case the 'gtk' GUI option is added, and not when the 'no_gui' option
is added.

Signed-off-by: Marek Vasut <marex@denx.de>
---
 meta-oe/recipes-extended/wxwidgets/wxwidgets_3.1.5.bb | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

Comments

Marek Vasut April 9, 2022, 11:21 p.m. UTC | #1
On 4/9/22 21:53, Khem Raj wrote:
> There is already a patch staged in master-next
> 
> https://lists.openembedded.org/g/openembedded-devel/message/96479
> 
> does that solve the problem?

That patch from Scott is even better, thanks !

Patch

diff --git a/meta-oe/recipes-extended/wxwidgets/wxwidgets_3.1.5.bb b/meta-oe/recipes-extended/wxwidgets/wxwidgets_3.1.5.bb
index e82143040..0c0c8417b 100644
--- a/meta-oe/recipes-extended/wxwidgets/wxwidgets_3.1.5.bb
+++ b/meta-oe/recipes-extended/wxwidgets/wxwidgets_3.1.5.bb
@@ -44,8 +44,7 @@  EXTRA_OECMAKE:append:libc-musl = " \
 "
 
 # All toolkit-configs except 'no_gui' require x11 explicitly (see toolkit.cmake)
-PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'gtk', 'no_gui', d)} \
-    ${@bb.utils.filter('DISTRO_FEATURES', 'opengl', d)} \
+PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'gtk ' + bb.utils.filter('DISTRO_FEATURES', 'opengl', d), 'no_gui', d)} \
 "
 
 PACKAGECONFIG:remove:class-native = "opengl"