webkitgtk: Add missing header locale.h

Message ID 20220409063325.3252179-1-raj.khem@gmail.com
State Accepted, archived
Commit 08c06980648d3f72cddbf62a96d6915f5d54b94e
Headers show
Series webkitgtk: Add missing header locale.h | expand

Commit Message

Khem Raj April 9, 2022, 6:33 a.m. UTC
This fixes build issues seen on mips, but problem is generic

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 .../webkitgtk/add_missing_include.patch       | 19 +++++++++++++++++++
 meta/recipes-sato/webkit/webkitgtk_2.36.0.bb  |  1 +
 2 files changed, 20 insertions(+)
 create mode 100644 meta/recipes-sato/webkit/webkitgtk/add_missing_include.patch

Comments

Alexander Kanavin April 9, 2022, 7:05 a.m. UTC | #1
Can you submit upstream please?

Alex

On Sat 9. Apr 2022 at 8.33, Khem Raj <raj.khem@gmail.com> wrote:

> This fixes build issues seen on mips, but problem is generic
>
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> ---
>  .../webkitgtk/add_missing_include.patch       | 19 +++++++++++++++++++
>  meta/recipes-sato/webkit/webkitgtk_2.36.0.bb  |  1 +
>  2 files changed, 20 insertions(+)
>  create mode 100644
> meta/recipes-sato/webkit/webkitgtk/add_missing_include.patch
>
> diff --git a/meta/recipes-sato/webkit/webkitgtk/add_missing_include.patch
> b/meta/recipes-sato/webkit/webkitgtk/add_missing_include.patch
> new file mode 100644
> index 00000000000..e60c317a26f
> --- /dev/null
> +++ b/meta/recipes-sato/webkit/webkitgtk/add_missing_include.patch
> @@ -0,0 +1,19 @@
> +Include locale.h for LC_MESSAGE definition
> +
> +This fixes build error
> +Source/WebCore/accessibility/atspi/AccessibilityRootAtspi.cpp:115:51:
> error: use of undeclared identifier 'LC_MESSAGES'
> +            return g_variant_new_string(setlocale(LC_MESSAGES, nullptr));
> +                                                  ^
> +Upstream-Status: Pending
> +Signed-off-by: Khem Raj <raj.khem@gmail.com>
> +
> +--- a/Source/WebCore/accessibility/atspi/AccessibilityRootAtspi.cpp
> ++++ b/Source/WebCore/accessibility/atspi/AccessibilityRootAtspi.cpp
> +@@ -30,6 +30,7 @@
> + #include "FrameView.h"
> + #include "Page.h"
> + #include <glib/gi18n-lib.h>
> ++#include <locale.h>
> +
> + namespace WebCore {
> +
> diff --git a/meta/recipes-sato/webkit/webkitgtk_2.36.0.bb
> b/meta/recipes-sato/webkit/webkitgtk_2.36.0.bb
> index 09d44933706..db8a565511a 100644
> --- a/meta/recipes-sato/webkit/webkitgtk_2.36.0.bb
> +++ b/meta/recipes-sato/webkit/webkitgtk_2.36.0.bb
> @@ -15,6 +15,7 @@ SRC_URI = "
> https://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \
>             file://0001-Fix-build-without-opengl-or-es.patch \
>             file://reproducibility.patch \
>
> file://0001-When-building-introspection-files-do-not-quote-CFLAG.patch \
> +           file://add_missing_include.patch \
>             "
>
>  SRC_URI[sha256sum] =
> "b877cca1f105235f5dd57c7ac2b2c2be3c6b691ff444f93925c7254cf156c64d"
> --
> 2.35.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#164185):
> https://lists.openembedded.org/g/openembedded-core/message/164185
> Mute This Topic: https://lists.openembedded.org/mt/90352028/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>

Patch

diff --git a/meta/recipes-sato/webkit/webkitgtk/add_missing_include.patch b/meta/recipes-sato/webkit/webkitgtk/add_missing_include.patch
new file mode 100644
index 00000000000..e60c317a26f
--- /dev/null
+++ b/meta/recipes-sato/webkit/webkitgtk/add_missing_include.patch
@@ -0,0 +1,19 @@ 
+Include locale.h for LC_MESSAGE definition
+
+This fixes build error
+Source/WebCore/accessibility/atspi/AccessibilityRootAtspi.cpp:115:51: error: use of undeclared identifier 'LC_MESSAGES'
+            return g_variant_new_string(setlocale(LC_MESSAGES, nullptr));
+                                                  ^
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+--- a/Source/WebCore/accessibility/atspi/AccessibilityRootAtspi.cpp
++++ b/Source/WebCore/accessibility/atspi/AccessibilityRootAtspi.cpp
+@@ -30,6 +30,7 @@
+ #include "FrameView.h"
+ #include "Page.h"
+ #include <glib/gi18n-lib.h>
++#include <locale.h>
+ 
+ namespace WebCore {
+ 
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.36.0.bb b/meta/recipes-sato/webkit/webkitgtk_2.36.0.bb
index 09d44933706..db8a565511a 100644
--- a/meta/recipes-sato/webkit/webkitgtk_2.36.0.bb
+++ b/meta/recipes-sato/webkit/webkitgtk_2.36.0.bb
@@ -15,6 +15,7 @@  SRC_URI = "https://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \
            file://0001-Fix-build-without-opengl-or-es.patch \
            file://reproducibility.patch \
            file://0001-When-building-introspection-files-do-not-quote-CFLAG.patch \
+           file://add_missing_include.patch \
            "
 
 SRC_URI[sha256sum] = "b877cca1f105235f5dd57c7ac2b2c2be3c6b691ff444f93925c7254cf156c64d"