[PATCHv2,02/14] libunique: Add PACKAGECONFIG for dbus

Submitted by Martin Jansa on Oct. 5, 2013, 12:22 p.m.

Details

Message ID cad7bd95c628ae8fa3d3990f6ee1f2fb21203809.1380975568.git.Martin.Jansa@gmail.com
State Accepted, archived
Headers show

Commit Message

Martin Jansa Oct. 5, 2013, 12:22 p.m.
* dbus-glib was missing in DEPENDS in order to enable dbus backend
  but because dbus was in DEPENDS lets enable this PACKAGECONFIG by
  default

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
---
 meta/recipes-gnome/libunique/libunique_1.1.6.bb | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

Patch hide | download patch | download mbox

diff --git a/meta/recipes-gnome/libunique/libunique_1.1.6.bb b/meta/recipes-gnome/libunique/libunique_1.1.6.bb
index adb9525..31af658 100644
--- a/meta/recipes-gnome/libunique/libunique_1.1.6.bb
+++ b/meta/recipes-gnome/libunique/libunique_1.1.6.bb
@@ -12,7 +12,10 @@  SRC_URI[sha256sum] = "e5c8041cef8e33c55732f06a292381cb345db946cf792a4ae18aa5c66c
 
 PR = "r7"
 
-DEPENDS = "glib-2.0 gtk+ dbus"
+DEPENDS = "glib-2.0 gtk+"
+
+PACKAGECONFIG ??= "dbus"
+PACKAGECONFIG[dbus] = "--enable-dbus,--disable-dbus,dbus dbus-glib"
 
 LICENSE = "LGPLv2.1"
 LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"