[1/7] arm/fvp: generalise FVP_ARCH

Message ID 20220325134853.3068169-1-ross.burton@arm.com
State New
Headers show
Series [1/7] arm/fvp: generalise FVP_ARCH | expand

Commit Message

Ross Burton March 25, 2022, 1:48 p.m. UTC
Use wildcards in the FVP_ARCH assignment, as older FVPs use _GCC-6.4
whilst newer FVPs use _GCC-9.3.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta-arm/recipes-devtools/fvp/fvp-base-r-aem.bb   | 1 -
 meta-arm/recipes-devtools/fvp/fvp-common.inc      | 4 +++-
 meta-arm/recipes-devtools/fvp/fvp-corstone1000.bb | 2 --
 3 files changed, 3 insertions(+), 4 deletions(-)

Comments

Jon Mason March 29, 2022, 1:40 a.m. UTC | #1
On Fri, 25 Mar 2022 13:48:47 +0000, Ross Burton wrote:
> Use wildcards in the FVP_ARCH assignment, as older FVPs use _GCC-6.4
> whilst newer FVPs use _GCC-9.3.

Applied, thanks!

[1/7] arm/fvp: generalise FVP_ARCH
      commit: 966d3ec03191e56b5a91eaa018c2786a853af904
[2/7] arm/fvp-base-a-aem: upgrade to latest release, 11.17.21
      commit: 22282ea8931b045e528f96f19cf7fe6c8483fedd
[3/7] arm/fvp: add more helper variables for the versioning
      commit: d47e6a89e1b8694a8c26edf23a8713118cfdd815
[4/7] arm-bsp/fvp-arm32: synchonise kernel config
      commit: 0e9df5afbb289207cb71db46912f551b32031e3d
[5/7] arm-bsp/fvp-base-arm32: use correct DeviceTree
      commit: 4ab912828eeeacc0630d08eb5a2d6fc2aa8b9ef1
[6/7] CI: fix random testimage failures
      (no commit info)
[7/7] CI: run testimage on fvp-base-arm32
      commit: 4c66c6dfd6561bd7b63797d079cceb5bfd392d0c

Best regards,

Patch

diff --git a/meta-arm/recipes-devtools/fvp/fvp-base-r-aem.bb b/meta-arm/recipes-devtools/fvp/fvp-base-r-aem.bb
index 911cc00a..f21ccae3 100644
--- a/meta-arm/recipes-devtools/fvp/fvp-base-r-aem.bb
+++ b/meta-arm/recipes-devtools/fvp/fvp-base-r-aem.bb
@@ -9,7 +9,6 @@  LIC_FILES_CHKSUM = "file://license_terms/license_agreement.txt;md5=1a33828e132ba
 # (for example, file:///home/user/FVP_Base_AEMv8R_11.17_21.tgz).
 FVP_BASE_R_AEM_TARBALL_URI ?= ""
 PV = "11.17.21"
-FVP_ARCH = "Linux64_GCC-9.3"
 
 SRC_URI = "${FVP_BASE_R_AEM_TARBALL_URI};subdir=${BP}"
 python() {
diff --git a/meta-arm/recipes-devtools/fvp/fvp-common.inc b/meta-arm/recipes-devtools/fvp/fvp-common.inc
index 9667892b..cf6cad04 100644
--- a/meta-arm/recipes-devtools/fvp/fvp-common.inc
+++ b/meta-arm/recipes-devtools/fvp/fvp-common.inc
@@ -7,7 +7,9 @@  LICENSE_FLAGS = "Arm-FVP-EULA"
 LICENSE = "Proprietary & Apache-2.0 & Python-2.0 & GPL-3.0-with-GCC-exception & Zlib & NCSA & LGPL-2.0-or-later & MIT & BSD-3-Clause"
 
 COMPATIBLE_HOST = '(x86_64|i.86).*-linux'
-FVP_ARCH = "Linux64_GCC-6.4"
+
+# The architecture-specific directory the binaries are installed under
+FVP_ARCH = "Linux64_GCC-*"
 
 def get_real_pv(d):
     # FVP versions are like 11.12_43
diff --git a/meta-arm/recipes-devtools/fvp/fvp-corstone1000.bb b/meta-arm/recipes-devtools/fvp/fvp-corstone1000.bb
index dcb6b7d1..b7b22f12 100644
--- a/meta-arm/recipes-devtools/fvp/fvp-corstone1000.bb
+++ b/meta-arm/recipes-devtools/fvp/fvp-corstone1000.bb
@@ -10,5 +10,3 @@  SRC_URI[sha256sum] = "00ccb72d02c90e2424d24a625d275cabf8ea8dc024713985208f618bb8
 LIC_FILES_CHKSUM = "file://license_terms/license_agreement.txt;md5=1a33828e132ba71861c11688dbb0bd16 \
                     file://license_terms/third_party_licenses.txt;md5=41029e71051b1c786bae3112a29905a7"
 
-FVP_ARCH = "Linux64_GCC-9.3"
-