rng-tools: enable macro JENT_CONF_ENABLE_INTERNAL_TIMER

Message ID 1648022502-11770-1-git-send-email-wangmy@fujitsu.com
State Accepted, archived
Commit e9fac3b6d32262e489992b116275d3eabcc35b4a
Headers show
Series rng-tools: enable macro JENT_CONF_ENABLE_INTERNAL_TIMER | expand

Commit Message

Mingyu Wang (Fujitsu) March 23, 2022, 8:01 a.m. UTC
do_compile error :
| ../git/rngd_jitter.c: In function 'rngd_notime_start':
| ../git/rngd_jitter.c:56:45: error: invalid use of undefined type 'struct jent_notime_ctx'
|    56 |         ret = -pthread_attr_init(&thread_ctx->notime_pthread_attr);

enable macro JENT_CONF_ENABLE_INTERNAL_TIMER to use struct jent_notime_ctx

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 meta/recipes-support/rng-tools/rng-tools_6.15.bb | 2 ++
 1 file changed, 2 insertions(+)

Comments

Alexander Kanavin March 23, 2022, 8:39 a.m. UTC | #1
This error is not seen on the autobuilder, can you please check why it
occurs only in your local setup? The macro probably needs to be
enabled in a more targeted way.

Alex

On Wed, 23 Mar 2022 at 09:02, wangmy <wangmy@fujitsu.com> wrote:
>
> do_compile error :
> | ../git/rngd_jitter.c: In function 'rngd_notime_start':
> | ../git/rngd_jitter.c:56:45: error: invalid use of undefined type 'struct jent_notime_ctx'
> |    56 |         ret = -pthread_attr_init(&thread_ctx->notime_pthread_attr);
>
> enable macro JENT_CONF_ENABLE_INTERNAL_TIMER to use struct jent_notime_ctx
>
> Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
> ---
>  meta/recipes-support/rng-tools/rng-tools_6.15.bb | 2 ++
>  1 file changed, 2 insertions(+)
>
> diff --git a/meta/recipes-support/rng-tools/rng-tools_6.15.bb b/meta/recipes-support/rng-tools/rng-tools_6.15.bb
> index ae974f9f6f..0696351903 100644
> --- a/meta/recipes-support/rng-tools/rng-tools_6.15.bb
> +++ b/meta/recipes-support/rng-tools/rng-tools_6.15.bb
> @@ -34,6 +34,8 @@ INITSCRIPT_PARAMS = "start 03 2 3 4 5 . stop 30 0 6 1 ."
>
>  SYSTEMD_SERVICE:${PN} = "rngd.service"
>
> +CFLAGS += " -DJENT_CONF_ENABLE_INTERNAL_TIMER "
> +
>  # Refer autogen.sh in rng-tools
>  do_configure:prepend() {
>      cp ${S}/README.md ${S}/README
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#163579): https://lists.openembedded.org/g/openembedded-core/message/163579
> Mute This Topic: https://lists.openembedded.org/mt/89971134/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Alexander Kanavin March 23, 2022, 9:01 a.m. UTC | #2
Please keep the replies on the mailing list. This patch should
probably be merged with the libjitterentropy update?

Alex


On Wed, 23 Mar 2022 at 09:55, wangmy@fujitsu.com <wangmy@fujitsu.com> wrote:
>
> After libjitterentropy is updated to 3.4, a macro JENT_CONF_ENABLE_INTERNAL_TIMER is added to jitterentropy.h used to control struct jent_notime_ct.
> rng-tools needs this struct, so it's need to make this macro enable.
>
>   --
> Best Regards
> ---------------------------------------------------
> Wang Mingyu
> Development Dept.I
> Nanjing Fujitsu Nanda Software Tech. Co., Ltd.(FNST) No. 6 Wenzhu Road, Nanjing, 210012, China
> TEL: +86+25-86630566-8568
> COINS: 79988548
> FAX: +86+25-83317685
> MAIL: wangmy@fujitsu.com
> http://www.fujitsu.com/cn/fnst/
>
> > -----Original Message-----
> > From: Alexander Kanavin <alex.kanavin@gmail.com>
> > Sent: Wednesday, March 23, 2022 4:40 PM
> > To: Wang, Mingyu/王 鸣瑜 <wangmy@fujitsu.com>
> > Cc: OE-core <openembedded-core@lists.openembedded.org>
> > Subject: Re: [OE-core] [PATCH] rng-tools: enable macro
> > JENT_CONF_ENABLE_INTERNAL_TIMER
> >
> > This error is not seen on the autobuilder, can you please check why it
> > occurs only in your local setup? The macro probably needs to be enabled
> > in a more targeted way.
> >
> > Alex
> >
> > On Wed, 23 Mar 2022 at 09:02, wangmy <wangmy@fujitsu.com> wrote:
> > >
> > > do_compile error :
> > > | ../git/rngd_jitter.c: In function 'rngd_notime_start':
> > > | ../git/rngd_jitter.c:56:45: error: invalid use of undefined type 'struct
> > jent_notime_ctx'
> > > |    56 |         ret =
> > -pthread_attr_init(&thread_ctx->notime_pthread_attr);
> > >
> > > enable macro JENT_CONF_ENABLE_INTERNAL_TIMER to use struct
> > > jent_notime_ctx
> > >
> > > Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
> > > ---
> > >  meta/recipes-support/rng-tools/rng-tools_6.15.bb | 2 ++
> > >  1 file changed, 2 insertions(+)
> > >
> > > diff --git a/meta/recipes-support/rng-tools/rng-tools_6.15.bb
> > > b/meta/recipes-support/rng-tools/rng-tools_6.15.bb
> > > index ae974f9f6f..0696351903 100644
> > > --- a/meta/recipes-support/rng-tools/rng-tools_6.15.bb
> > > +++ b/meta/recipes-support/rng-tools/rng-tools_6.15.bb
> > > @@ -34,6 +34,8 @@ INITSCRIPT_PARAMS = "start 03 2 3 4 5 . stop 30 0 6
> > 1 ."
> > >
> > >  SYSTEMD_SERVICE:${PN} = "rngd.service"
> > >
> > > +CFLAGS += " -DJENT_CONF_ENABLE_INTERNAL_TIMER "
> > > +
> > >  # Refer autogen.sh in rng-tools
> > >  do_configure:prepend() {
> > >      cp ${S}/README.md ${S}/README
> > > --
> > > 2.25.1
> > >
> > >
> > > -=-=-=-=-=-=-=-=-=-=-=-
> > > Links: You receive all messages sent to this group.
> > > View/Reply Online (#163579):
> > >
> > https://lists.openembedded.org/g/openembedded-core/message/163579
> > > Mute This Topic: https://lists.openembedded.org/mt/89971134/1686489
> > > Group Owner: openembedded-core+owner@lists.openembedded.org
> > > Unsubscribe:
> > https://lists.openembedded.org/g/openembedded-core/unsub
> > > [alex.kanavin@gmail.com]
> > > -=-=-=-=-=-=-=-=-=-=-=-
> > >
Mingyu Wang (Fujitsu) March 23, 2022, 9:19 a.m. UTC | #3
Yes, if libjitterentropy is updated, rng-tools must be modified, otherwise do_compile errors will occur

  --
Best Regards
---------------------------------------------------
Wang Mingyu
Development Dept.I
Nanjing Fujitsu Nanda Software Tech. Co., Ltd.(FNST) No. 6 Wenzhu Road, Nanjing, 210012, China
TEL: +86+25-86630566-8568
COINS: 79988548
FAX: +86+25-83317685
MAIL: wangmy@fujitsu.com
http://www.fujitsu.com/cn/fnst/

> -----Original Message-----
> From: Alexander Kanavin <alex.kanavin@gmail.com>
> Sent: Wednesday, March 23, 2022 5:02 PM
> To: Wang, Mingyu/王 鸣瑜 <wangmy@fujitsu.com>; OE-core
> <openembedded-core@lists.openembedded.org>
> Subject: Re: [OE-core] [PATCH] rng-tools: enable macro
> JENT_CONF_ENABLE_INTERNAL_TIMER
> 
> Please keep the replies on the mailing list. This patch should probably be
> merged with the libjitterentropy update?
> 
> Alex
> 
> 
> On Wed, 23 Mar 2022 at 09:55, wangmy@fujitsu.com
> <wangmy@fujitsu.com> wrote:
> >
> > After libjitterentropy is updated to 3.4, a macro
> JENT_CONF_ENABLE_INTERNAL_TIMER is added to jitterentropy.h used to
> control struct jent_notime_ct.
> > rng-tools needs this struct, so it's need to make this macro enable.
> >
> >   --
> > Best Regards
> > ---------------------------------------------------
> > Wang Mingyu
> > Development Dept.I
> > Nanjing Fujitsu Nanda Software Tech. Co., Ltd.(FNST) No. 6 Wenzhu
> > Road, Nanjing, 210012, China
> > TEL: +86+25-86630566-8568
> > COINS: 79988548
> > FAX: +86+25-83317685
> > MAIL: wangmy@fujitsu.com
> > http://www.fujitsu.com/cn/fnst/
> >
> > > -----Original Message-----
> > > From: Alexander Kanavin <alex.kanavin@gmail.com>
> > > Sent: Wednesday, March 23, 2022 4:40 PM
> > > To: Wang, Mingyu/王 鸣瑜 <wangmy@fujitsu.com>
> > > Cc: OE-core <openembedded-core@lists.openembedded.org>
> > > Subject: Re: [OE-core] [PATCH] rng-tools: enable macro
> > > JENT_CONF_ENABLE_INTERNAL_TIMER
> > >
> > > This error is not seen on the autobuilder, can you please check why
> > > it occurs only in your local setup? The macro probably needs to be
> > > enabled in a more targeted way.
> > >
> > > Alex
> > >
> > > On Wed, 23 Mar 2022 at 09:02, wangmy <wangmy@fujitsu.com> wrote:
> > > >
> > > > do_compile error :
> > > > | ../git/rngd_jitter.c: In function 'rngd_notime_start':
> > > > | ../git/rngd_jitter.c:56:45: error: invalid use of undefined type
> > > > | 'struct
> > > jent_notime_ctx'
> > > > |    56 |         ret =
> > > -pthread_attr_init(&thread_ctx->notime_pthread_attr);
> > > >
> > > > enable macro JENT_CONF_ENABLE_INTERNAL_TIMER to use struct
> > > > jent_notime_ctx
> > > >
> > > > Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
> > > > ---
> > > >  meta/recipes-support/rng-tools/rng-tools_6.15.bb | 2 ++
> > > >  1 file changed, 2 insertions(+)
> > > >
> > > > diff --git a/meta/recipes-support/rng-tools/rng-tools_6.15.bb
> > > > b/meta/recipes-support/rng-tools/rng-tools_6.15.bb
> > > > index ae974f9f6f..0696351903 100644
> > > > --- a/meta/recipes-support/rng-tools/rng-tools_6.15.bb
> > > > +++ b/meta/recipes-support/rng-tools/rng-tools_6.15.bb
> > > > @@ -34,6 +34,8 @@ INITSCRIPT_PARAMS = "start 03 2 3 4 5 . stop 30
> > > > 0 6
> > > 1 ."
> > > >
> > > >  SYSTEMD_SERVICE:${PN} = "rngd.service"
> > > >
> > > > +CFLAGS += " -DJENT_CONF_ENABLE_INTERNAL_TIMER "
> > > > +
> > > >  # Refer autogen.sh in rng-tools
> > > >  do_configure:prepend() {
> > > >      cp ${S}/README.md ${S}/README
> > > > --
> > > > 2.25.1
> > > >
> > > >
> > > > -=-=-=-=-=-=-=-=-=-=-=-
> > > > Links: You receive all messages sent to this group.
> > > > View/Reply Online (#163579):
> > > >
> > >
> https://lists.openembedded.org/g/openembedded-core/message/163579
> > > > Mute This Topic:
> > > > https://lists.openembedded.org/mt/89971134/1686489
> > > > Group Owner: openembedded-core+owner@lists.openembedded.org
> > > > Unsubscribe:
> > > https://lists.openembedded.org/g/openembedded-core/unsub
> > > > [alex.kanavin@gmail.com]
> > > > -=-=-=-=-=-=-=-=-=-=-=-
> > > >

Patch

diff --git a/meta/recipes-support/rng-tools/rng-tools_6.15.bb b/meta/recipes-support/rng-tools/rng-tools_6.15.bb
index ae974f9f6f..0696351903 100644
--- a/meta/recipes-support/rng-tools/rng-tools_6.15.bb
+++ b/meta/recipes-support/rng-tools/rng-tools_6.15.bb
@@ -34,6 +34,8 @@  INITSCRIPT_PARAMS = "start 03 2 3 4 5 . stop 30 0 6 1 ."
 
 SYSTEMD_SERVICE:${PN} = "rngd.service"
 
+CFLAGS += " -DJENT_CONF_ENABLE_INTERNAL_TIMER "
+
 # Refer autogen.sh in rng-tools
 do_configure:prepend() {
     cp ${S}/README.md ${S}/README