[4/9] python3-backports-functional-lru-cache: remove, not needed for Python 3

Message ID 20220310132523.2253188-4-ross.burton@arm.com
State New
Headers show
Series [1/9] packagegroup-meta-python: add poetry-core and unattended-upgrade | expand

Commit Message

Ross Burton March 10, 2022, 1:25 p.m. UTC
This is a backport of the Python 3 lru_cache for Python 2 users, so
obviously it makes no sense to have for Python 3.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 .../packagegroups/packagegroup-meta-python.bb |  2 --
 ...on3-backports-functools-lru-cache_1.6.4.bb | 31 -------------------
 2 files changed, 33 deletions(-)
 delete mode 100644 meta-python/recipes-devtools/python/python3-backports-functools-lru-cache_1.6.4.bb

Patch

diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
index 6eb803bd2a..66a11d2dd9 100644
--- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
+++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
@@ -46,7 +46,6 @@  RDEPENDS:packagegroup-meta-python3 = "\
     python3-aws-iot-device-sdk-python \
     python3-babel \
     python3-backcall \
-    python3-backports-functools-lru-cache \
     python3-bandit \
     python3-bcrypt \
     python3-beautifulsoup4 \
@@ -484,7 +483,6 @@  RDEPENDS:packagegroup-meta-python3-ptest = "\
     python3-markupsafe-ptest \
     python3-ansicolors-ptest \
     python3-appdirs-ptest \
-    python3-backports-functools-lru-cache-ptest \
     python3-bcrypt-ptest \
     python3-betamax-ptest \
     python3-blinker-ptest \
diff --git a/meta-python/recipes-devtools/python/python3-backports-functools-lru-cache_1.6.4.bb b/meta-python/recipes-devtools/python/python3-backports-functools-lru-cache_1.6.4.bb
deleted file mode 100644
index 392c044bfc..0000000000
--- a/meta-python/recipes-devtools/python/python3-backports-functools-lru-cache_1.6.4.bb
+++ /dev/null
@@ -1,31 +0,0 @@ 
-SUMMARY = "Backport of functools.lru_cache from Python 3.3"
-HOMEPAGE = "https://github.com/jaraco/backports.functools_lru_cache"
-SECTION = "devel/python"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=7a7126e068206290f3fe9f8d6c713ea6"
-
-PYPI_PACKAGE = "backports.functools_lru_cache"
-
-SRC_URI[sha256sum] = "d5ed2169378b67d3c545e5600d363a923b09c456dab1593914935a68ad478271"
-
-DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
-
-inherit pypi setuptools3 ptest
-
-SRC_URI += " \
-	file://run-ptest \
-"
-
-RDEPENDS:${PN}-ptest += " \
-	${PYTHON_PN}-pytest \
-"
-
-do_install_ptest() {
-	install -d ${D}${PTEST_PATH}/tests
-	cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
-}
-
-RDEPENDS:${PN} += "\
-    ${PYTHON_PN}-pickle \
-    ${PYTHON_PN}-threading \
-    "