[2/3] python3-pip: remove redundant DEPENDS on python3-setuptools-native

Message ID 20220310114035.2226442-2-ross.burton@arm.com
State Accepted, archived
Commit 5d514b5dbd09ce059047d849d5b7cc2b2327564d
Headers show
Series [1/3] pip_install_wheel: add a generic do_install for bootstrapping | expand

Commit Message

Ross Burton March 10, 2022, 11:40 a.m. UTC
This recipe inherits setuptools_build_meta which already depends on
python3-setuptools-native.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta/recipes-devtools/python/python3-pip_22.0.3.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Patch

diff --git a/meta/recipes-devtools/python/python3-pip_22.0.3.bb b/meta/recipes-devtools/python/python3-pip_22.0.3.bb
index f7fcf47c06..bce3b68861 100644
--- a/meta/recipes-devtools/python/python3-pip_22.0.3.bb
+++ b/meta/recipes-devtools/python/python3-pip_22.0.3.bb
@@ -6,7 +6,7 @@  LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=63ec52baf95163b597008bb46db68030"
 
 inherit pypi setuptools_build_meta
 
-DEPENDS += "python3 python3-setuptools-native"
+DEPENDS += "python3"
 
 # To avoid a dependency loop; we bootstrap -native
 DEPENDS:remove:class-native = "python3-pip-native"