[meta-oe/master/dylan] icon-slicer: fix native build by depending on gdk-pixbuf only

Submitted by Andreas Müller on May 22, 2013, 8:50 a.m.

Details

Message ID 1369212636-6760-1-git-send-email-schnitzeltony@googlemail.com
State Accepted, archived
Commit dd63dc5afda827649555a126c9225982f370ccb0
Headers show

Commit Message

Andreas Müller May 22, 2013, 8:50 a.m.
| checking for GDK_PIXBUF... no
| configure: error: GTK+-2.0 is required to compile icon-slicer
<...>
ERROR: Task 2643 (virtual:native:/home/andreas/data/oe-core/sources/meta-openembedded/meta-oe/recipes-devtools/icon-slicer/icon-slicer_0.3.bb, do_configure) failed with exit code '1'

Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
---
 .../icon-slicer/icon-slicer_0.3.bb                 |    3 +--
 1 files changed, 1 insertions(+), 2 deletions(-)

Patch hide | download patch | download mbox

diff --git a/meta-oe/recipes-devtools/icon-slicer/icon-slicer_0.3.bb b/meta-oe/recipes-devtools/icon-slicer/icon-slicer_0.3.bb
index b77fbf5..d6cfd35 100644
--- a/meta-oe/recipes-devtools/icon-slicer/icon-slicer_0.3.bb
+++ b/meta-oe/recipes-devtools/icon-slicer/icon-slicer_0.3.bb
@@ -1,8 +1,7 @@ 
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
 
-DEPENDS = "gtk+ popt"
-DEPENDS_class-native = "popt-native"
+DEPENDS = "gdk-pixbuf popt"
 
 SRC_URI = "http://freedesktop.org/software/${BPN}/releases/${BPN}-${PV}.tar.gz \
            file://0001-Makefile.am-no-examples.patch"

Comments

Eric BENARD May 28, 2013, 8:02 a.m.
Le Wed, 22 May 2013 10:50:36 +0200,
Andreas Müller <schnitzeltony@googlemail.com> a écrit :

> | checking for GDK_PIXBUF... no
> | configure: error: GTK+-2.0 is required to compile icon-slicer
> <...>
> ERROR: Task 2643 (virtual:native:/home/andreas/data/oe-core/sources/meta-openembedded/meta-oe/recipes-devtools/icon-slicer/icon-slicer_0.3.bb, do_configure) failed with exit code '1'
> 
> Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>

pushed to dylan-next, thanks
Eric