[6/7] python3-pyrsistent: use setuptools_build_meta

Message ID 20220308163206.4039089-6-ross.burton@arm.com
State Accepted, archived
Commit f2bac34088256d52354f4ec7ab3bd69a6812708f
Headers show
Series [1/7] python3-pip: clean up PYPA_WHEEL usage | expand

Commit Message

Ross Burton March 8, 2022, 4:32 p.m. UTC
This project builds with setuptools_build_meta, so use that instead.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta/recipes-devtools/python/python3-pyrsistent_0.18.1.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Patch

diff --git a/meta/recipes-devtools/python/python3-pyrsistent_0.18.1.bb b/meta/recipes-devtools/python/python3-pyrsistent_0.18.1.bb
index 4c9b8ec1dd..ecd55672f5 100644
--- a/meta/recipes-devtools/python/python3-pyrsistent_0.18.1.bb
+++ b/meta/recipes-devtools/python/python3-pyrsistent_0.18.1.bb
@@ -5,7 +5,7 @@  LIC_FILES_CHKSUM = "file://LICENSE.mit;md5=b695eb9c6e7a6fb1b1bc2d193c42776e"
 
 SRC_URI[sha256sum] = "d4d61f8b993a7255ba714df3aca52700f8125289f84f704cf80916517c46eb96"
 
-inherit pypi setuptools3
+inherit pypi setuptools_build_meta
 
 RDEPENDS:${PN} += " \
     ${PYTHON_PN}-numbers \