[6/6] python3-flit-core: improve recipe

Message ID 20220308143035.3569559-6-ross.burton@arm.com
State Accepted, archived
Commit ec8799eb92174cb6780a0cc7e1fa9828e4d75c79
Headers show
Series [1/6] flit_core: respect PIP_INSTALL_DIST_PATH | expand

Commit Message

Ross Burton March 8, 2022, 2:30 p.m. UTC
flit_core can bootstrap itself, so the python3-flit-core recipe can just
inherit flit_core and set PEP517_SOURCE_PATH to the flit_core submodule.

Also setting FILES:${PN} is redundant.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 .../python/python3-flit-core_3.7.1.bb          | 18 ++++--------------
 1 file changed, 4 insertions(+), 14 deletions(-)

Patch

diff --git a/meta/recipes-devtools/python/python3-flit-core_3.7.1.bb b/meta/recipes-devtools/python/python3-flit-core_3.7.1.bb
index f5e7506d5d..55ce256550 100644
--- a/meta/recipes-devtools/python/python3-flit-core_3.7.1.bb
+++ b/meta/recipes-devtools/python/python3-flit-core_3.7.1.bb
@@ -10,31 +10,22 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=41eb78fa8a872983a882c694a8305f08"
 
 SRC_URI[sha256sum] = "3c9bd9c140515bfe62dd938c6610d10d6efb9e35cc647fc614fe5fb3a5036682"
 
-inherit pip_install_wheel python3native python3-dir pypi setuptools3-base
+inherit pypi flit_core
 
+# Need to install by hand as there's a dependency loop
 DEPENDS:remove:class-native = " python3-pip-native"
 DEPENDS:append:class-native = " unzip-native"
 
 # We need the full flit tarball
 PYPI_PACKAGE = "flit"
-
+PEP517_SOURCE_PATH = "${S}/flit_core"
 PIP_INSTALL_PACKAGE = "flit_core"
-PIP_INSTALL_DIST_PATH = "${S}/flit_core/dist"
-
-do_compile () {
-    nativepython3 flit_core/build_dists.py
-}
 
 do_install:class-native () {
     install -d ${D}${PYTHON_SITEPACKAGES_DIR}
-    unzip -d ${D}${PYTHON_SITEPACKAGES_DIR} ./flit_core/dist/flit_core-${PV}-py3-none-any.whl
+    unzip -d ${D}${PYTHON_SITEPACKAGES_DIR} ${PIP_INSTALL_DIST_PATH}/flit_core*.whl
 }
 
-FILES:${PN} += "\
-    ${PYTHON_SITEPACKAGES_DIR}/flit_core/* \
-    ${PYTHON_SITEPACKAGES_DIR}/flit_core-${PV}.dist-info/* \
-"
-
 PACKAGES =+ "${PN}-tests"
 
 FILES:${PN}-tests += "\
@@ -42,4 +33,3 @@  FILES:${PN}-tests += "\
 "
 
 BBCLASSEXTEND = "native nativesdk"
-