[0/4] Multilib related postinstall fixes

Submitted by Laurentiu Palcu on April 25, 2013, 12:23 p.m.


Message ID cover.1366892003.git.laurentiu.palcu@intel.com
State New
Headers show


git://git.yoctoproject.org/poky-contrib lpalcu/ml_postinstall_fixes

Commit Message

Laurentiu Palcu April 25, 2013, 12:23 p.m.
There is still work to do on the multilib postinstalls running on host front.
This is a first patchset trying to address some of the issues.


The following changes since commit addcfcda84ed6b43b00f569a6060e3b78196ef52:

  glib-2.0: disable tests for native builds, and respect ptest for LSB (2013-04-23 13:00:43 +0100)

are available in the git repository at:

  git://git.yoctoproject.org/poky-contrib lpalcu/ml_postinstall_fixes

Laurentiu Palcu (4):
  qemuwrapper: use fallback in case the ELF binary is wrong
  pango: fix postinstall when using multilib
  Revert "qemu.bbclass: Use the correct qemu binary in multilib cases"
  scripts/postinst-intercepts: create separete hooks for multilib

 meta/classes/qemu.bbclass                          |    4 +--
 .../recipes-devtools/qemu/qemuwrapper-cross_1.0.bb |   28 +++++++++++++++++++-
 meta/recipes-graphics/pango/pango.inc              |    2 +-
 scripts/postinst-intercepts/postinst_intercept     |   18 +++++++++++++
 4 files changed, 47 insertions(+), 5 deletions(-)