augeas: allow empty augeas-lenses package

Submitted by Ting Liu on April 17, 2013, 8:42 a.m.

Details

Message ID 1366188175-29768-1-git-send-email-b28495@freescale.com
State New
Headers show

Commit Message

Ting Liu April 17, 2013, 8:42 a.m.
From: Ting Liu <b28495@freescale.com>

Fix the error when do_rootfs:
| Loading cache...
| Updating cache...               ######################################## [100%]
|
| Computing transaction...error: Can't install libaugeas0-1.0.0-r1@ppce500v2: no package provides augeas-lenses
|
| Saving cache...
|
| ERROR: Function failed: do_rootfs

augeas-lenses rpm is not generated due to no content:
$ ls tmp/deploy/rpm/ppce500v2/augeas-
augeas-1.0.0-r1.ppce500v2.rpm      augeas-dev-1.0.0-r1.ppce500v2.rpm
augeas-dbg-1.0.0-r1.ppce500v2.rpm  augeas-doc-1.0.0-r1.ppce500v2.rpm
$ ls tmp/work/ppce500v2-fsl_networking-linux-gnuspe/augeas/1.0.0-r1/packages-split/augeas-lenses/
$

Change-Id: I63b871fdbbd45f1c0b1b5605b342e62e1526c37b
Signed-off-by: Ting Liu <b28495@freescale.com>
---
 meta/recipes-extended/augeas/augeas.inc      |    3 +++
 meta/recipes-extended/augeas/augeas_1.0.0.bb |    2 +-
 2 files changed, 4 insertions(+), 1 deletions(-)

Patch hide | download patch | download mbox

diff --git a/meta/recipes-extended/augeas/augeas.inc b/meta/recipes-extended/augeas/augeas.inc
index c956621..49da973 100644
--- a/meta/recipes-extended/augeas/augeas.inc
+++ b/meta/recipes-extended/augeas/augeas.inc
@@ -29,3 +29,6 @@  LEAD_SONAME = "libaugeas.so"
 do_install_append() {
 	rm -fr ${D}${datadir}/vim
 }
+
+ALLOW_EMPTY_${PN}-lenses = "1" 
+
diff --git a/meta/recipes-extended/augeas/augeas_1.0.0.bb b/meta/recipes-extended/augeas/augeas_1.0.0.bb
index 82bda19..d898eea 100644
--- a/meta/recipes-extended/augeas/augeas_1.0.0.bb
+++ b/meta/recipes-extended/augeas/augeas_1.0.0.bb
@@ -1,6 +1,6 @@ 
 require augeas.inc
 
-PR = "r1"
+PR = "r2"
 
 SRC_URI[md5sum] = "82131019432ecf8102e1491610ad2dd1"
 SRC_URI[sha256sum] = "31bf757c5b8197765946b3805f3793c32b03cd92a7a77ec95d37e71a1f131912"

Comments

Richard Purdie April 17, 2013, 10:40 a.m.
On Wed, 2013-04-17 at 16:42 +0800, b28495@freescale.com wrote:
> From: Ting Liu <b28495@freescale.com>
> 
> Fix the error when do_rootfs:
> | Loading cache...
> | Updating cache...               ######################################## [100%]
> |
> | Computing transaction...error: Can't install libaugeas0-1.0.0-r1@ppce500v2: no package provides augeas-lenses
> |
> | Saving cache...
> |
> | ERROR: Function failed: do_rootfs
> 
> augeas-lenses rpm is not generated due to no content:
> $ ls tmp/deploy/rpm/ppce500v2/augeas-
> augeas-1.0.0-r1.ppce500v2.rpm      augeas-dev-1.0.0-r1.ppce500v2.rpm
> augeas-dbg-1.0.0-r1.ppce500v2.rpm  augeas-doc-1.0.0-r1.ppce500v2.rpm
> $ ls tmp/work/ppce500v2-fsl_networking-linux-gnuspe/augeas/1.0.0-r1/packages-split/augeas-lenses/
> $
> 
> Change-Id: I63b871fdbbd45f1c0b1b5605b342e62e1526c37b
> Signed-off-by: Ting Liu <b28495@freescale.com>
> ---
>  meta/recipes-extended/augeas/augeas.inc      |    3 +++
>  meta/recipes-extended/augeas/augeas_1.0.0.bb |    2 +-
>  2 files changed, 4 insertions(+), 1 deletions(-)
> 
> diff --git a/meta/recipes-extended/augeas/augeas.inc b/meta/recipes-extended/augeas/augeas.inc
> index c956621..49da973 100644
> --- a/meta/recipes-extended/augeas/augeas.inc
> +++ b/meta/recipes-extended/augeas/augeas.inc
> @@ -29,3 +29,6 @@ LEAD_SONAME = "libaugeas.so"
>  do_install_append() {
>  	rm -fr ${D}${datadir}/vim
>  }
> +
> +ALLOW_EMPTY_${PN}-lenses = "1" 
> +
> diff --git a/meta/recipes-extended/augeas/augeas_1.0.0.bb b/meta/recipes-extended/augeas/augeas_1.0.0.bb
> index 82bda19..d898eea 100644
> --- a/meta/recipes-extended/augeas/augeas_1.0.0.bb
> +++ b/meta/recipes-extended/augeas/augeas_1.0.0.bb
> @@ -1,6 +1,6 @@
>  require augeas.inc
>  
> -PR = "r1"
> +PR = "r2"
>  
>  SRC_URI[md5sum] = "82131019432ecf8102e1491610ad2dd1"
>  SRC_URI[sha256sum] = "31bf757c5b8197765946b3805f3793c32b03cd92a7a77ec95d37e71a1f131912"

Thanks for the warning about this but this isn't the right way to fix
it. The question is what happened to the files that should be there?

I've just sent out a patch which fixes this properly.

Cheers,

Richard