[v2,2/2] python3-meh: use setuptools_legacy

Message ID 20220307121818.1851345-2-ross.burton@arm.com
State New
Headers show
Series [v2,1/2] python3-meh: fix HOMEPAGE | expand

Commit Message

Ross Burton March 7, 2022, 12:18 p.m. UTC
This setup.py installs data_files with absolute paths, which isn't
supported by bdist_wheel.  Use setuptools_legacy as the legacy install
task needs to be used.

Also update patch status on the setuptools port.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 ...etup.py-switch-from-distutils-to-setuptools.patch |  3 +--
 .../python-meh/python3-meh_0.50.1.bb                 | 12 ++----------
 2 files changed, 3 insertions(+), 12 deletions(-)

Comments

Khem Raj March 7, 2022, 4:43 p.m. UTC | #1
this patch does not apply. Please rebase

On Mon, Mar 7, 2022 at 4:18 AM Ross Burton <ross@burtonini.com> wrote:
>
> This setup.py installs data_files with absolute paths, which isn't
> supported by bdist_wheel.  Use setuptools_legacy as the legacy install
> task needs to be used.
>
> Also update patch status on the setuptools port.
>
> Signed-off-by: Ross Burton <ross.burton@arm.com>
> ---
>  ...etup.py-switch-from-distutils-to-setuptools.patch |  3 +--
>  .../python-meh/python3-meh_0.50.1.bb                 | 12 ++----------
>  2 files changed, 3 insertions(+), 12 deletions(-)
>
> diff --git a/meta-python/recipes-extended/python-meh/python3-meh/0001-setup.py-switch-from-distutils-to-setuptools.patch b/meta-python/recipes-extended/python-meh/python3-meh/0001-setup.py-switch-from-distutils-to-setuptools.patch
> index b616b3fad3..2eb6be5a18 100644
> --- a/meta-python/recipes-extended/python-meh/python3-meh/0001-setup.py-switch-from-distutils-to-setuptools.patch
> +++ b/meta-python/recipes-extended/python-meh/python3-meh/0001-setup.py-switch-from-distutils-to-setuptools.patch
> @@ -9,8 +9,7 @@ In Python 3.10 'distutils' is deprecated with removal slated for Python
>  This also allows for a 'wheel' binary archive format to be built with
>  'setup.py bdist_wheel'.
>
> -Upstream-Status: Submitted
> -[https://github.com/rhinstaller/python-meh/pull/37]
> +Upstream-Status: Backport [cf9eafdd165347f86bb4a2534c41fd805db52322]
>
>  Signed-off-by: Tim Orling <tim.orling@konsulko.com>
>
> diff --git a/meta-python/recipes-extended/python-meh/python3-meh_0.50.1.bb b/meta-python/recipes-extended/python-meh/python3-meh_0.50.1.bb
> index 9f72b72623..1d9af438da 100644
> --- a/meta-python/recipes-extended/python-meh/python3-meh_0.50.1.bb
> +++ b/meta-python/recipes-extended/python-meh/python3-meh_0.50.1.bb
> @@ -5,7 +5,7 @@ HOMEPAGE = "https://github.com/rhinstaller/python-meh"
>  LICENSE = "GPL-2.0-or-later"
>  LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
>
> -inherit setuptools3
> +inherit setuptools3_legacy
>
>  S = "${WORKDIR}/git"
>
> @@ -14,12 +14,4 @@ SRC_URI = "git://github.com/rhinstaller/python-meh.git;protocol=https;branch=rhe
>            "
>  SRCREV = "c321ce22950aff76611a3c6beffa02b5ea3adbed"
>
> -PIP_INSTALL_PACKAGE = "python_meh"
> -
> -do_install:append () {
> -    install -d ${D}/${datadir}/python-meh
> -    mv ${D}${PYTHON_SITEPACKAGES_DIR}${datadir}/python-meh/* ${D}/${datadir}/python-meh/
> -}
> -
> -FILES:${PN} += "${datadir}/*"
> -
> +FILES:${PN} += "${datadir}/python-meh"
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#95852): https://lists.openembedded.org/g/openembedded-devel/message/95852
> Mute This Topic: https://lists.openembedded.org/mt/89610377/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>

Patch

diff --git a/meta-python/recipes-extended/python-meh/python3-meh/0001-setup.py-switch-from-distutils-to-setuptools.patch b/meta-python/recipes-extended/python-meh/python3-meh/0001-setup.py-switch-from-distutils-to-setuptools.patch
index b616b3fad3..2eb6be5a18 100644
--- a/meta-python/recipes-extended/python-meh/python3-meh/0001-setup.py-switch-from-distutils-to-setuptools.patch
+++ b/meta-python/recipes-extended/python-meh/python3-meh/0001-setup.py-switch-from-distutils-to-setuptools.patch
@@ -9,8 +9,7 @@  In Python 3.10 'distutils' is deprecated with removal slated for Python
 This also allows for a 'wheel' binary archive format to be built with
 'setup.py bdist_wheel'.
 
-Upstream-Status: Submitted
-[https://github.com/rhinstaller/python-meh/pull/37]
+Upstream-Status: Backport [cf9eafdd165347f86bb4a2534c41fd805db52322]
 
 Signed-off-by: Tim Orling <tim.orling@konsulko.com>
 
diff --git a/meta-python/recipes-extended/python-meh/python3-meh_0.50.1.bb b/meta-python/recipes-extended/python-meh/python3-meh_0.50.1.bb
index 9f72b72623..1d9af438da 100644
--- a/meta-python/recipes-extended/python-meh/python3-meh_0.50.1.bb
+++ b/meta-python/recipes-extended/python-meh/python3-meh_0.50.1.bb
@@ -5,7 +5,7 @@  HOMEPAGE = "https://github.com/rhinstaller/python-meh"
 LICENSE = "GPL-2.0-or-later"
 LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
 
-inherit setuptools3
+inherit setuptools3_legacy
 
 S = "${WORKDIR}/git"
 
@@ -14,12 +14,4 @@  SRC_URI = "git://github.com/rhinstaller/python-meh.git;protocol=https;branch=rhe
           "
 SRCREV = "c321ce22950aff76611a3c6beffa02b5ea3adbed"
 
-PIP_INSTALL_PACKAGE = "python_meh"
-
-do_install:append () {
-    install -d ${D}/${datadir}/python-meh
-    mv ${D}${PYTHON_SITEPACKAGES_DIR}${datadir}/python-meh/* ${D}/${datadir}/python-meh/
-}
-
-FILES:${PN} += "${datadir}/*"
-
+FILES:${PN} += "${datadir}/python-meh"