tcf-agent: Don't download epl-v10.html just for LIC_FILES_CHKSUM validation

Submitted by Martin Jansa on March 28, 2013, 9:54 p.m.

Details

Message ID 1364507667-26360-1-git-send-email-Martin.Jansa@gmail.com
State Accepted
Commit 22bce79652fc753a7b5d536664b744e110b5775a
Headers show

Commit Message

Martin Jansa March 28, 2013, 9:54 p.m.
* it's not part of sources, downloading some html from web is not better
  check then using meta/files/common-licenses/EPL-1.0
* http://www.eclipse.org/org/documents/epl-v10.html was changed, plain
  text looks the same, but html formating was changed (from MS Word
  export to valid XHTML 1.0, changing checksums for this new html
  would cause issues for people with old epl-v10.html already on
  PREMIRROR, so lets just remove it.
---
 meta/recipes-devtools/tcf-agent/tcf-agent_git.bb | 7 +------
 1 file changed, 1 insertion(+), 6 deletions(-)

Patch hide | download patch | download mbox

diff --git a/meta/recipes-devtools/tcf-agent/tcf-agent_git.bb b/meta/recipes-devtools/tcf-agent/tcf-agent_git.bb
index 25fccaf..4d43c62 100644
--- a/meta/recipes-devtools/tcf-agent/tcf-agent_git.bb
+++ b/meta/recipes-devtools/tcf-agent/tcf-agent_git.bb
@@ -3,22 +3,17 @@  HOMEPAGE = "http://wiki.eclipse.org/TCF"
 BUGTRACKER = "https://bugs.eclipse.org/bugs/"
 
 LICENSE = "EPL-1.0 | EDL-1.0"
-LIC_FILES_CHKSUM = "file://../epl-v10.html;md5=7aa4215a330a0a4f6a1cbf8da1a0879f \
-                    file://edl-v10.html;md5=522a390a83dc186513f0500543ad3679"
+LIC_FILES_CHKSUM = "file://edl-v10.html;md5=522a390a83dc186513f0500543ad3679"
 
 SRCREV = "4ef94ecb927a8912c3d79ce137182247786cff8f"
 PV = "0.4.0+git${SRCPV}"
 PR = "r0"
 
 SRC_URI = "git://git.eclipse.org/gitroot/tcf/org.eclipse.tcf.agent.git;protocol=git \
-           http://www.eclipse.org/legal/epl-v10.html;name=epl \
            file://fix_ranlib.patch \
            file://fix_tcf-agent.init.patch \
           "
 
-SRC_URI[epl.md5sum] = "7aa4215a330a0a4f6a1cbf8da1a0879f"
-SRC_URI[epl.sha256sum] = "4fd64aeed340d62a64a8da4b371efe0f6d0d745f4d2dbefacba86c646d36bc72"
-
 DEPENDS = "util-linux openssl"
 RDEPENDS_${PN} = "bash"