[meta-python,4/9] python3-pkconfig: inherit poetry_core

Message ID 20220301203354.3839755-4-tim.orling@konsulko.com
State New
Headers show
Series [meta-python,1/9] python3-poetry-core: add v1.0.8 | expand

Commit Message

Tim Orling March 1, 2022, 8:33 p.m. UTC
Use PEP-517 build-backend instead of setuptools3.

Signed-off-by: Tim Orling <tim.orling@konsulko.com>
---
 meta-python/recipes-devtools/python/python3-pkgconfig_1.5.5.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Khem Raj March 2, 2022, 1:19 a.m. UTC | #1
typo in subject line but I fixed it in master-next

On Tue, Mar 1, 2022 at 12:34 PM Tim Orling <ticotimo@gmail.com> wrote:
>
> Use PEP-517 build-backend instead of setuptools3.
>
> Signed-off-by: Tim Orling <tim.orling@konsulko.com>
> ---
>  meta-python/recipes-devtools/python/python3-pkgconfig_1.5.5.bb | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/meta-python/recipes-devtools/python/python3-pkgconfig_1.5.5.bb b/meta-python/recipes-devtools/python/python3-pkgconfig_1.5.5.bb
> index 2d68a78e37..c5a74796a0 100644
> --- a/meta-python/recipes-devtools/python/python3-pkgconfig_1.5.5.bb
> +++ b/meta-python/recipes-devtools/python/python3-pkgconfig_1.5.5.bb
> @@ -10,7 +10,7 @@ RDEPENDS:${PN} = "pkgconfig \
>                   ${PYTHON_PN}-shell \
>                   "
>
> -inherit pypi setuptools3
> +inherit pypi poetry_core
>
>  BBCLASSEXTEND = "native"
>
> --
> 2.30.2
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#95651): https://lists.openembedded.org/g/openembedded-devel/message/95651
> Mute This Topic: https://lists.openembedded.org/mt/89486858/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Tim Orling March 2, 2022, 1:20 a.m. UTC | #2
On Tue, Mar 1, 2022 at 5:19 PM Khem Raj <raj.khem@gmail.com> wrote:

> typo in subject line but I fixed it in master-next
>

Grr. I think I need to see the eye doctor again

>
> On Tue, Mar 1, 2022 at 12:34 PM Tim Orling <ticotimo@gmail.com> wrote:
> >
> > Use PEP-517 build-backend instead of setuptools3.
> >
> > Signed-off-by: Tim Orling <tim.orling@konsulko.com>
> > ---
> >  meta-python/recipes-devtools/python/python3-pkgconfig_1.5.5.bb | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > diff --git a/meta-python/recipes-devtools/python/
> python3-pkgconfig_1.5.5.bb b/meta-python/recipes-devtools/python/
> python3-pkgconfig_1.5.5.bb
> > index 2d68a78e37..c5a74796a0 100644
> > --- a/meta-python/recipes-devtools/python/python3-pkgconfig_1.5.5.bb
> > +++ b/meta-python/recipes-devtools/python/python3-pkgconfig_1.5.5.bb
> > @@ -10,7 +10,7 @@ RDEPENDS:${PN} = "pkgconfig \
> >                   ${PYTHON_PN}-shell \
> >                   "
> >
> > -inherit pypi setuptools3
> > +inherit pypi poetry_core
> >
> >  BBCLASSEXTEND = "native"
> >
> > --
> > 2.30.2
> >
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#95651):
> https://lists.openembedded.org/g/openembedded-devel/message/95651
> > Mute This Topic: https://lists.openembedded.org/mt/89486858/1997914
> > Group Owner: openembedded-devel+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [
> raj.khem@gmail.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
>

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pkgconfig_1.5.5.bb b/meta-python/recipes-devtools/python/python3-pkgconfig_1.5.5.bb
index 2d68a78e37..c5a74796a0 100644
--- a/meta-python/recipes-devtools/python/python3-pkgconfig_1.5.5.bb
+++ b/meta-python/recipes-devtools/python/python3-pkgconfig_1.5.5.bb
@@ -10,7 +10,7 @@  RDEPENDS:${PN} = "pkgconfig \
                  ${PYTHON_PN}-shell \
                  "
 
-inherit pypi setuptools3
+inherit pypi poetry_core
 
 BBCLASSEXTEND = "native"