[meta-python] python3-gcovr: fix wheel build

Message ID 20220301165418.11653-1-jsbronder@cold-front.org
State New
Headers show
Series [meta-python] python3-gcovr: fix wheel build | expand

Commit Message

Justin Bronder March 1, 2022, 4:54 p.m. UTC
Recipe does not inherit pypi nor would PN be a good guess at the name of
the wheel. Set PIP_INSTALL_PACKAGE appropriately.

Signed-off-by: Justin Bronder <jsbronder@cold-front.org>
---
 meta-python/recipes-devtools/python/python3-gcovr_5.0.bb | 1 +
 1 file changed, 1 insertion(+)

Patch

diff --git a/meta-python/recipes-devtools/python/python3-gcovr_5.0.bb b/meta-python/recipes-devtools/python/python3-gcovr_5.0.bb
index 330831a0b3..27ae198139 100644
--- a/meta-python/recipes-devtools/python/python3-gcovr_5.0.bb
+++ b/meta-python/recipes-devtools/python/python3-gcovr_5.0.bb
@@ -10,6 +10,7 @@  SRCREV = "2b50284e8a6792b4ddcba14e2050c5c05f15deb6"
 S = "${WORKDIR}/git"
 
 inherit setuptools3
+PIP_INSTALL_PACKAGE = "gcovr"
 
 RDEPENDS:${PN} += "${PYTHON_PN}-jinja2 ${PYTHON_PN}-lxml ${PYTHON_PN}-setuptools ${PYTHON_PN}-pygments"