[meta-python,3/3] python3-qface: add recipe

Message ID 20220301093355.2746877-3-samuli.piippo@qt.io
State New
Headers show
Series [meta-python,1/3] python3-path: add recipe | expand

Commit Message

Samuli Piippo March 1, 2022, 9:33 a.m. UTC
Signed-off-by: Samuli Piippo <samuli.piippo@qt.io>
---
 .../python/python3-qface_2.0.6.bb             | 24 +++++++++++++++++++
 1 file changed, 24 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-qface_2.0.6.bb

Patch

diff --git a/meta-python/recipes-devtools/python/python3-qface_2.0.6.bb b/meta-python/recipes-devtools/python/python3-qface_2.0.6.bb
new file mode 100644
index 000000000..6b47564ff
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-qface_2.0.6.bb
@@ -0,0 +1,24 @@ 
+SUMMARY = "A generator framework based on a common modern IDL"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=eee61e10a40b0e3045ee5965bcd9a8b5"
+
+SRC_URI[sha256sum] = "87ce8ce7123ae57d91ac903c6c330a99273e7f4665a0ab88e6a17f9c98143a68"
+
+inherit pypi setuptools_build_meta
+
+DEPS = "\
+    python3-jinja2 \
+    python3-click \
+    python3-pyyaml \
+    python3-pytest \
+    python3-six \
+    python3-path \
+    python3-antrl4-runtime \
+    python3-watchdog \
+    python3-markupsafe \
+    python3-setuptools \
+"
+DEPENDS += "${DEPS}"
+RDEPENDS:${PN} += "${DEPS}"
+
+BBCLASSEXTEND = "nativesdk native"