[meta-networking,1/3] python3-scapy: Define custom PYPA_WHEEL

Message ID 20220228222154.210195-1-raj.khem@gmail.com
State New
Headers show
Series [meta-networking,1/3] python3-scapy: Define custom PYPA_WHEEL | expand

Commit Message

Khem Raj Feb. 28, 2022, 10:21 p.m. UTC
Standard defaults are not able to guess it right, so aid it a bit

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta-networking/recipes-devtools/python/python3-scapy_2.4.5.bb | 2 ++
 1 file changed, 2 insertions(+)

Patch

diff --git a/meta-networking/recipes-devtools/python/python3-scapy_2.4.5.bb b/meta-networking/recipes-devtools/python/python3-scapy_2.4.5.bb
index d318c27c5a..3a1f102dc9 100644
--- a/meta-networking/recipes-devtools/python/python3-scapy_2.4.5.bb
+++ b/meta-networking/recipes-devtools/python/python3-scapy_2.4.5.bb
@@ -25,6 +25,8 @@  S = "${WORKDIR}/git"
 UPSTREAM_CHECK_COMMITS = "1"
 
 inherit setuptools3 ptest
+PIP_INSTALL_PACKAGE = "scapy"
+PYPA_WHEEL = "${PIP_INSTALL_DIST_PATH}/${PIP_INSTALL_PACKAGE}-*-*.whl"
 
 do_install:append() {
         mv ${D}${bindir}/scapy ${D}${bindir}/scapy3