[meta-python] python3-pybind11: Override pip install variables

Message ID 20220228182956.2955678-1-tom.hochstein@nxp.com
State New
Headers show
Series [meta-python] python3-pybind11: Override pip install variables | expand

Commit Message

Tom Hochstein Feb. 28, 2022, 6:29 p.m. UTC
Fix the pip install variables since the default values don't work
here.

Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
---
 meta-python/recipes-devtools/python/python3-pybind11_2.8.1.bb | 3 +++
 1 file changed, 3 insertions(+)

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pybind11_2.8.1.bb b/meta-python/recipes-devtools/python/python3-pybind11_2.8.1.bb
index dfacb41f1..4d94e2033 100644
--- a/meta-python/recipes-devtools/python/python3-pybind11_2.8.1.bb
+++ b/meta-python/recipes-devtools/python/python3-pybind11_2.8.1.bb
@@ -19,6 +19,9 @@  EXTRA_OECMAKE =  "-DPYBIND11_TEST=OFF"
 
 inherit cmake setuptools3 python3native
 
+PIP_INSTALL_DIST_PATH = "${S}/dist"
+PIP_INSTALL_PACKAGE = "pybind11"
+
 do_configure() {
 	cmake_do_configure
 }