python3-marshmallow: fix wheel build

Message ID 20220228155234.1053650-1-troth@openavr.org
State New
Headers show
Series python3-marshmallow: fix wheel build | expand

Commit Message

Theodore A. Roth Feb. 28, 2022, 3:52 p.m. UTC
Recipe does not inherit pypi nor would PN be a good guess at the name of
the wheel. Set PIP_INSTALL_PACKAGE appropriately.

Signed-off-by: Theodore A. Roth <theodore_roth@trimble.com>
Signed-off-by: Theodore A. Roth <troth@openavr.org>
---
 .../recipes-devtools/python/python3-marshmallow_3.14.1.bb       | 2 ++
 1 file changed, 2 insertions(+)

Comments

Tim Orling Feb. 28, 2022, 4:03 p.m. UTC | #1
On Mon, Feb 28, 2022 at 7:52 AM Theodore A. Roth <troth@openavr.org> wrote:

> Recipe does not inherit pypi nor would PN be a good guess at the name of
> the wheel. Set PIP_INSTALL_PACKAGE appropriately.
>
> Signed-off-by: Theodore A. Roth <theodore_roth@trimble.com>
> Signed-off-by: Theodore A. Roth <troth@openavr.org>
>
Reviewed-by: TIm Orling <tim.orling@konsulko.com>

> ---
>  .../recipes-devtools/python/python3-marshmallow_3.14.1.bb       | 2 ++
>  1 file changed, 2 insertions(+)
>
> diff --git a/meta-python/recipes-devtools/python/
> python3-marshmallow_3.14.1.bb b/meta-python/recipes-devtools/python/
> python3-marshmallow_3.14.1.bb
> index ddfe4b99c..dc5f17388 100644
> --- a/meta-python/recipes-devtools/python/python3-marshmallow_3.14.1.bb
> +++ b/meta-python/recipes-devtools/python/python3-marshmallow_3.14.1.bb
> @@ -15,4 +15,6 @@ S = "${WORKDIR}/git"
>
>  inherit setuptools3
>
> +PIP_INSTALL_PACKAGE = "marshmallow"
> +
>  RDEPENDS:${PN} += "python3-core"
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#95584):
> https://lists.openembedded.org/g/openembedded-devel/message/95584
> Mute This Topic: https://lists.openembedded.org/mt/89453269/924729
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [
> ticotimo@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>

Patch

diff --git a/meta-python/recipes-devtools/python/python3-marshmallow_3.14.1.bb b/meta-python/recipes-devtools/python/python3-marshmallow_3.14.1.bb
index ddfe4b99c..dc5f17388 100644
--- a/meta-python/recipes-devtools/python/python3-marshmallow_3.14.1.bb
+++ b/meta-python/recipes-devtools/python/python3-marshmallow_3.14.1.bb
@@ -15,4 +15,6 @@  S = "${WORKDIR}/git"
 
 inherit setuptools3
 
+PIP_INSTALL_PACKAGE = "marshmallow"
+
 RDEPENDS:${PN} += "python3-core"