[meta-security] python3-fail2ban: Migrate to use wheels.

Message ID 20220228000816.12012-1-akuster808@gmail.com
State New
Headers show
Series [meta-security] python3-fail2ban: Migrate to use wheels. | expand

Commit Message

akuster808 Feb. 28, 2022, 12:08 a.m. UTC
This package uses 2to3 so need to call build-it ourselves.

Signed-off-by: Armin Kuster <akuster808@gmail.com>
---
 recipes-security/fail2ban/python3-fail2ban_0.11.2.bb | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

Patch

diff --git a/recipes-security/fail2ban/python3-fail2ban_0.11.2.bb b/recipes-security/fail2ban/python3-fail2ban_0.11.2.bb
index f6394cc..93bc3a7 100644
--- a/recipes-security/fail2ban/python3-fail2ban_0.11.2.bb
+++ b/recipes-security/fail2ban/python3-fail2ban_0.11.2.bb
@@ -15,13 +15,17 @@  SRC_URI = " git://github.com/fail2ban/fail2ban.git;branch=0.11;protocol=https \
         file://run-ptest \
 "
 
-inherit update-rc.d ptest setuptools3
+inherit update-rc.d ptest setuptools_build_meta
+
+PIP_INSTALL_PACKAGE = "fail2ban"
+PYPA_WHEEL = "${PIP_INSTALL_DIST_PATH}/${PIP_INSTALL_PACKAGE}-${PV}-*.whl"
 
 S = "${WORKDIR}/git"
 
 do_compile () {
     cd ${S}
     ./fail2ban-2to3
+    nativepython3 ${S}/build-it.py
 }
 
 do_install:append () {