[meta-oe,1/6] python3-apt: Point PYPA_WHEEL to custom location

Message ID 20220227075848.610467-1-raj.khem@gmail.com
State New
Headers show
Series [meta-oe,1/6] python3-apt: Point PYPA_WHEEL to custom location | expand

Commit Message

Khem Raj Feb. 27, 2022, 7:58 a.m. UTC
Standard deduction logic does not work so help the system a bit

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta-oe/recipes-devtools/python/python3-apt_2.3.0.bb | 2 ++
 1 file changed, 2 insertions(+)

Patch

diff --git a/meta-oe/recipes-devtools/python/python3-apt_2.3.0.bb b/meta-oe/recipes-devtools/python/python3-apt_2.3.0.bb
index 6463f49bb5..183836f406 100644
--- a/meta-oe/recipes-devtools/python/python3-apt_2.3.0.bb
+++ b/meta-oe/recipes-devtools/python/python3-apt_2.3.0.bb
@@ -10,6 +10,8 @@  SRCREV = "6145b6484d220685edfd922d364afbf065127efe"
 S = "${WORKDIR}/git"
 
 inherit setuptools3
+PIP_INSTALL_PACKAGE = "python_apt"
+PYPA_WHEEL = "${PIP_INSTALL_DIST_PATH}/${PIP_INSTALL_PACKAGE}-0.0.0-*.whl"
 
 DEPENDS += "apt"
 RDEPENDS:${PN} += "apt python3-core"