diff mbox series

[3/3] Revert "arm-bsp/corstone1000-flash-firmware-image: add nopt generation"

Message ID 20240423182517.2590896-3-jon.mason@arm.com
State New
Headers show
Series [1/3] Revert "arm-bsp/documentation: corstone1000: update capsule generation steps" | expand

Commit Message

Jon Mason April 23, 2024, 6:25 p.m. UTC
This reverts commit e6ff022d6d3d6cbcbd9b30006a75be69f7d35c29.
---
 .../images/corstone1000-flash-firmware-image.bb | 17 -----------------
 1 file changed, 17 deletions(-)
diff mbox series

Patch

diff --git a/meta-arm-bsp/recipes-bsp/images/corstone1000-flash-firmware-image.bb b/meta-arm-bsp/recipes-bsp/images/corstone1000-flash-firmware-image.bb
index 5238d1d34fff..73fc17664d87 100644
--- a/meta-arm-bsp/recipes-bsp/images/corstone1000-flash-firmware-image.bb
+++ b/meta-arm-bsp/recipes-bsp/images/corstone1000-flash-firmware-image.bb
@@ -38,11 +38,6 @@  RE_LAYOUT_WRAPPER_VERSION = "0.0.7"
 TFM_SIGN_PRIVATE_KEY = "${libdir}/tfm-scripts/root-RSA-3072_1.pem"
 RE_IMAGE_OFFSET = "0x1000"
 
-# Offsets for the .nopt image generation
-TFM_OFFSET = "102400"
-FIP_OFFSET = "479232"
-KERNEL_OFFSET = "2576384"
-
 do_sign_images() {
     # Sign TF-A BL2
     sign_host_image ${RECIPE_SYSROOT}/firmware/${TFA_BL2_BINARY} \
@@ -61,15 +56,3 @@  do_sign_images() {
 do_sign_images[depends] = "\
     fiptool-native:do_populate_sysroot \
     "
-
-# This .nopt image is not the same as the one which is generated by meta-arm/meta-arm/classes/wic_nopt.bbclass.
-# The meta-arm/meta-arm/classes/wic_nopt.bbclass removes the partition table from the wic image, but keeps the
-# second bank. This function creates a no-partition image with only the first bank.
-create_nopt_image() {
-    dd conv=notrunc bs=1 if=${DEPLOY_DIR_IMAGE}/bl2_signed.bin of=${B}/${MACHINE}_image.nopt
-    dd conv=notrunc bs=1 if=${DEPLOY_DIR_IMAGE}/tfm_s_signed.bin of=${B}/${MACHINE}_image.nopt seek=${TFM_OFFSET}
-    dd conv=notrunc bs=1 if=${DEPLOY_DIR_IMAGE}/signed_fip-corstone1000.bin of=${B}/${MACHINE}_image.nopt seek=${FIP_OFFSET}
-    dd conv=notrunc bs=1 if=${DEPLOY_DIR_IMAGE}/Image.gz-initramfs-${MACHINE}.bin of=${B}/${MACHINE}_image.nopt seek=${KERNEL_OFFSET}
-}
-create_nopt_image[depends] += "mc:firmware:linux-yocto:do_deploy"
-do_image_uefi_capsule[prefuncs] += "create_nopt_image"